Results 1 to 5 of 5

93 firebird quits running, dies, going down the road

This is a discussion on 93 firebird quits running, dies, going down the road within the LT1 forums, part of the Vehicle Specific category; I have a 93 firebird, with the LT1 auto trans, it runs great at first then 5 or 10 miles ...

  1. #1
    Junior Member
    Join Date
    Jul 2013
    Location
    corinth, ms
    Posts
    5

    red
    93 firebird, LT1, auto

    93 firebird quits running, dies, going down the road

    I have a 93 firebird, with the LT1 auto trans, it runs great at first then 5 or 10 miles along it dies, just shuts off. have checked fuel pressure, 43 lbs. changed icm, coil, when it dies it has no fire going to plugs when you turn it over, fuel pressure is 42 or 43. let it set 10 min it will crank up and go again. It may go a mile or 10 but it will do it again. Just bought car figure thats why he sold it, it has 90,000 miles and is un molested bone stock, for now,

  2. #2
    Waiting on the Tree transamtom's Avatar
    Join Date
    Jul 2005
    Location
    Niagara Falls Ont.Canada
    Posts
    927

    NBM
    1999 TA A4

    Check your EGR valve on the back of the intake manifold,if its not functioning properly it will cause similar problems.
    2010 Camaro SIM 2SS/RS A6
    1999 TA A4 NBM
    12.265 at 110.52mph

  3. #3
    Junior Member
    Join Date
    Jul 2013
    Location
    corinth, ms
    Posts
    5

    red
    93 firebird, LT1, auto

    checked egr seems ok stumbles when pressed in thanks, im at the point ill try anything

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    is that 90k on the opti-spark too?

  5. #5
    Junior Member
    Join Date
    Jul 2013
    Location
    corinth, ms
    Posts
    5

    red
    93 firebird, LT1, auto

    Quote Originally Posted by SMWS6TA View Post
    is that 90k on the opti-spark too?
    opti spark and water pump look new no moisture on or around opti-spark, cranks perfect, runs strong no misses or sputters. when it quits i have no fire to plugwires i hook my timing light to number 1 plug wire n turn it over. i have changed coil n ignition modgule. fuel pump has been changed someonee made a trap door. whhen it quits it can be any speed it just shuts off no warning no power loss no miss

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1976 Pontiac Firebird Formula - Road-Ready Resurrection
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 09-17-2012, 10:01 PM
  2. Another Firebird back on the road
    By Justin23454 in forum Firebird / WS6
    Replies: 5
    Last Post: 11-09-2010, 07:19 AM
  3. quits running on top end
    By whiskers in forum Internal Engine
    Replies: 10
    Last Post: 05-01-2010, 01:13 PM
  4. Road/Cone Course @ Firebird Jan 9th 2010 - AZ
    By chellzers in forum Western Members
    Replies: 4
    Last Post: 12-16-2009, 08:14 AM
  5. Question: 95 Bird Quits Running
    By puppypounder in forum General Help
    Replies: 6
    Last Post: 06-02-2009, 09:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •