Page 1 of 4 1234 LastLast
Results 1 to 20 of 71

383 Stroker Problems

This is a discussion on 383 Stroker Problems within the LT1 forums, part of the Vehicle Specific category; Well i built the motor 7k miles ago, Just took the motor out and installed The Lt4 hotcam Kit, Headers ...

  1. #1
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    383 Stroker Problems

    Well i built the motor 7k miles ago, Just took the motor out and installed The Lt4 hotcam Kit, Headers and I was on the Way to the Exhaust Shop and Didnt get 40 miles before what seems to be a Broke Crank or broke Main cap, Front seal blew out of the timing cover, The Belt is running of towards the front, Lost all oil pressure and I can move the front of the crank 1/2 inch in any direction with a bar. Anyone Ever had a Problem with Eagle Cranks Breaking?

  2. #2
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    Well thats eagle's quality for you.
    Srry to hear that man but Eagle doesnt make that great of cranks, the cheapest good one you can get is Scat. Then next step up is the compstar


    300RWHP, 341RWTQ
    1/8 mile 8.32 at 83.97
    1/4 mile 13.049 at 105.24

  3. #3
    Member cailey37's Avatar
    Join Date
    Mar 2006
    Location
    Mississippi
    Posts
    832

    Silver
    1998 Pontiac Trans Am

    I've got a LT1 383 in a Fiero and I haven't had one problem with the Eagle Crank.....

  4. #4
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    ya its just my luck lol!! i didnt pick the crank, my machinist did the picking.

    we had a problem with the first crank eagle sent us, it wouldnt balance so they hand picked this one that were running which balanced nice. My machinist sayys he has never had a problem out of eagle, but doesnt mean i didnt get a bad one.

    but im still not 100% the crank is broke, it could just as easily be a main cap broke which is even worse cause then the block is trashed.

    but im pulling it back out this weekend to get full details of the damage.

  5. #5
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Are you sure it is the front of the crank or the balancer you are moving? Maybe you broke the balancer bolt.

  6. #6
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    Well I would consider a Broke bolt except that doesnt explain all the metal shavings in the oil Im afraid its pretty serious. ill know for sure friday night when I get a chance to pull it.

  7. #7
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    Man I am sorry.
    I hope its not too serious.

  8. #8
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    well im just hoping its not ruined the block.

  9. #9
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    Well I pulled the motor tonight and this is what I found:


    Crank Snapped clean in half!! right before rod number 1.

    Anyone seen this happen?

  10. #10
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    I've seen them break, but typically more towards the snout. Must have been a bad one. that sucks

  11. #11
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    Ya well Eagle is getting a call Bright n early Monday Morning. Hopefully I can get a new crank and Bearings out of the deal!! They should also pay me for my time and labor and now the machine work thats gotta be done again!!

    I dunno about u guys but im loving these Cheap ass parts now days. The materials and Metals are getting worse n worse. I Don't see how anyone could make a living building motors with all the bad parts floating around.

  12. #12
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    yea thats eagle for ya.
    But I really hope they give you a new one and pay you as well. I would be pissed.
    While on the phone ask them "isnt the cranks suppose to be forged 4340 the highest grade of steel?"

  13. #13
    Member moesplace's Avatar
    Join Date
    May 2007
    Location
    fl
    Posts
    120

    black
    1999 pontiac T/A WS-6

    Sorry to here that sucks out side of defects what can cause it has any one seen cranks brake like that my brothers truck crank broke the same way stock 5.7 vortec motor driveing down the X at 70

  14. #14
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Quote Originally Posted by Sleeper101 View Post
    Ya well Eagle is getting a call Bright n early Monday Morning. Hopefully I can get a new crank and Bearings out of the deal!! They should also pay me for my time and labor and now the machine work thats gotta be done again!!

    I dunno about u guys but im loving these Cheap ass parts now days. The materials and Metals are getting worse n worse. I Don't see how anyone could make a living building motors with all the bad parts floating around.
    Well, Eagle stuff is made in China. I wouldnt buy it just for that reason alone. just my opinion

  15. #15
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    Well I tore the motor the rest of the way down today.Found out it completely trashed the block. The number 1 main cap bearing wore the Block Slap out. none fixable.

    Here is some more pics of the damage:








    This was not a 4340 forged crank. it was the cast crank 600hp rated.

    Looks like time for a new block and a 4340 forged crank 1000hp.

  16. #16
    Senior Member 5.0THIS's Avatar
    Join Date
    Oct 2001
    Location
    Colorado
    Posts
    3,704

    red
    95 Z28

    Man that sucks... Might look into Lunati or Callies.

  17. #17
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    Ya it sucks bad!! Im going to se what Eagle says and see if they make it right or not. Im sure it will not come out my way tho.

  18. #18
    Kenne-Bell Killer Cayenne97's Avatar
    Join Date
    Oct 2007
    Location
    Lake Tahoe, CA
    Posts
    609

    Cayenne Red, Pewter
    '97 Z28 1LE #53, '02 WS6

    Sorry to hear about that man. I can honestly say that I have heard negative feedback on Eagle cranks, but never used one. I have a SCAT Forged 4340 in my car that has seen numerous passes down the track with no issues. The best of luck to you.
    97 Z28 1LE #53 11.08/122.84 N/A, 9.82/131.06 150-shot

    02 WS6 M6, STOCK H/C/I, 3189 lbs., 11.77/113.02 (1.59 60')

    08 Mercedez C63 AMG, FOR SALE!!!
    http://www.ls1.com/forums/f38/2008-mercedez-c63-amg-108586/

  19. #19
    Senior Member Sleeper101's Avatar
    Join Date
    Oct 2007
    Location
    Springcity
    Posts
    1,152

    Red
    Vette,240sx,ls1 camaro

    well if eagle decides to screw me im going to give that scat forged crank a try. ive been hearing alot of good feedback on it.

    anyone know were i can find a bare block at? would be nice to find a bare .030 over block already setup for the 383 crank. But i can work with a bare stock block.

  20. #20
    Kenne-Bell Killer Cayenne97's Avatar
    Join Date
    Oct 2007
    Location
    Lake Tahoe, CA
    Posts
    609

    Cayenne Red, Pewter
    '97 Z28 1LE #53, '02 WS6

    I got my bare block for my '97 Z28 project from Allen Motorsports in Texas. High quality product at a very reasonable price. I got mine in a .030" bore and have a SCAT forged 3.48" crank going inside.

    Here is a link to their e-bay site:
    http://cgi.ebay.com/ebaymotors/LT1-S...mZ270209326432

Page 1 of 4 1234 LastLast

LinkBacks (?)

  1. 07-26-2016, 01:25 PM
  2. 09-19-2015, 10:41 PM
  3. 11-19-2014, 02:31 AM
  4. 04-10-2013, 03:03 PM
  5. 05-24-2012, 12:38 PM
  6. 04-14-2012, 09:24 AM
  7. 03-21-2012, 05:08 PM
  8. 02-25-2012, 10:54 AM
  9. 02-23-2012, 04:41 PM
  10. 02-11-2012, 08:39 PM
  11. 01-05-2012, 07:22 PM
  12. 12-21-2011, 05:59 PM
  13. 12-15-2011, 06:36 AM
  14. 11-29-2011, 08:37 AM
  15. 11-28-2011, 06:10 AM
  16. 11-22-2011, 11:32 AM
  17. 11-18-2011, 07:25 PM
  18. 10-30-2011, 01:32 PM
  19. 10-27-2011, 10:39 AM
  20. 10-21-2011, 06:05 PM
  21. 10-21-2011, 11:51 AM
  22. 10-16-2011, 08:30 PM
  23. 10-10-2011, 02:13 AM
  24. 10-07-2011, 08:08 AM
  25. 09-15-2011, 05:40 PM
  26. 09-07-2011, 01:32 PM
  27. 08-25-2011, 10:54 AM
  28. 08-25-2011, 10:22 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. problems with my slp 402 stroker
    By donrey007 in forum General Help
    Replies: 11
    Last Post: 07-26-2008, 09:03 AM
  2. Replies: 10
    Last Post: 06-26-2007, 11:56 AM
  3. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 07:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •