Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Whats wrong?

This is a discussion on Whats wrong? within the Firebird / WS6 forums, part of the Vehicle Specific category; I stopped at a stoplight earlier today and for some odd reason all my gauges dropped down. Also the car ...

  1. #1
    Junior Member TruThug's Avatar
    Join Date
    Jan 2009
    Location
    La Vergne, TN
    Posts
    67

    Black
    1999 Firebird

    Whats wrong?

    I stopped at a stoplight earlier today and for some odd reason all my gauges dropped down. Also the car was shaking (I guess would be the best way to describe it) really bad, almost felt like the car was losing battery power. I put it in park to go turn it off but all of a sudden my gauges rose and was alright after that. Would/Could it be an alternator problem? If there is something you guys need to know more of let me know. Thanks for the help!

  2. #2
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Quote Originally Posted by TruThug View Post
    I stopped at a stoplight earlier today and for some odd reason all my gauges dropped down. Also the car was shaking (I guess would be the best way to describe it) really bad, almost felt like the car was losing battery power. I put it in park to go turn it off but all of a sudden my gauges rose and was alright after that. Would/Could it be an alternator problem? If there is something you guys need to know more of let me know. Thanks for the help!
    Is it throwing any codes?

  3. #3
    Junior Member TruThug's Avatar
    Join Date
    Jan 2009
    Location
    La Vergne, TN
    Posts
    67

    Black
    1999 Firebird

    Im not very smart when it comes to stuff like that, as far as a light coming on or anything noticeable, then nope.

  4. #4
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Quote Originally Posted by TruThug View Post
    Im not very smart when it comes to stuff like that, as far as a light coming on or anything noticeable, then nope.
    So when it did this you didn't notice your check engine or abs inop ebrake pulled or traction inop lights come on?

  5. #5
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Because when the alt died on my old bird and wouldn't charge the battery, it started to sacrifice the abs traction and said my ebrake was pulled to save power!! Also my speedo and rpm gauge went crazy!!

  6. #6
    Junior Member TruThug's Avatar
    Join Date
    Jan 2009
    Location
    La Vergne, TN
    Posts
    67

    Black
    1999 Firebird

    Nothing came on and it was fine after that. I drove it for another 15 mins home and it ran fine. Its weird that it happen.

  7. #7
    Junior Member TruThug's Avatar
    Join Date
    Jan 2009
    Location
    La Vergne, TN
    Posts
    67

    Black
    1999 Firebird

    Now that I think about it my light did not come on but my brakes did feel a little different like not as "soft" as they usually are, if that makes any sense.

  8. #8
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Quote Originally Posted by TruThug View Post
    Now that I think about it my light did not come on but my brakes did feel a little different like not as "soft" as they usually are, if that makes any sense.
    Then if it only happend for a moment I would say that your alt has a short or you need to check the connections on the alt to make sure they are tight. But that def sounds like an electrical problem!!

  9. #9
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Check the belt for wear/cracks.

    Alt. might be going as well.

  10. #10
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Quote Originally Posted by KMdef9 View Post
    Check the belt for wear/cracks.

    Alt. might be going as well.
    I didn't think about that so that would be good to check also!!


    EDIT: You can take the alt up to autozone they will check to see if it's good or bad for free!!

  11. #11
    Junior Member TruThug's Avatar
    Join Date
    Jan 2009
    Location
    La Vergne, TN
    Posts
    67

    Black
    1999 Firebird

    Thanks so much guys I will do all that tomorrow and I'll go from there

  12. #12
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Quote Originally Posted by TruThug View Post
    Thanks so much guys I will do all that tomorrow and I'll go from there
    Your welcome, best bet is to just take it one step at a time, and take your time!!

  13. #13
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Sounds like it tried to stall. Have you cleaned your throttle body lately?

  14. #14
    Member TA98's Avatar
    Join Date
    Mar 2009
    Location
    Maryland
    Posts
    863

    Black
    1998 Trans Am

    check battery connections too

  15. #15
    Junior Member TruThug's Avatar
    Join Date
    Jan 2009
    Location
    La Vergne, TN
    Posts
    67

    Black
    1999 Firebird

    When it comes to cars I have no clue how to maintain them, so no to the cleaning my throttle body, should I? and my connections are good I check today.

  16. #16
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Quote Originally Posted by TruThug View Post
    When it comes to cars I have no clue how to maintain them, so no to the cleaning my throttle body, should I? and my connections are good I check today.
    When was the last time you changed the plugs and wires also?

  17. #17
    Junior Member TruThug's Avatar
    Join Date
    Jan 2009
    Location
    La Vergne, TN
    Posts
    67

    Black
    1999 Firebird

    I love my bird to death but I have never changed anything on it it sucks dont have the money too, I do change the oil and the radiator fluid because it has a leak but thats all I have done to the engine it needs a tune up really bad but don't have the money.

  18. #18
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Quote Originally Posted by TruThug View Post
    I love my bird to death but I have never changed anything on it it sucks dont have the money too, I do change the oil and the radiator fluid because it has a leak but thats all I have done to the engine it needs a tune up really bad but don't have the money.
    Yea I know the feeling man, but that comes along with having a vehicle keep it maintained to keep it alive. I would check into getting some new plugs and wires tho, and check your filter to!!

  19. #19
    Junior Member TruThug's Avatar
    Join Date
    Jan 2009
    Location
    La Vergne, TN
    Posts
    67

    Black
    1999 Firebird

    I know it is and alright I well definitely check it out and again thanks for the help guys

  20. #20
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Quote Originally Posted by TruThug View Post
    I know it is and alright I well definitely check it out and again thanks for the help guys
    Yea no prob anytime!!!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can someone tell me whats wrong with this LS2
    By LS2SS in forum General Help
    Replies: 8
    Last Post: 10-16-2013, 07:41 PM
  2. whats wrong with my headrests?
    By keith455 in forum General Help
    Replies: 5
    Last Post: 10-02-2013, 08:50 AM
  3. Umm... I don't know whats wrong??
    By WS6Dream in forum General Help
    Replies: 1
    Last Post: 03-30-2011, 05:33 PM
  4. Question: Whats wrong with my T/A?
    By Dann in forum Firebird / WS6
    Replies: 8
    Last Post: 06-03-2009, 08:45 AM
  5. whats wrong
    By huggerls1 in forum General Help
    Replies: 5
    Last Post: 01-10-2009, 09:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •