Page 2 of 2 FirstFirst 12
Results 21 to 33 of 33

what problems do you have after 80k?

This is a discussion on what problems do you have after 80k? within the Firebird / WS6 forums, part of the Vehicle Specific category; Originally Posted by third_shift|studios damn near 5k and it's still stock...that's gotta hurt nah, 2500 including the 2 grand i ...

  1. #21
    Member
    Join Date
    Feb 2007
    Location
    austin
    Posts
    524

    Black/Black
    '00 Firebird WS6 T/A

    Quote Originally Posted by third_shift|studios View Post
    damn near 5k and it's still stock...that's gotta hurt
    nah, 2500 including the 2 grand i dumped at shops.

    and it isn't quite stock, it has picked up a few goodies along the way

    oh, and 2 tires ($425) so the total is really around $3k but that includes the lid, K&N, tune (which I did myself) tb bypass ! ram air hood baffles and ! maf screen; not a lot, but I have subframe connectors too and an electric cutout on the way so i think i'm about done with performance modding unless something else breaks and i decide to replace it with something better... or unless I get the itch and bust out my nitrous kit again :P

  2. #22
    Member blownh2x's Avatar
    Join Date
    Jan 2007
    Location
    Joliet,IL
    Age
    38
    Posts
    175

    Red
    99 Firehawk (M6) #518

    I purchased a 99 Firehawk recently and had to replace the power antenna, Lt headlamp motor, belt tensioner pulley and thats it so far. It has 75,000 miles and the clutch was replaced before I purchased it. I purchased it as a reposession knowing I had to put a little money into it.

  3. #23
    Senior Member 35thAnniZ28's Avatar
    Join Date
    Mar 2007
    Location
    Texas
    Posts
    1,809

    eating bulldog
    son of biscuit

    does anyone make a writeup on how to install a power antenna from trans ams?

  4. #24
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    Quote Originally Posted by 35thAnniZ28 View Post
    does anyone make a writeup on how to install a power antenna from trans ams?
    honestly it would just be to buy a TA attn. then just wire it to i think the radio. then obluoily the ground and youll be straight.

    they are nice thoe

  5. #25
    Senior Member
    Join Date
    Apr 2007
    Location
    Newport, RI
    Posts
    1,550

    Navy Blue Metallic
    '00 Formy A4

    It should be pretty easy. My car has one, and when I removed the spare tire cover, the antenna motor was right there, very easy to get to. I wouldn't be surprised if the wiring for it is already there.....alot of times it's cheaper for them to use the same wiring harness, whether the car has the power options or not.


    Oh, and my car....66.5k, I took it in for underhood noise yesterday, turned out to be pulleys. The A/C compressor pulley, and the AC belt tensioner pulley. They had to order them, not sure what the bill will be.

  6. #26
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    Quote Originally Posted by StuntmanMike View Post
    It should be pretty easy. My car has one, and when I removed the spare tire cover, the antenna motor was right there, very easy to get to. I wouldn't be surprised if the wiring for it is already there.....alot of times it's cheaper for them to use the same wiring harness, whether the car has the power options or not.


    Oh, and my car....66.5k, I took it in for underhood noise yesterday, turned out to be pulleys. The A/C compressor pulley, and the AC belt tensioner pulley. They had to order them, not sure what the bill will be.
    do you have the ext warrenty?

  7. #27
    Senior Member
    Join Date
    Apr 2007
    Location
    Newport, RI
    Posts
    1,550

    Navy Blue Metallic
    '00 Formy A4

    Quote Originally Posted by greatwhiteZ28 View Post
    do you have the ext warrenty?
    Yeah, but of course it doesn't cover this. My mechanic called the company, belts and pulleys aren't covered.

    This is why I think extended warrantees are generally a waste of money, all they do is find excuses not to pay out.

    I'm going to try and get it from the guy I bought the car from, I'll see how that goes.

  8. #28
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    belts might not be coverered but pullies are. .. its mechanical. belts coulddddd be notmal wear, but still,

    hey im loving my ext. warrnety, paid my 100 detucabol on a couple of things

  9. #29
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    1 being the front o2 sensor,

  10. #30
    Senior Member
    Join Date
    Apr 2007
    Location
    Newport, RI
    Posts
    1,550

    Navy Blue Metallic
    '00 Formy A4

    Well, I went with a shorter warranty, 6mos/7500 miles. Apparently the longer ones cover more.

    Came out to $245, with the tax. Only charged me 60 bucks for labor, the rest was the parts. He had a hard time getting them too, he ordered them Tues, they finally came in today.

    Nice and quiet now, the car sounds great that now all I hear is motor.

  11. #31
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    Quote Originally Posted by StuntmanMike View Post
    Well, I went with a shorter warranty, 6mos/7500 miles. Apparently the longer ones cover more.

    Came out to $245, with the tax. Only charged me 60 bucks for labor, the rest was the parts. He had a hard time getting them too, he ordered them Tues, they finally came in today.

    Nice and quiet now, the car sounds great that now all I hear is motor.
    well thats good then, i think i paid 850$ for full coverage 2 year.

    i thought it was only 1 year but after looking at the card it said 11/ 2008 , soo i was pretty happy

  12. #32
    Junior Member kevinm2112's Avatar
    Join Date
    Aug 2007
    Location
    New Mexico
    Age
    39
    Posts
    4

    Red
    1999 Trans Am

    My 99 TA has 94,XXX miles and so far no problems. I replaced the warped rotors and plugs and wires about a month ago, but that is it. There is a slight squeal from under the hood which I am sure is probably just a worn pulley, just have to spend the time to replace it. This is my second TA and have had good luck with both, I think alot depends on how well the car has been maintained!

  13. #33
    Junior Member indig0_2000's Avatar
    Join Date
    Feb 2006
    Location
    San Pedro, CA
    Age
    41
    Posts
    13

    pewter
    2001 Trans Am WS6 Conv.

    my '01 vert a4 has 37,000 miles and has had the tensioner replaced and needs pwr ant replaced and the driver side window leaks water when it rains i definitely need to get that fixed asap since it should start to rain here soon and washing the baby has become a chore. the window doesn't seal well with the top.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 97 LT1 problems
    By james78657 in forum LT1
    Replies: 18
    Last Post: 01-20-2012, 10:30 AM
  2. Help: 62.9i problems
    By trooperrunner in forum Stereo and Electronics
    Replies: 1
    Last Post: 08-12-2009, 04:08 PM
  3. problems with my 66 g.t.o. (help)
    By 05gtoautoX in forum GTO
    Replies: 6
    Last Post: 07-11-2006, 04:49 AM
  4. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 07:26 PM
  5. A/C problems.
    By gnomee in forum General Help
    Replies: 2
    Last Post: 03-14-2006, 07:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •