Page 291 of 294 FirstFirst ... 4191141191241251261271287288289290291292293294 LastLast
Results 5,801 to 5,820 of 5875
Like Tree1411Likes

What did you do with your Trans Am today?

This is a discussion on What did you do with your Trans Am today? within the Firebird / WS6 forums, part of the Vehicle Specific category; Originally Posted by joesurfer got a link or source? https://www.autotrix.net/Products/10...indow+Fix+Kit/...

  1. #5801
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,434

    Navy Blue Metallic
    98 T/A w/a little mods...

    Quote Originally Posted by joesurfer View Post
    got a link or source?
    https://www.autotrix.net/Products/10...indow+Fix+Kit/

  2. #5802
    Now in Summit LT1 Flavor! Y2KArcticSS's Avatar
    Join Date
    Mar 2007
    Location
    Henryetta/Tulsa Oklahoma
    Posts
    3,471

    Summit White
    2016 Camaro SS

    The best part is that Autotrix is local to Tulsa. I am going to check and see if I can pick up my parts instead of having them shipped

    2016 Summit White 1SS - The DD
    2001 NBM Trans Am WS6 - Wifey's Grocery Getter
    2000 Arctic White SS #1667 - Sold

  3. #5803
    Member BobbyGFirebird's Avatar
    Join Date
    Jul 2015
    Location
    NY
    Posts
    124
    Blog Entries
    1
    dreamcruise-2016.jpgI entered my 30th Anniv. Ed. white/blue TransAm Hurst t-top in the car show this weekend up in CT for Special Olympics DreamRide. They bring in about "$ half a Billion" worth of cars (sic: $500,000,000) of exotic, supercar, muscle, classics, etc. Check out the pics and weblinks on and after weekend. Really fun stuff, Gents. www.DreamRide.org

    Regards to you all.
    Last edited by BobbyGFirebird; 08-26-2017 at 07:10 AM.

  4. #5804
    Junior Member
    Join Date
    Aug 2016
    Location
    oceanside
    Posts
    35

    Silver
    2002 T/A Ws6 convertible

    Thanks for that info!, I did not know of this site.

  5. #5805
    Senior Member Whamhammer's Avatar
    Join Date
    Sep 2010
    Location
    Bel Air, Maryland
    Posts
    1,307

    Silver
    '02 Trans Am WS-6, 6M

    Quote Originally Posted by SMWS6TA View Post
    Which kit did you look at? There are 2. One that fixes the power issue the other does that and does the express down like the drivers side?

    The power only should only have you running the power and ground from the switch harness thru the door jam into the cabin then thru the fire wall. You should then run it along the passenger fender towards the battery then along the front (I ran mine along the harness that connects the front lights and washer) then up to the red cap that is the + post next to the fuse box.
    Whoa, isn't that positive post supposed to be used for jumpstarting the car? Won't that block w that switches circuit?
    SLP Air Lid/Smooth Bellows
    Kooks Emissions LT Headers/Catted Y pipe
    NGK TR55 plugs
    Magnaflow Cat-back
    Spohn Front Upper Tubular Control Arms
    UMI Front Lower Tubular Control Arms
    UMI Rear Lower Control Arms/ Adjustable Panhard Rod
    Factory C5 Z06 17x9.5 wheels w/ 285-40-17 Continental Extreme Contact DW's all the way around.
    Dyno Dynamics dynoed @:
    356 rwhp, 360 rwlb/tq

  6. #5806
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,994

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by Whamhammer View Post
    Whoa, isn't that positive post supposed to be used for jumpstarting the car? Won't that block w that switches circuit?
    Won't be any issue at all


    Sent from my iPhone using Tapatalk
    -------------------------------------
    Kooks 1 7/8" race headers, Kooks ORY, Borla catback, Nitto 555R, LS6 intake manifold, Shaner S3 ported stock throttle body, SLP lid, smooth bellows, JAAM Ram Air kit, Elite Engineering catch can, LS6 valley cover, EGR and AIR deleted, Frost tune, and Simpson Racing child car seat in the back. 13.2 @ 108MPH

  7. #5807
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,434

    Navy Blue Metallic
    98 T/A w/a little mods...

    Replaced the pilot bearing last night in prep for tranny when it gets back. Good thing too, the old one looks like it was oval from the input shaft.

    Tick is shipping the tranny today.....finally!!

  8. #5808
    Member BobbyGFirebird's Avatar
    Join Date
    Jul 2015
    Location
    NY
    Posts
    124
    Blog Entries
    1
    Old School rules! Rear blinker stopped working on dreamy, night cruise w windows down. Pull into next auto parts store, buy the bulbs... but first diagnose the darn corrosion. Wiped it all off first bulb i thought bad. Filaments still good. Reinstall. NOT WORK. Could also be the FRONT amber dual-blinker/running bulb.
    Just for good measure, pull other "good bulb" on same side and see some minor corrosion, but both dual filaments good. Reinstall lens assembly after scraping all contacts with little screwdriver file --- those ones you never think you need or can find! Reinstall ... .... resigned that I'll rip it all out to put in new $150 sockets next week.
    Drumroll: turn car on to drive away in defeat. WORKS !

  9. #5809
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,434

    Navy Blue Metallic
    98 T/A w/a little mods...

    Transmission is back and in. What a bitch to install by myself with a messed up hand.

    That Viper output shaft is no joke. It's at least 1/3" thicker over the stock output shaft.

    Tonight I'll finished putting the car back together. Hopefully a test drive too

  10. #5810
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,434

    Navy Blue Metallic
    98 T/A w/a little mods...

    Here are some of the picks of the transmission carnage now that I figured out how to work flickr.

















    20170730_173101 by Scott McDonald, on Flickr



    Here is it back again.



    Put on some anti-seize so the yoke slides on easier.




  11. #5811
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,434

    Navy Blue Metallic
    98 T/A w/a little mods...

    It lives!!!!!

    Shifts so tight and crisp....

  12. #5812
    Senior Member Whamhammer's Avatar
    Join Date
    Sep 2010
    Location
    Bel Air, Maryland
    Posts
    1,307

    Silver
    '02 Trans Am WS-6, 6M

    Quote Originally Posted by SMWS6TA View Post
    It lives!!!!!

    Shifts so tight and crisp....
    While you're at it, send me a rebuilt six speed too

  13. #5813
    Member TransAmTerry's Avatar
    Join Date
    May 2010
    Location
    Abingdon, Md
    Posts
    204

    black
    02 TransAm Ramair WS6

    First chance I had to get on since Sunday when I took the T/A out auto-crossing again !!! WooHoo !! Mixing it up with the Porches again. I think I found a new past-time. 6 runs and improved on each run - no cones were killed,, at least by me ! I'm going to have to look into a brake upgrade though.
    '02 Black RamAir M6--Kooks LTH, Magnaflo, Lowered Eibach springs and Bilstien shocks, Tuned By Frost, K&N & SLP box, Smooth bellows, polished TB, Spohn perf. suspension, shock tower brace. UMI 3point SFC. Front & side splitters w/ canards.
    '76 LagunaS3 - 355ci , 350 turbo, 3:55's

  14. #5814
    Member Decadence75's Avatar
    Join Date
    Aug 2013
    Location
    Missississipi
    Posts
    364

    Bright Red
    2000 Trans Am

    Quote Originally Posted by BobbyGFirebird View Post
    Old School rules! Rear blinker stopped working on dreamy, night cruise w windows down. Pull into next auto parts store, buy the bulbs... but first diagnose the darn corrosion. Wiped it all off first bulb i thought bad. Filaments still good. Reinstall. NOT WORK. Could also be the FRONT amber dual-blinker/running bulb.
    Just for good measure, pull other "good bulb" on same side and see some minor corrosion, but both dual filaments good. Reinstall lens assembly after scraping all contacts with little screwdriver file --- those ones you never think you need or can find! Reinstall ... .... resigned that I'll rip it all out to put in new $150 sockets next week.
    Drumroll: turn car on to drive away in defeat. WORKS !
    If they act up again, you can replace the whole housings/sockets/led bulbs for less than that. You can get the sockets themselves for about $8 each, then a set of housings off amazon for around $60-$70. The LED bulbs should only be around $10 or so. I don't remember exactly, it has been several years since I swapped mine out.

    2000 Trans Am T56 Swapped - GMPP "HOT" Cam | LS6 Intake | PnP TB | 25% UD Pulley | Founders adjustable LCA/PHB/TA | Norris Catch Can | TSP 1-7/8 SS LT | TSP True Duals with bullets | SLP Lid | UMI Shock tower brace | Torq Thrust M 17x9 275/40 front 17x10.5 315/35 rear - YouTube Videos - My Car Site

  15. #5815
    Senior Member Redphoenix1998's Avatar
    Join Date
    Apr 2002
    Location
    San Jose
    Age
    36
    Posts
    1,897

    Red
    1998 Pontiac Trans Am

    YAY my new AFR 245 heads are in! More Mods!
    98 WS6 M6 ASC #2647
    Forged Custom 408 w/Vortec YSi

  16. #5816
    Member DarrenWS6's Avatar
    Join Date
    May 2015
    Location
    Blossburg, PA
    Age
    27
    Posts
    404

    Silver Metallic
    2000 Trans Am WS6

    I did this yesterday with mine LOL!



    Finally getting around to putting new tires on the worn pair I had. I bought the tires at GM Carlisle 2016, if that says how long its been lol! I need more power, and need a line-lock. Very disappointed with the low amount of smoke.
    2000 Trans Am WS.6 M6

    SLP lid & bellow w/ K&N, GMMG catback w/ Corsa Clones, UMI SFC, UMI Adj. Panhard, UMI Adj. TQ arm w/ relocation kit, Eibach prokit, Bilstein HDs, Nitto NT555s, skip shift elim, whiteface overlays, 20% tint, matte black decal/overlays

  17. #5817
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,484

    Black & Blue
    '02 WS.6 / '07 Suburban

    You so need a line lock in that car!

    Also, referring to a few posts back I am thinking that "Scott" is synonymous with "Spaz" when it comes to automotive carnage. Damn...

  18. #5818
    Member speedyWS6's Avatar
    Join Date
    Sep 2009
    Location
    U.K.
    Posts
    493

    Pewter
    2002 WS6 TA

    Well.....

    I got the Keeaudio bazooka subs sent over from Dave (Nutball) as a very cheap "gift"
    and no charges.

    Clearly they are to replace the rubbish, falling apart factory subs and today i had a chance to fiddle
    about and fit them. Contrary to what i have read they line up perfectly with the four captive nuts
    and they sound damn good!! Highly recommended for a (relatively) inexpensive fix for the
    factory subs going haywire!

    Gave her a good clean and polish at the same time but rain stopped a drive..

  19. #5819
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,447

    Red
    02 35th LE Camaro SS

    She is officially back on the road. Drove her about 60 miles. I really needed this right now.http://cloud.tapatalk.com/s/59c7d667...1659252723.mp4

    Sent from my SM-G955U using Tapatalk
    It's on jackstands.

  20. #5820
    Member BobbyGFirebird's Avatar
    Join Date
    Jul 2015
    Location
    NY
    Posts
    124
    Blog Entries
    1
    i bought replace speakers from Crutchfield.....they were super helpful on phone and knew what to recommend for F-body subs behind driver/pass seats. Cant recall exact model now but will post. havent put in yet as only 1 blown speaker and only on super low Bass (eg. Straight Outta Compton c.d. !). No rattles on my Adele c.d. ! :-)))

    Quote Originally Posted by speedyWS6 View Post
    Well.....

    I got the Keeaudio bazooka subs sent over from Dave (Nutball) as a very cheap "gift"
    and no charges.

    Clearly they are to replace the rubbish, falling apart factory subs and today i had a chance to fiddle
    about and fit them. Contrary to what i have read they line up perfectly with the four captive nuts
    and they sound damn good!! Highly recommended for a (relatively) inexpensive fix for the
    factory subs going haywire!

    Gave her a good clean and polish at the same time but rain stopped a drive..

Page 291 of 294 FirstFirst ... 4191141191241251261271287288289290291292293294 LastLast

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (0 members and 3 guests)

Similar Threads

  1. new guy just got my first trans am today
    By roger_johnson2002 in forum New Member Introductions
    Replies: 9
    Last Post: 07-14-2011, 08:35 AM
  2. Found this on the windshield of my Trans Am today
    By ls1camino in forum Almost Anything Goes
    Replies: 60
    Last Post: 03-10-2009, 12:11 PM
  3. Got into an accident in the Trans Am today
    By ls1camino in forum Almost Anything Goes
    Replies: 30
    Last Post: 09-21-2008, 04:32 PM
  4. Just got my Trans Am today!
    By vannatte in forum Firebird / WS6
    Replies: 34
    Last Post: 09-20-2007, 09:57 AM
  5. First time at Track today!!! 2000 Trans Am ws6
    By gimmeadonut in forum Drag Racing
    Replies: 1
    Last Post: 11-12-2005, 01:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •