Results 1 to 6 of 6

Weird headlights 02'

This is a discussion on Weird headlights 02' within the Firebird / WS6 forums, part of the Vehicle Specific category; Anyone have this problem: I turned on the headlights(low beams) one was bright, 3 were very dim. Hit the high ...

  1. #1
    Member
    Join Date
    Jun 2012
    Location
    florida
    Posts
    409

    Weird headlights 02'

    Anyone have this problem: I turned on the headlights(low beams) one was bright, 3 were very dim. Hit the high beams all 4 were bright, switch to low again and 2 outer ones were on (normal). Is the switch bad?

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    sounds like it's going...

  3. #3
    expensive tires az gt eater's Avatar
    Join Date
    Mar 2006
    Location
    phoenix
    Posts
    1,951

    white
    04 2500 4x4 crew cab

    I thought that was a ground issue.....or a loose connection.

  4. #4
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    Usually (90%) this is a bad connection at the one of the headlights. Unplug them all, replug them all in, and you should be ok. It almost never is a headlight switch issue. Look for any corrosion on the headlight connections. You can clean them with a small wire brush if you want.

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    If you have corrosion issues, you can also dip the plugs in a chemical cleaner such as CLR, white vinegar and such. Just be sure to fully rinse and dry them after doing so. After that, apply a dab of dielectric grease in each socket and you should be good to go.

  6. #6
    Yeah baby! Yeah! silverWS6's Avatar
    Join Date
    May 2009
    Location
    okc
    Posts
    2,571

    Silver 2002 WS.6
    Red 1989 Formula

    I'm almost %99 sure you have a bad connection, check the headlight connections. I just had this happen to me a while ago

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. does this look weird?
    By Ieatstangs in forum Almost Anything Goes
    Replies: 24
    Last Post: 05-14-2009, 10:52 AM
  2. Something weird
    By ledesma54 in forum GTO
    Replies: 3
    Last Post: 11-21-2008, 10:25 PM
  3. Don't Flash Headlights At Any Car With No Headlights On!!
    By Danger731 in forum Almost Anything Goes
    Replies: 44
    Last Post: 10-18-2007, 01:56 PM
  4. Weird, Keyless entry pops up headlights
    By Stipes in forum Computer & Tuning
    Replies: 4
    Last Post: 04-02-2007, 10:32 AM
  5. that's weird
    By pecha in forum Almost Anything Goes
    Replies: 13
    Last Post: 06-13-2006, 06:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •