Results 1 to 20 of 20

Turn Signal Problems

This is a discussion on Turn Signal Problems within the Firebird / WS6 forums, part of the Vehicle Specific category; When I went out and started my Trans Am tonight, I found a problem. My left turn signals do not ...

  1. #1
    Member
    Join Date
    Jan 2011
    Location
    Mishawaka IN
    Posts
    123

    Silver
    2000 Trans Am

    Turn Signal Problems

    When I went out and started my Trans Am tonight, I found a problem. My left turn signals do not work. On the dash, when I put the left blinker on, I get a solid green left arrow that does not blink. My flashers work. What do I need to test or possibly replace. Also, if I left anything out, let me know. Thanks, Sid.

  2. #2
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    One of the bolbs should be messed up.
    Turn on the signals and check the front & back
    00 ss blk m6 " STOCK" strano springs, slp bilstein shocks, adj LCA, adj panhard bar, relocation brackets, 2 point SFCs welded,OEM zo6 rims black, magnaflow exhaust, CME exhaust,E/cutout, slp grille, custom front plate mount, HIDs, whistler mod, side moldings delete, slp air lid, ported and polished TB, strut tower brace, 3.73s gears, and some other parts to list!
    next to come,4.10s,ls7 clutch, ms3 or 228r cam, ported 243s, ls6 intake, ls6 oil pump. ls2 timing chain, longtube headers no cats, with a tune..
    02 tahoe Z71 blacked out
    00 jeep grand Cherokee limited on 22s.
    07 Dodge Charger R/T Inferno Red, Sold
    98 z28 red m6 sold
    07 zx6r ninja flat/black sold
    08 zx6r ninja sold

  3. #3
    Member
    Join Date
    Jan 2011
    Location
    Mishawaka IN
    Posts
    123

    Silver
    2000 Trans Am

    I did do that. When I turn on the left turn signal, nothing happens in the front or back. The right side work but seem slow.

  4. #4
    Member Frozen WS6's Avatar
    Join Date
    Jan 2006
    Location
    EagleRiver, Alaska
    Age
    39
    Posts
    612

    RED, BLACK
    2001 WS6, 1998 TA

    It will be your flasher then. Mine did the same thing this summer. No turns, but my 4 ways still blinked because they use seperate flashers.

  5. #5
    Member
    Join Date
    Jan 2011
    Location
    Mishawaka IN
    Posts
    123

    Silver
    2000 Trans Am

    Where is that and how expensive is it? Like the flasher relay?

  6. #6
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    you might wanna switch over to LEDs......best mod i ever did

  7. #7
    Member Frozen WS6's Avatar
    Join Date
    Jan 2006
    Location
    EagleRiver, Alaska
    Age
    39
    Posts
    612

    RED, BLACK
    2001 WS6, 1998 TA

    It's under the dash kinda hidden, clipped to a metal support behind the heater controls. There pretty cheap, under $5.00. Schucks will have them. I can get a pic posted in the morning.

  8. #8
    Member
    Join Date
    Jan 2011
    Location
    Mishawaka IN
    Posts
    123

    Silver
    2000 Trans Am

    Quote Originally Posted by sjsingle1 View Post
    you might wanna switch over to LEDs......best mod i ever did
    How much did that cost? You have a video of the LED's?

  9. #9
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    the front DRL LEDs were 25$ apiece.....then had to switch over to the electronic flashers......2 at 8$......i had just changed out the burnt sockets and they were starting to get burnt again.....no heat with the LEDs.....totally worth it......no vid

  10. #10
    Army Dude robcas47's Avatar
    Join Date
    Nov 2007
    Location
    Ft. Rucker Area, Lower AL
    Posts
    674

    Arctic White
    01 TA / 06 Duc 749D

    You might want to check out all of your turn signal bulbs. I had the same problem a while back, the drl both worked fine but when I applied the r/s turn signal i got a steady arrow and no light when I got out and checked. The other side worked fine. When I pulled the r/s bulb it was corroded at the base, i cleaned it off and cleaned out the socket and it worked fine, for a while. After repeatedly going through this process I went to a junk yard and founda socket in great shape and cut/spliced it on and that fixed it for good, or at least for now. This might not be the fix for your issue, but it could easily be that simple and far less costly than an overall LED swap. But LED's are always a good upgrade. Good luck

  11. #11
    Member
    Join Date
    Jan 2011
    Location
    Mishawaka IN
    Posts
    123

    Silver
    2000 Trans Am

    Well I replaced the blinker relay and now they both blink the normal speed but my left front blinker is out. Ill replace that sometime soon, I think that will fix the problem.

  12. #12
    Senior Member justinmc978's Avatar
    Join Date
    May 2009
    Location
    college station, tx
    Posts
    2,564

    sold: 1999 firebird
    1998 Trans Am

    put on your hazards, what ever bulb isn't flashing is busted, has nothing to do with your flashers

    edit: nvm looks like you figured it out
    Last edited by justinmc978; 02-16-2011 at 07:26 AM.

  13. #13
    Military Police FutureWS6's Avatar
    Join Date
    Mar 2007
    Location
    dallas
    Posts
    300

    Black
    1999 Trans Am

    Quote Originally Posted by justinmc978 View Post
    put on your hazards, what ever bulb isn't flashing is busted, has nothing to do with your flashers

    edit: nvm looks like you figured it out
    agreed, i doubt its the flasher. its either one of the metal peices on the bulb is broken and so only the hazards can work, or its the housing, or another option it might just b alittle lose.

  14. #14
    Junior Member
    Join Date
    Sep 2009
    Location
    illinois
    Posts
    94

    Black
    2000 Trans Am

    Quote Originally Posted by sjsingle1 View Post
    the front DRL LEDs were 25$ apiece.....then had to switch over to the electronic flashers......2 at 8$......i had just changed out the burnt sockets and they were starting to get burnt again.....no heat with the LEDs.....totally worth it......no vid
    Where did you get the parts at for the switch

  15. #15
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    electronic flasher? pep boys........EL12
    Last edited by sjsingle1; 02-19-2011 at 11:50 PM.

  16. #16
    Junior Member
    Join Date
    Sep 2009
    Location
    illinois
    Posts
    94

    Black
    2000 Trans Am

    Thanks

  17. #17
    Junior Member
    Join Date
    May 2007
    Location
    California
    Posts
    12

    Black
    99 WS6

    my TA had the front bulbs burning out a lot because the design allowed water to pool inside the blinker and corrode the bulbs. Terrible design.

  18. #18
    Senior Member justinmc978's Avatar
    Join Date
    May 2009
    Location
    college station, tx
    Posts
    2,564

    sold: 1999 firebird
    1998 Trans Am

    Quote Originally Posted by JR99RamAir View Post
    my TA had the front bulbs burning out a lot because the design allowed water to pool inside the blinker and corrode the bulbs. Terrible design.
    drill holes in the bottom of the drl, wont happen again

  19. #19
    Junior Member
    Join Date
    Sep 2009
    Location
    illinois
    Posts
    94

    Black
    2000 Trans Am

    I had the same problem with the water. Replaced both housings and no more water problems and it looks better now. The bulbs still burn out faster than i think they should, but i will probably do the led upgrade.

  20. #20
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    I had some issues with my sockets. Easy fix new sockets from any auto store. I swapped in Leds with a electronic flasher and ditched the useless drl crap so I used normal Leds dint need the overpriced ones for cars with drl's and looks better without them on all the time. At least with my trailblazer you can turn them off wish that was a option on the fbodys.
    1998 Trans Am 85k miles.
    Bolt ons, MS3 113LSA cam, Circle D Stall, Tune, Modified WS6 style hood, Full Suspension, 6000k HID's, Clear Side Markers w/ Leds, Led 3rd Brake Light and 18" AR Staggered Killer Wheels w/ BFG KDW NT's.- Weekend Toy/DD
    02 Trailblazer -Sold
    09 Ram 1500 CC - Sold
    09 Cobalt SS/TC - Sold
    13 ram 1500 LoneStar CC 4x4 - Magnaflow, K&N,and more to come-DD/Toy

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Turn Signal
    By Z28boy2000 in forum Stereo and Electronics
    Replies: 1
    Last Post: 03-30-2009, 12:36 PM
  2. Turn Signal Problems
    By chaosinfinite in forum General Help
    Replies: 21
    Last Post: 09-23-2008, 07:51 AM
  3. Turn Signal help
    By Blksilvr in forum Appearance Section
    Replies: 3
    Last Post: 07-29-2007, 09:07 AM
  4. Turn Signal Cam
    By shlby123 in forum Firebird / WS6
    Replies: 0
    Last Post: 03-20-2007, 02:15 PM
  5. Turn signal/DRL problems
    By daryl.l in forum General Help
    Replies: 8
    Last Post: 04-08-2006, 08:19 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •