Page 1 of 2 12 LastLast
Results 1 to 20 of 24

Turn signal problem....what did I miss!

This is a discussion on Turn signal problem....what did I miss! within the Firebird / WS6 forums, part of the Vehicle Specific category; Ok I searched through the other posts and tried everything I found in there and I still have a problem. ...

  1. #1
    Junior Member
    Join Date
    Jan 2008
    Location
    Las Vegas
    Posts
    3

    Turn signal problem....what did I miss!

    Ok I searched through the other posts and tried everything I found in there and I still have a problem.

    My flashers work fine, but my turn signals just come on and won't blink (note they blink for the flashers). I changed the blubs, I replaced the front sockets, and I installed a new flasher thingy. Still same problem.

    What did I miss? Is there a fuse I am over looking?

    Thanks,
    Jack

  2. #2
    Member WS-6's Avatar
    Join Date
    Feb 2008
    Location
    NW Indiana
    Posts
    418

    Pewter
    2000 T/A WS-6

    Quote Originally Posted by CrackerJackjp View Post
    Ok I searched through the other posts and tried everything I found in there and I still have a problem.

    My flashers work fine, but my turn signals just come on and won't blink (note they blink for the flashers). I changed the blubs, I replaced the front sockets, and I installed a new flasher thingy. Still same problem.

    What did I miss? Is there a fuse I am over looking?

    Oh and this is on 2001 T/A
    Thanks,
    Jack
    There are two (flashers) one for siginals and one for hazzards. They are usually a cylinder shape and silver I am not sure if the are in the fuse block or not, but most cars are. Do a search on here for flashers. Good luck

  3. #3
    Something Diabolical... chuckie669's Avatar
    Join Date
    May 2007
    Location
    Houston, Texas
    Posts
    2,677
    2000 C5 Torch Red

    If just one side is not working then I believe you got a bulb partially out or a funky socket. If both are not working I would check out your flasher unit.

    turn on your blinker and then start in the front and give all the bulbs a wiggle in the socket. When I got my car I had one that wasn't seating right and causing it to look like they were out and not flash.

  4. #4
    i f*****g hate rice adam0321's Avatar
    Join Date
    Apr 2007
    Location
    north carolina
    Age
    35
    Posts
    482

    black
    1999 ws6 trans-am

    drivers side?/i have the similar problem, if I mess with it it goes on and off. I am thinking of buying a new part from pontiac and just rewiriring the darn thing.

  5. #5
    Junior Member
    Join Date
    Jan 2008
    Location
    Las Vegas
    Posts
    3
    thanks for the help guys. It is both sides that don't work.

  6. #6
    Member Stricken1's Avatar
    Join Date
    Sep 2006
    Location
    Florida
    Posts
    248

    Black
    2001 Trans Am WS6

    There is a fuse for the turn signals on the driverside fuse box (inside of the door) ...first row second fuse.

  7. #7
    JMAC Racing WS6ICK's Avatar
    Join Date
    Aug 2005
    Location
    Kentucky
    Posts
    535

    2000 Trans Am WS6 LS6
    2006 GTO LS2

    Check both front and rear turn signal bulbs. If one is blown, the other one won't work properly.

  8. #8
    Junior Member
    Join Date
    Jan 2008
    Location
    Las Vegas
    Posts
    3
    ok I am a retard. I changed the hazard flasher, I didn't realize there where two under that dash. I just changed the turn signal flasher and now the blinkers work correctly.

    Thanks for all the help,
    Jack

  9. #9
    Member afattitude's Avatar
    Join Date
    Jun 2008
    Location
    Tampa
    Age
    31
    Posts
    243

    Black & Silver
    2000 WS6 & 2003 Z06

    i have the same problem it is a pain

  10. #10
    Member afattitude's Avatar
    Join Date
    Jun 2008
    Location
    Tampa
    Age
    31
    Posts
    243

    Black & Silver
    2000 WS6 & 2003 Z06

    just goin to replace the flasher part and see if that works

  11. #11
    Junior Member SmoothAl's Avatar
    Join Date
    Aug 2005
    Location
    Solvang, CA
    Posts
    32

    Black
    2002 Trans Am - Firehawk

    Quote Originally Posted by CrackerJackjp View Post
    ok I am a retard. I changed the hazard flasher, I didn't realize there where two under that dash. I just changed the turn signal flasher and now the blinkers work correctly.

    Thanks for all the help,
    Jack
    Jack,

    I'm about to change out my "flasher unit" and have never done it. What should I look for that is going to distinguish the Hazards from the Blinkers? Also, what is the best route to take to get to the unit - from the panel that lies below the steering wheel?

    SA

  12. #12
    Member SSMOKEshow's Avatar
    Join Date
    Feb 2008
    Location
    in the world
    Age
    30
    Posts
    227

    black
    1999 Camaro SS

    both my hazards and turn signals wont work still can figure it out i hate this shit

  13. #13
    Junior Member
    Join Date
    May 2009
    Location
    SC
    Posts
    3

    Red
    2000 SS Camaro

    hey im having the same problem. my bulbs light up but no flashing.. where do i find the flasher unit.. thanks

  14. #14
    Still The Junior Member RedVertTA's Avatar
    Join Date
    Jun 2008
    Location
    Orlando FL
    Age
    28
    Posts
    1,045

    Red+White Top and Stripes
    2000TransAmConvertible A4

    Old thread, but I'm having the same problem. How do I tell the 2 flashers apart? Are both interchangeable? Otherwise I'll swap both and if that solves the problem then I know its the flasher and not something else.

  15. #15
    Member blackcar's Avatar
    Join Date
    Oct 2005
    Location
    Arkansas
    Posts
    1,234

    2000 Camaro SS
    '02 Z28 parting-out

    Quote Originally Posted by RedVertTA View Post
    Old thread, but I'm having the same problem. How do I tell the 2 flashers apart? Are both interchangeable? Otherwise I'll swap both and if that solves the problem then I know its the flasher and not something else.
    If you turn on your hazzards are they blinking?

  16. #16
    Still The Junior Member RedVertTA's Avatar
    Join Date
    Jun 2008
    Location
    Orlando FL
    Age
    28
    Posts
    1,045

    Red+White Top and Stripes
    2000TransAmConvertible A4

    Yes they do, I know its the flasher, the fuse is fine, I just need the info from my previous post. Also, does anyone know what a replacement flasher would cost?

  17. #17
    Member blackcar's Avatar
    Join Date
    Oct 2005
    Location
    Arkansas
    Posts
    1,234

    2000 Camaro SS
    '02 Z28 parting-out

    Quote Originally Posted by RedVertTA View Post
    Yes they do, I know its the flasher, the fuse is fine, I just need the info from my previous post. Also, does anyone know what a replacement flasher would cost?
    Haven't changed the flashers b4, but I think if you turn your hazzards on you could feel/hear which one was blinking and change the other one.

  18. #18
    Still The Junior Member RedVertTA's Avatar
    Join Date
    Jun 2008
    Location
    Orlando FL
    Age
    28
    Posts
    1,045

    Red+White Top and Stripes
    2000TransAmConvertible A4

    That's a good idea, I think I'll try that.

  19. #19
    Member devil6rr's Avatar
    Join Date
    Oct 2008
    Location
    NJ
    Posts
    440

    SOM / NBM
    2002 Pro Z28/2001 TurboTA

    My 02 camaro does this also sometimes they work and sometimes they dont, if i hit the steering column somtimes it will start working

  20. #20
    lmpounded SandmanWs7's Avatar
    Join Date
    Jan 2006
    Location
    Dallas, Texas
    Posts
    8,028

    Silver
    2007 CTS-V

    Quote Originally Posted by RedVertTA View Post
    Old thread, but I'm having the same problem. How do I tell the 2 flashers apart? Are both interchangeable? Otherwise I'll swap both and if that solves the problem then I know its the flasher and not something else.
    Yes they are interchangeable.

    Do you know where they are? I believe the hazard flasher is the one by the door and the turn signal flasher is closer to the center. If you dont know what to look for let me know.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. turn signal problem?
    By DMAN in forum General Help
    Replies: 6
    Last Post: 10-25-2010, 05:21 PM
  2. turn signal problem
    By Firebirdformula in forum Firebird / WS6
    Replies: 7
    Last Post: 06-07-2010, 05:55 PM
  3. Turn Signal problem
    By Camaroride32 in forum General Help
    Replies: 3
    Last Post: 04-16-2008, 04:23 PM
  4. Turn signal problem
    By {FzS}BlacKMagicK in forum General Help
    Replies: 10
    Last Post: 05-01-2007, 06:27 AM
  5. Turn Signal Problem
    By M.RedWS6 in forum Firebird / WS6
    Replies: 5
    Last Post: 11-25-2006, 11:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •