Results 1 to 8 of 8

turn signal problem

This is a discussion on turn signal problem within the Firebird / WS6 forums, part of the Vehicle Specific category; I have replaced both front pig tails and they still wont blink, but when i turn on my running lights ...

  1. #1
    Member Firebirdformula's Avatar
    Join Date
    Feb 2009
    Location
    oklahoma
    Posts
    146

    black
    2000 firebird formula Ws6

    turn signal problem

    I have replaced both front pig tails and they still wont blink, but when i turn on my running lights they come on and all my fuses are good. My rears blink fine its jus the front ones that wont blink... any ideas?

  2. #2
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    Check the connections but other than that if all the fuses are good and the rears flash I have no other idea but loose wire
    1998 Trans Am 85k miles.
    Bolt ons, MS3 113LSA cam, Circle D Stall, Tune, Modified WS6 style hood, Full Suspension, 6000k HID's, Clear Side Markers w/ Leds, Led 3rd Brake Light and 18" AR Staggered Killer Wheels w/ BFG KDW NT's.- Weekend Toy/DD
    02 Trailblazer -Sold
    09 Ram 1500 CC - Sold
    09 Cobalt SS/TC - Sold
    13 ram 1500 LoneStar CC 4x4 - Magnaflow, K&N,and more to come-DD/Toy

  3. #3
    Member Firebirdformula's Avatar
    Join Date
    Feb 2009
    Location
    oklahoma
    Posts
    146

    black
    2000 firebird formula Ws6

    ok thx im cheking the connections and there good ....when i turn on my running lights they come on and stay on fine they jus wont blink....theres not a seperate flasher for the front right l?

  4. #4
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    Not as far as I know when I swapped in the led bulbs I changed to an electric flasher. The flasher for the turn signals is on the right side of the steering column under the dash

  5. #5
    Member Firebirdformula's Avatar
    Join Date
    Feb 2009
    Location
    oklahoma
    Posts
    146

    black
    2000 firebird formula Ws6

    it clicks when i turn them on and the back ones work jus fine tho

  6. #6
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    If you turn the hazard lights on do the front blink?

  7. #7
    Member Firebirdformula's Avatar
    Join Date
    Feb 2009
    Location
    oklahoma
    Posts
    146

    black
    2000 firebird formula Ws6

    nope

  8. #8
    Member Firebirdformula's Avatar
    Join Date
    Feb 2009
    Location
    oklahoma
    Posts
    146

    black
    2000 firebird formula Ws6

    they used to work and then i kept replacing bulbs and the pigtail got charred so i cut and put new ones on

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. turn signal problem?
    By DMAN in forum General Help
    Replies: 6
    Last Post: 10-25-2010, 05:21 PM
  2. Turn Signal problem
    By Camaroride32 in forum General Help
    Replies: 3
    Last Post: 04-16-2008, 04:23 PM
  3. Left Turn Signal Problem
    By 6speedTAthistime in forum Firebird / WS6
    Replies: 6
    Last Post: 11-21-2007, 07:53 PM
  4. Turn signal problem
    By {FzS}BlacKMagicK in forum General Help
    Replies: 10
    Last Post: 05-01-2007, 06:27 AM
  5. Turn Signal Problem
    By M.RedWS6 in forum Firebird / WS6
    Replies: 5
    Last Post: 11-25-2006, 11:02 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •