Results 1 to 3 of 3

Too odd problems

This is a discussion on Too odd problems within the Firebird / WS6 forums, part of the Vehicle Specific category; So I had the stock 16x8 wheels on the car and everything was fine. Then I put on the 17x9s ...

  1. #1
    Member speedracer25f's Avatar
    Join Date
    Nov 2007
    Location
    Bethlehem, Pa
    Age
    43
    Posts
    202

    Midnight Blue
    1998 Trans Am

    Too odd problems

    So I had the stock 16x8 wheels on the car and everything was fine. Then I put on the 17x9s with some wide Pirellis. The car is awesome on nice roads and takes off ramps at 80mph without a squeak, but on bad roads, the car is all over the place. The imperfections in the road pull the front wheels back and forth like crazy. I jacked it up and looked over the front end and everything seems tight. Someone told me big tires on the front can cause it but it seems pretty bad. Any ideas? One other odd thing, my line lock has been sticking. Was doing a burn out, let go of the switch and it just sat there. I had to stop, back up a hair, then it released. Almost seems like the calipers are hanging up. Any ideas on that one?

  2. #2
    Member Fearls1's Avatar
    Join Date
    Oct 2005
    Location
    Verdigris, OK
    Age
    35
    Posts
    289

    MRM
    2002 T/A M6

    You will get some "tracking" with wide fronts, but it shouldn't be all that crazy. I would check your tie rod ends and get an alignment. I have no idea bout the line lock. GL
    3" MagnaFlow CatBack w/Corsa (clone)Tips, Lloyds Custom Floor Mats, SLP Lid, Pro 5.0 W/ Lou's SS, 7.5" Eaton Locker w/3.73, KYB AGX, BMR LCA's, FRA, SSE, 5% Tint, 18x9 C5 Rims w/Falken 452

  3. #3
    autoconnectionllc.com 02transamce's Avatar
    Join Date
    Nov 2008
    Location
    Montgomery,Ala
    Posts
    2,436

    2007 Corvette
    Ebony

    wide tires will cause the first concern,but i would take the advice on post 2,when i worked for ford,there was a tsb about the wide tires causing the vehicle to wander with the road ruts.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 97 LT1 problems
    By james78657 in forum LT1
    Replies: 18
    Last Post: 01-20-2012, 10:30 AM
  2. Help: 62.9i problems
    By trooperrunner in forum Stereo and Electronics
    Replies: 1
    Last Post: 08-12-2009, 04:08 PM
  3. problems with my 66 g.t.o. (help)
    By 05gtoautoX in forum GTO
    Replies: 6
    Last Post: 07-11-2006, 04:49 AM
  4. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 07:26 PM
  5. A/C problems.
    By gnomee in forum General Help
    Replies: 2
    Last Post: 03-14-2006, 07:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •