Results 1 to 9 of 9

Thermostat Question???

This is a discussion on Thermostat Question??? within the Firebird / WS6 forums, part of the Vehicle Specific category; My Car doesnt have an overheating problem, but it reaches about 210 degrees max. I know thats no bad at ...

  1. #1
    IM DROPPIN THE HAMMER! Pro50gt's Avatar
    Join Date
    Nov 2005
    Location
    California
    Age
    35
    Posts
    48

    SILVER GT + RED WS6
    1990 5.0 GT + 2000 WS6

    Thermostat Question???

    My Car doesnt have an overheating problem, but it reaches about 210 degrees max. I know thats no bad at all... but in my mustang I run a 180 thermostat and it keeps everything at the perfect temp. Do any of you guys run aftermarket thermos...or do LS1's just run that cool cause there all aluminum???

  2. #2
    Member Thorazine Shuffle's Avatar
    Join Date
    Oct 2006
    Location
    Indianapolis,Indiana
    Age
    42
    Posts
    169

    Pewter
    2000 WS6 A4

    If you're judging this by the factory temp gauge, I wouldn't get too upset. I don't think they are that accurate. Mine is always at 210 when at operating temp, and all of the others I've driven are the same...

    This is just my .02 so, if I'm wrong please chime in...

  3. #3
    2000pontiac6
    Guest
    Quote Originally Posted by Thorazine Shuffle View Post
    If you're judging this by the factory temp gauge, I wouldn't get too upset. I don't think they are that accurate. Mine is always at 210 when at operating temp, and all of the others I've driven are the same...

    This is just my .02 so, if I'm wrong please chime in...
    I'm npt sure about that because my friends 98 TA says he runs at 180

  4. #4
    Member Fedge's Avatar
    Join Date
    Feb 2006
    Location
    New Jersey
    Age
    48
    Posts
    383

    Black
    1998 Trans Am M6

    well, mine was running around 215-220 according to Bill (Tuning Doctor) with the stock stat, he says now it runs around 195-205 with a 160 stat...I have a Hypertech stat...works fine, my heat is great, gets up to operaing temp fine...no complaints here
    95 Exploder

    01 R1 coming?

  5. #5
    *lick* 99_natural_beauty's Avatar
    Join Date
    Oct 2006
    Location
    Fayetteville, AR
    Age
    40
    Posts
    153

    White
    1999 Trans Am WS6

    210 is normal for these cars with the stock stat (at least the LS1s that I've seen). It's more of an idiot gauge anyway, Thorazine is right, they're not that accurate. Nothing to worry about.

  6. #6
    Firebird Encyclopedia 9T8W66's Avatar
    Join Date
    Oct 2006
    Location
    St. Clair Shores. Michigan
    Age
    49
    Posts
    1,605

    Navy Blue Metallic
    `98 Formula M6 HdTp

    `98's have a WORKING Temp Guage mine reads 180-190.

  7. #7
    Member Thorazine Shuffle's Avatar
    Join Date
    Oct 2006
    Location
    Indianapolis,Indiana
    Age
    42
    Posts
    169

    Pewter
    2000 WS6 A4

    I did some searching about this , because I was curious also. From everything I've read, the '98s were the last year to have a temp guage that was accurate. After that, it's like natural beauty said " they are more of an idiot guage than anything"...

  8. #8
    IM DROPPIN THE HAMMER! Pro50gt's Avatar
    Join Date
    Nov 2005
    Location
    California
    Age
    35
    Posts
    48

    SILVER GT + RED WS6
    1990 5.0 GT + 2000 WS6

    cool, thanks for all the help guys!

  9. #9
    Junior Member
    Join Date
    Mar 2006
    Location
    lubbock Texas
    Age
    34
    Posts
    35

    blue
    1999 pontiac Trans AM

    it is a fake gauge not true temp just lets you know if overheating and Opp. temp I have a 160 in mine and it runs at 170 so it is a good idea BUT HARD on the water pump

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: 160 thermostat
    By 2002ssslp in forum External Engine
    Replies: 11
    Last Post: 12-13-2011, 07:26 AM
  2. Help: Thermostat
    By CORYSTA in forum Firebird / WS6
    Replies: 7
    Last Post: 11-05-2010, 10:32 AM
  3. Thermostat Question
    By getcha01 in forum External Engine
    Replies: 17
    Last Post: 03-28-2009, 09:00 AM
  4. 160 Thermostat Hypertech question
    By 6speedTAthistime in forum General Help
    Replies: 22
    Last Post: 11-26-2007, 07:10 AM
  5. 160deg Thermostat Question
    By BDowning in forum General Help
    Replies: 6
    Last Post: 01-26-2007, 09:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •