Page 1 of 2 12 LastLast
Results 1 to 20 of 24

tcs off light issues

This is a discussion on tcs off light issues within the Firebird / WS6 forums, part of the Vehicle Specific category; every time i drive my car in the morning the tcs off light comes on and i can't turn it ...

  1. #1
    Member TOMASINO's Avatar
    Join Date
    Mar 2008
    Location
    downers grove
    Posts
    206

    white
    2000

    tcs off light issues

    every time i drive my car in the morning the tcs off light comes on and i can't turn it off with the switch i turn off the car and turn it back on the light goes out but as soon i drive the light (tcs off) comes on again anybody has the same problem w this?? thanks for the help...
    Last edited by TOMASINO; 11-27-2010 at 01:42 PM.

  2. #2
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    You dont need traction control on lol!!!

  3. #3
    Member TOMASINO's Avatar
    Join Date
    Mar 2008
    Location
    downers grove
    Posts
    206

    white
    2000

    i mean "off" i try to push the button but is not workin i know this is not normal cause never happen before...

  4. #4
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    so you cant get it to turn on or off?

  5. #5
    Member TOMASINO's Avatar
    Join Date
    Mar 2008
    Location
    downers grove
    Posts
    206

    white
    2000

    exactly... if the car is not moving i CAN turn it on or off but when i drive light appears in the dash (tcs off) and i can't turn it on or off with the switch

  6. #6
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Quote Originally Posted by TOMASINO View Post
    exactly... if the car is not moving i CAN turn it on or off but when i drive light appears in the dash (tcs off) and i can't turn it on or off with the switch
    Might have to do with the sensor!!!!

  7. #7
    Member TOMASINO's Avatar
    Join Date
    Mar 2008
    Location
    downers grove
    Posts
    206

    white
    2000

    thanks wich one?? and where is it?? thanks for the help

  8. #8
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    I was just reading up on some stuff and does your abs inop light come on to, cause their has been things about the speed sensors!!!

  9. #9
    Member TOMASINO's Avatar
    Join Date
    Mar 2008
    Location
    downers grove
    Posts
    206

    white
    2000

    no abs inop light

  10. #10
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    oh ok, but honestly I havent actually checked out the rear end myself, I am thinking the sensor itself will be located on the rear axle somewhere weather on the actual rear end housing or near the wheels!!!

  11. #11
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    The sensors are on the backing plate at each end of the axle. Look for the wire harness and you can't miss them. Not sure why it would act up like that and not also trip the ABS light. Does your ABS light come on when you turn your key?

  12. #12
    Member TOMASINO's Avatar
    Join Date
    Mar 2008
    Location
    downers grove
    Posts
    206

    white
    2000

    yea it does i installed 1.5 inch spacers for the rear wheels maybe it has to do with this?? is cold already this is the first time i drive the car in cold weather when i turn the key even the engine on the switch works on and off along with the light in the dash but as soon as i star driving light (tcs off) comes on and swtich won't work...

  13. #13
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I don't think spacers would have any effect. The reluctor rings for the sensors are pressed onto the ends of the axles. This is good question for Cutlass...

  14. #14
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Thanks pajeff, I wasnt real sure myself where the sensors were located, and it seems weird that the abs light wouldnt come on also since I was reading up on the problematic threads that had to do with this, and it is usually both lights and I have heard its the speed sensors!!!

  15. #15
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Typically a wheel speed sensor fault will cause a traction and ABS light. But there are a bunch of other faults that can cause a traction light by itself. The traction control is done by both the PCM(engine computer) and EBCM (ABS computer). Have the trouble codes scanned in both those computers and that should lead you to the problem.

    Post the codes up here and we'll help out.

  16. #16
    Member TOMASINO's Avatar
    Join Date
    Mar 2008
    Location
    downers grove
    Posts
    206

    white
    2000

    will do thanks!!!

  17. #17
    Pony_eater Pony_Eater's Avatar
    Join Date
    Aug 2008
    Location
    Murrieta, Ca
    Posts
    369

    Black
    2000 trans am ws6

    does it say trac control inop? thats what keeps happening to me whenever it rains and i lose traction...or if its rreally cold for some reason

  18. #18
    Member TOMASINO's Avatar
    Join Date
    Mar 2008
    Location
    downers grove
    Posts
    206

    white
    2000

    well its cold out here and it says "tcs off" amber light can't turn it off or not while driving raining dry whatever..

  19. #19
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    I would go by what cutlass said, and when you figure out what the codes are their is a place where he can look up the codes to see what it is. I was just thinking maybe the sensor itself was maybe loose or something, cause when your moving it happens when your sitting still its making a good connection maybe its dirty or its got a loose connection I was just trying to go the simple way first, but these guys know their stuff I am just kinda old school and look at the simple problems first lol hoping for the best and planning for the worst!!

  20. #20
    Member 2000dreambird's Avatar
    Join Date
    Jun 2009
    Location
    Mass
    Posts
    618

    silver/black
    00 trans am,SLP,Ws6

    I had just the trac off light come on in my car an believe it or not it was a bad wire to the MAP sensor. I did a ls6 intake swap on mine and I pulled on the wire by mistake. Once I fixed the wire the light never came back on

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: security light issues...HELP..!!!!!!!!!
    By DIRK DIGGLER in forum Stereo and Electronics
    Replies: 0
    Last Post: 09-14-2011, 07:04 AM
  2. Help: Head light issues...
    By Ptkirk in forum Firebird / WS6
    Replies: 19
    Last Post: 04-11-2009, 05:38 PM
  3. Engine Light Issues
    By BocachevyZ28 in forum General Help
    Replies: 5
    Last Post: 03-02-2009, 08:18 PM
  4. fog light issues
    By blackbirdbrain89 in forum Firebird / WS6
    Replies: 21
    Last Post: 02-04-2008, 04:29 PM
  5. Security Light Issues
    By BlackLT1Z28 in forum LT1
    Replies: 9
    Last Post: 11-20-2007, 10:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •