Results 1 to 16 of 16

T-Top Squeak/Rubbing Noise

This is a discussion on T-Top Squeak/Rubbing Noise within the Firebird / WS6 forums, part of the Vehicle Specific category; I've noticed a squeak/rubbing noise coming from my T-Tops when I am going 40+ mph. I gave it a thorough ...

  1. #1
    Junior Member
    Join Date
    Nov 2007
    Location
    Dublin, OH
    Age
    33
    Posts
    33

    Black
    2000 Trans Am WS6

    T-Top Squeak/Rubbing Noise

    I've noticed a squeak/rubbing noise coming from my T-Tops when I am going 40+ mph. I gave it a thorough cleaning, but it persists. Anyone else ever have this issue, and how did you fix?

  2. #2
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    do you have t-top shades on the tops right now??

  3. #3
    Junior Member
    Join Date
    Nov 2007
    Location
    Dublin, OH
    Age
    33
    Posts
    33

    Black
    2000 Trans Am WS6

    Nope. The shades are out.

  4. #4
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    the point on the pillars where the pins fit in when the tops or locked,......they screw in , could they be loose????

  5. #5
    Member Mike's TA's Avatar
    Join Date
    Nov 2006
    Location
    Austin, TX
    Age
    35
    Posts
    880

    Black
    99 Trans Am(sold)

    Do you have SFC's? I have heard that this will stop the majority of squeeks in our cars.

    I still need to get some.

  6. #6
    Junior Member
    Join Date
    Nov 2007
    Location
    Dublin, OH
    Age
    33
    Posts
    33

    Black
    2000 Trans Am WS6

    Cool. I'll check the screws.

    I don't have SFCs either. I may check into those, too.

  7. #7
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    i have SFC and my tops dont make any noise

  8. #8
    Member Piranhaz's Avatar
    Join Date
    Aug 2008
    Location
    Minnesota
    Age
    46
    Posts
    269

    Arctic White
    1999 Trans Am M6

    Easiest fix.....................take the tops out. That's the whole point of them right???

  9. #9
    Junior Member
    Join Date
    Nov 2007
    Location
    Dublin, OH
    Age
    33
    Posts
    33

    Black
    2000 Trans Am WS6

    Hahaha. Touché sir.

  10. #10
    Awaiting Activation
    Join Date
    Sep 2007
    Location
    Philly+Glenmoore, Pa
    Age
    28
    Posts
    4,704

    Pewter Metallic
    2002 Trans Am WS6 M6 D1SC

    My tops would make noises and rattle too but everything stopped after I put in my UMI 2pt weld-in SFCs.

  11. #11
    War Machine BIG GUNS's Avatar
    Join Date
    May 2007
    Location
    St. Louis MO.
    Age
    53
    Posts
    2,100

    Black
    00 Trans Am/Auto

    Quote Originally Posted by TransAm11973 View Post
    i have SFC and my tops dont make any noise

    What are SFCs? Need an education here......lol.

  12. #12
    Member qwk93ta's Avatar
    Join Date
    Oct 2006
    Location
    Fairfield, Ohio
    Age
    54
    Posts
    944

    Black
    00 WS6

    sub-frame connectors..........

  13. #13
    Member qwk93ta's Avatar
    Join Date
    Oct 2006
    Location
    Fairfield, Ohio
    Age
    54
    Posts
    944

    Black
    00 WS6

    Quote Originally Posted by regerror6 View Post
    I've noticed a squeak/rubbing noise coming from my T-Tops when I am going 40+ mph. I gave it a thorough cleaning, but it persists. Anyone else ever have this issue, and how did you fix?
    I sprayed some silicone in the holes where the silver pins go in and mine stopped squeaking.

  14. #14
    LINGER LONGERRR DUBB's Avatar
    Join Date
    Jun 2008
    Location
    BC,CANADA
    Posts
    696

    NBM
    02 M6 Formula

    Quote Originally Posted by BIG GUNS View Post
    What are SFCs? Need an education here......lol.
    http://www.highperformancepontiac.co...all/index.html

    weld in would be preferred though

  15. #15
    Awaiting Activation
    Join Date
    Sep 2007
    Location
    Philly+Glenmoore, Pa
    Age
    28
    Posts
    4,704

    Pewter Metallic
    2002 Trans Am WS6 M6 D1SC

    Quote Originally Posted by DUBB View Post
    Weld-in FTW. Take it to someone you trust to do it right though.

  16. #16
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    Age
    36
    Posts
    21,719

    My life is a
    Ben Stiller movie.

    I've had welded SFC's for a long time now and just rececently developed a rattle in the ttop. I think its actually inside the latch/locking mechanizm so i'm gonna rip it apart in the coming winter and mess with it to see if i can fix it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Akward squeak noise
    By Same ol Situation in forum Firebird / WS6
    Replies: 6
    Last Post: 10-19-2010, 09:40 AM
  2. 315's rubbing?
    By clint195 in forum Wheels and Tires
    Replies: 5
    Last Post: 01-17-2007, 01:46 PM
  3. Tire rubbing noise during hard right corners.
    By Blkls1 in forum Suspension and Handling
    Replies: 1
    Last Post: 12-30-2005, 10:51 AM
  4. When making a hard left i hear a rubbing sounding noise???
    By NeeD4SpeeD in forum Suspension and Handling
    Replies: 3
    Last Post: 12-27-2005, 01:06 PM
  5. Need Help with some rubbing
    By 02_WS6 in forum Suspension and Handling
    Replies: 7
    Last Post: 08-20-2005, 04:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •