Page 1 of 2 12 LastLast
Results 1 to 20 of 32

so once again another light thread

This is a discussion on so once again another light thread within the Firebird / WS6 forums, part of the Vehicle Specific category; I have replaced the harness's, i replace bulbs i have switched harness's and its gettin on my nerves. It blinks ...

  1. #1
    2002 Arctic White T/A Ws6islife's Avatar
    Join Date
    Sep 2009
    Location
    Houston , Texas
    Posts
    570

    Metallic Pewter
    2002 SLP Firehawk

    so once again another light thread

    I have replaced the harness's, i replace bulbs i have switched harness's and its gettin on my nerves. It blinks only when i do it manually if u know what i mean. Drivers side blinks just fine its the passenger that will not blink at all unless the hazards come on then they do blink, any opinions?

  2. #2
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    i dont know what you mean by switching harnesses ...but have you tried putting a new socket on ?

  3. #3
    Senior Member Schmalgar's Avatar
    Join Date
    Apr 2010
    Location
    Alpharetta, Ga
    Age
    45
    Posts
    1,060

    04 Cobra 'vert - M6 mysti
    02 WS6 coupe - A4 red

    That's usually just water burning out the bulb, as I'm sure you know. If you've changed bulbs and the harness too, I dunno...

    The only thing I can think of is that maybe you didn't get the right bulb? Maybe you got a single filament bulb in there instead of the double filament. What is it, the 3057/3157 I think? Or possible you got a bad bulb out of the box? Maybe take the bulb from the driver side that you know is working and put it in the passenger side to test?

  4. #4
    Senior Member Schmalgar's Avatar
    Join Date
    Apr 2010
    Location
    Alpharetta, Ga
    Age
    45
    Posts
    1,060

    04 Cobra 'vert - M6 mysti
    02 WS6 coupe - A4 red

    Quote Originally Posted by shady milkman View Post
    ...but have you tried putting a new socket on ?
    Yeah that too... Or at least check the existing one. It has 3 wires connecting to it, maybe one has slipped loose...?

  5. #5
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Faulty relay maybe? Or bad switch on the steering column?

  6. #6
    Member damianj03's Avatar
    Join Date
    May 2009
    Location
    saint robert, mo
    Posts
    265

    slap your mama red
    1998 trans am

    sounds like you need a new flasher to me

  7. #7
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    Try an electronic flasher you can get at any auto store if you have already changed bulbs and sockets. I use the eclectronic since I run all leds but I recommend them even with regular bulbs since they are a better replacement.
    1998 Trans Am 85k miles.
    Bolt ons, MS3 113LSA cam, Circle D Stall, Tune, Modified WS6 style hood, Full Suspension, 6000k HID's, Clear Side Markers w/ Leds, Led 3rd Brake Light and 18" AR Staggered Killer Wheels w/ BFG KDW NT's.- Weekend Toy/DD
    02 Trailblazer -Sold
    09 Ram 1500 CC - Sold
    09 Cobalt SS/TC - Sold
    13 ram 1500 LoneStar CC 4x4 - Magnaflow, K&N,and more to come-DD/Toy

  8. #8
    2002 Arctic White T/A Ws6islife's Avatar
    Join Date
    Sep 2009
    Location
    Houston , Texas
    Posts
    570

    Metallic Pewter
    2002 SLP Firehawk

    ok so a couple thigs i did

    i switched sockets/harness's and still nothing, but i did realize that my display that shows my miles doesnt light up allt he way unless my headlights are on witch i realized that when i turn my headlights on my passenger blinker comes on, but does not flash it just stays, just like when i go to turn the light indicator comes on but does not flash while my left blinker does work. also my spedometor light come on even if i dont turn the headlights on very dim but do come on. take in consideration that no the dim control isnt switched on so no reason for the gauge lights to come on. i have switched bulbs as well and nothing. im confused.

  9. #9
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    Most likely you have a bad bulb somewhere or one is put it wrong, or less likely is a wiring issue. Since the right side works ok, usually that rules out a bad flasher. Do this:

    Turn on your parking lights.
    Now put on your hazards.
    Look closely at which lights work on the right side.
    You should see the same lights work on the left side.
    If not, there is the problem, either bulb or wiring issue to the light which won't light correctly.

  10. #10
    2002 Arctic White T/A Ws6islife's Avatar
    Join Date
    Sep 2009
    Location
    Houston , Texas
    Posts
    570

    Metallic Pewter
    2002 SLP Firehawk

    i dont know what to do anymore, so many awkward things are happening the other day i get off did not touch the hatch release and my hatch was open. i turn my headlights on my passenger blinker indicator comes on i turn the car on and the led display in the spedometer wont come on unless my headlights are on my spedometer lights come on when i turn the car on even if the headlights are not on and the dimmer is off..i dont understand and the blinker still will not blink only the drivers side

  11. #11
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    ^^^You need to check the drivers side lights. Most likely you have one in wrong or one is burned out. Try the tip I gave in post #9 and tell us the results. On the back you should have two inner lights working (on each side) when they are flashing with the hazards.

    You may have other problems with lights as well, you have to get them fixed one at a time.

  12. #12
    2002 Arctic White T/A Ws6islife's Avatar
    Join Date
    Sep 2009
    Location
    Houston , Texas
    Posts
    570

    Metallic Pewter
    2002 SLP Firehawk

    so you think because of the lights my car is goign crazy? also if i turn the headlight switch once not all the way my needle for gas goes nuts and the speed

  13. #13
    2002 Arctic White T/A Ws6islife's Avatar
    Join Date
    Sep 2009
    Location
    Houston , Texas
    Posts
    570

    Metallic Pewter
    2002 SLP Firehawk

    ok so i checked the right lights are blinking while the hazards are on. I noticed when unplugging the passenger blinker on the front (the one that will not blink) everything works fine, the blinker doesnt blink slower than usual, the dash lights stay on when need be, stuff like that. But once i plug that light in hell breaks loose everything goes nuts.
    any more ideas? ive switched bulbs, i have switched sockets, i have checked for messed up wires, fuses, the flasher obviously works because one side blinks just fine.

  14. #14
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    I think the ground for the passenger front turn signal socket is open so the voltage is backfeeding through the bulb and trying to find a ground else where causing your funky problems. The ground for that socket is attached to the top right side of the radiator support.

  15. #15
    2002 Arctic White T/A Ws6islife's Avatar
    Join Date
    Sep 2009
    Location
    Houston , Texas
    Posts
    570

    Metallic Pewter
    2002 SLP Firehawk

    so how would i go about fixing this should i follow the wire see if theres a problem with it?

  16. #16
    2002 Arctic White T/A Ws6islife's Avatar
    Join Date
    Sep 2009
    Location
    Houston , Texas
    Posts
    570

    Metallic Pewter
    2002 SLP Firehawk

    so i just came from outside did a litle bit of a fuse test i noticed that when i pull fuse 5 (tail lps) the light on the dash turns off. any ideas?

  17. #17
    2002 Arctic White T/A Ws6islife's Avatar
    Join Date
    Sep 2009
    Location
    Houston , Texas
    Posts
    570

    Metallic Pewter
    2002 SLP Firehawk

    Day 5 in attempting to fix the car and wel....NOTHING

  18. #18
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    Have you tried what Cutlass suggested, in post #14? I'm a Master ASE tech also, what he says is logical. And if you pull the taillight fuse, it may be the circuit for the dash lights as well. Like I said, I don't have a wiring diagram in front of me. I may remember tomorrow to check for one at work.

    You could put a temporary jumper wire to the ground circuit of the affected light, and see what that does. ONLY if you know which wire to connect to. If not, I suggest you go to a place that can fix it, and spend a little $$$. Shouldn't cost too much.

  19. #19
    Member godless-phoenix's Avatar
    Join Date
    Jan 2010
    Location
    culver city, Ca.
    Posts
    459

    Blackened fire chicken
    2000 Pontiac Trans Am WS6

    Quote Originally Posted by damianj03 View Post
    sounds like you need a new flasher to me
    i agree

  20. #20
    2002 Arctic White T/A Ws6islife's Avatar
    Join Date
    Sep 2009
    Location
    Houston , Texas
    Posts
    570

    Metallic Pewter
    2002 SLP Firehawk

    hey toofast what exactly is it that cutlass wanted me to check because i see 2 grounds and they were tight i disconnected them and re connected but still nothing ,ir mifhr be ust skimming the top of my head

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tail Light, Head Light Lens Cleanup, Body Work Questions
    By MAXX2 in forum Appearance Section
    Replies: 3
    Last Post: 12-15-2010, 09:15 AM
  2. light up middle tail light bird
    By trans_am7935 in forum Firebird / WS6
    Replies: 16
    Last Post: 05-28-2009, 08:59 AM
  3. Adjustable Timing Light - Light Up Performance
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 03-23-2009, 07:50 AM
  4. Bud Light, Coors Light or Miller Lite?
    By Hurley711 in forum Almost Anything Goes
    Replies: 69
    Last Post: 05-26-2007, 02:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •