Results 1 to 2 of 2

signal issues....still

This is a discussion on signal issues....still within the Firebird / WS6 forums, part of the Vehicle Specific category; I know there have been several posts about issues regarding problems with the turn signals on the 4th gen f-bodies ...

  1. #1
    Junior Member 94TAGT's Avatar
    Join Date
    Apr 2007
    Location
    Fredericksburg,Virginia
    Posts
    20

    Sunfire Yellow
    1994 Trans Am GT

    Angry signal issues....still

    I know there have been several posts about issues regarding problems with the turn signals on the 4th gen f-bodies however after following some of the advice posted Im still back to square one. So the problem is this, my left side signals flash very slow if they flash at all. The issue I was originally having was no flashing at all so I replaced the flasher, the bulbs (front and back), the turn signal switch in the column, and the actual pigtail socket for the left front after finding it was corroded. Thinking positive that after all that was changed, the signal still does not work correctly. If anyone has any ideas or input it would be appreciated. Thanks.

  2. #2
    Senior Member GULLETT17's Avatar
    Join Date
    Oct 2007
    Location
    Muncie, IN
    Posts
    2,554

    00 TA PWTR, 98 VertTA NBM
    80 TA BLK, 80 Formula NBM

    i'd say its a bad ground somewhere. my buddy had a 95 ta and his taillights always did funky things but come to find out it was just a bad ground. I'd go through the wiring for your signals and brake lights and find the grounds. unscrew em, clean em shiny, screw em back in place

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 12-16-2014, 03:35 AM
  2. We need a signal
    By Dave-TransAm in forum Firebird / WS6
    Replies: 45
    Last Post: 03-30-2011, 11:49 PM
  3. Question: 98' tach signal.
    By yellowv in forum Computer & Tuning
    Replies: 4
    Last Post: 09-23-2008, 01:20 PM
  4. Turn Signal help
    By Blksilvr in forum Appearance Section
    Replies: 3
    Last Post: 07-29-2007, 09:07 AM
  5. bad signal
    By tigersport14 in forum Firebird / WS6
    Replies: 0
    Last Post: 02-18-2007, 08:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •