Results 1 to 2 of 2

Sending unit problems

This is a discussion on Sending unit problems within the Firebird / WS6 forums, part of the Vehicle Specific category; So in my 1998 trans am Im going to put the racetronix fuel pump in, with the hotwire kit. My ...

  1. #1
    Member speedracer25f's Avatar
    Join Date
    Nov 2007
    Location
    Bethlehem, Pa
    Age
    43
    Posts
    202

    Midnight Blue
    1998 Trans Am

    Sending unit problems

    So in my 1998 trans am Im going to put the racetronix fuel pump in, with the hotwire kit. My question is last summer the sending unit stopped working, how do I test which part is bad? I want to replace whatever is bad now.

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    The fuel level sensor is a variable resistor, so when you have it out you can ohm test it. 99% of the time its the level sensor that is bad.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil pressure sending unit
    By wickedWS6 in forum General Help
    Replies: 8
    Last Post: 08-13-2012, 05:09 PM
  2. Help: oil sending unit
    By ls1ws6ben in forum General Help
    Replies: 10
    Last Post: 01-31-2011, 07:41 AM
  3. Question: Oil sending unit
    By lancesT/A in forum General Help
    Replies: 7
    Last Post: 12-09-2009, 12:37 PM
  4. Help: Oil Sending Unit
    By GWTWayne in forum General Help
    Replies: 2
    Last Post: 08-10-2009, 04:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •