Results 1 to 3 of 3

rear defrost button broke

This is a discussion on rear defrost button broke within the Firebird / WS6 forums, part of the Vehicle Specific category; This is my second time, replaced it once already. I find one on ebay, but of course they want to ...

  1. #1
    Junior Member
    Join Date
    Apr 2006
    Location
    Michigan
    Age
    46
    Posts
    25

    Black
    2002 ws6

    rear defrost button broke

    This is my second time, replaced it once already. I find one on ebay, but of course they want to sell whole console, and shipping is same as the item. They won't pull the switch out.

    Anyone have tips on where to get just the switch? Or is it fixable?

    This is likely just me wasting some type, I doubt there's another way, unless maybe someone has a spare they'll sell lol, but worth a try.

    Stupid rear window defrost

    Thanks!

    --Alex

  2. #2
    Awaiting Activation
    Join Date
    Jan 2010
    Location
    Motor City MI
    Posts
    21

    red
    99 Trans Am

    What exactly is the old one doing? If it's just turning itself off very quickly, there is a quick and easy fix for that - just replace the little circuit breaker in your fuse panel with a real fuse. Worked for me....

  3. #3
    Junior Member
    Join Date
    Apr 2006
    Location
    Michigan
    Age
    46
    Posts
    25

    Black
    2002 ws6

    what the rear defrost is doing

    Yes, it lights up a little bit, i guess, but won't stay lit. Before, I replaced it and it's been fine for 3 or 4 years, so I really don't think it's a fuse, was your fuse blown? I will check tomorrow, but I'm pretty sure the fuse is fine.

    Much easier fix than the switch though, so i will check.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rear defrost?
    By gstdsm in forum Camaro / SS
    Replies: 7
    Last Post: 09-07-2010, 08:21 AM
  2. Help: shift button broke..
    By speedthatkillz in forum Automatic Transmission
    Replies: 0
    Last Post: 07-09-2010, 06:21 PM
  3. Help: Rear defrost does not work
    By kool-aide in forum General Help
    Replies: 44
    Last Post: 11-25-2009, 05:06 AM
  4. Rear Defrost Help
    By kool-aide in forum General Help
    Replies: 5
    Last Post: 12-21-2007, 03:08 PM
  5. Rear defrost tab repair
    By opprime in forum General Help
    Replies: 1
    Last Post: 10-10-2006, 06:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •