Results 1 to 11 of 11

radiator v6 or v8

This is a discussion on radiator v6 or v8 within the Firebird / WS6 forums, part of the Vehicle Specific category; I needed a radiator for my WS6 and it seems like the 5.7 v8 radiator is wrong. went to a ...

  1. #1
    Member
    Join Date
    Jun 2012
    Location
    florida
    Posts
    409

    radiator v6 or v8

    I needed a radiator for my WS6 and it seems like the 5.7 v8 radiator is wrong. went to a couple of different parts places. The v8 version has a heater hose connection on the lower left side of the car. The v6 model is correct. what gives?

  2. #2
    Member sjgreen6's Avatar
    Join Date
    Dec 2009
    Location
    Jefferson City, MO
    Posts
    476

    Navy Blue
    2002 Trans Am WS6 Conv

    Definitely sounds strange. What year is your car and are you certain that it was born a V8 and not converted at some time during it's life?

    On my 2002 WS6 the left side (driver) radiator hose enters at the top of the tank. That hose comes from the top of the water pump on the passenger side of the engine compartment, crosses over the top of the fans and includes the inline power steering cooler. The other hose on the right (passenger) side enters the radiator tank toward the bottom. That hose comes from the thermostat housing. There are two smaller hoses that enter the radiator just below the radiator cap (passenger side). One hose is for the overflow tank and the other is for the throttle body preheater. If this does not sound like yours, please post photos so we can see what you are dealing with.

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    This does sound odd... the connections should be as described by Steve. Wonder if it is some sort of "universal fit" that can be installed in a number of models. Does the radiator come with a cap or block off for the extra outlet?

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Looks like the Spectra I just looked up at Autozone is outfitted as John posted: Spectra Premium/Radiator C1486 at AutoZone.com

    My guess is that can easily be capped with a heater hose cap (usually found in the Help! section on the racks).

    WTH?

  5. #5
    Member
    Join Date
    Jun 2012
    Location
    florida
    Posts
    409

    radiator

    Its a 2002 CE so it came with a v8 for sure. I looked at some pics on the internet and found out that the port on the bottom left is for the lt1 engine. You could cap it but I wouldnt. Those help caps are made from chinese junk rubber and rot out quickly. The v6 model is an exact match. Its a mistake the vendor made. I went to different parts houses like napa and autozone and they carry the same incorrect product. So much for QAC

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    That's interesting. Did you buy one yet?

  7. #7
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    Doesn't sound right to me.
    My ride is a 2002 Camaro SS SLP #3296 with 30k, LTH, 3" Y, CME, Frost tune, K&N, ported TB, Blackwing lid, Bellows, MSD, Denso Iridium, and 85mm MAF, Bilsteins, Eibach springs, SLP strut brace, Adj. Panhard, TA Girdle, UMI, Pro 5.0, Nitto NT555
    My wife has a 2004 GTO with the rare SAP, 18" wheels, K&N Cold Air System, MSD, Ported TB, Frost tune, Denso Iridium, Flowmaster cat-back, 3200 Yank, 75k

  8. #8
    Member
    Join Date
    Jun 2012
    Location
    florida
    Posts
    409

    v6

    I originally bought the ls1 v8 model and then returned it for the v6 model. Prefect match. Do you think its hard to believe that a company that makes radiators made a mistake with their number system? Companies make QAC mistakes all the time. The lt1 radiator will fit, I just wont plug a port that is not suppose to be there. What is even worse is the v6 model that does not have the port is more money.

  9. #9
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Nothing surprises me at the parts stores anymore. I could tell you several great stories about parts they have looked up for me over the years that were just plain wrong, even when they looked them up right.

  10. #10
    Member
    Join Date
    Jun 2012
    Location
    florida
    Posts
    409

    parts store

    In this case its the vendor not the parts store. I went to different parts stores and they sold the same wrong part. typo at the vendor/manufacturer level.

  11. #11
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Ok -- that makes sense as to why they are all listed incorrectly. Good info!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Boiling sound at radiator, radiator cap blowin off
    By lanprat in forum External Engine
    Replies: 7
    Last Post: 08-05-2012, 05:29 PM
  2. Griffin radiator install, stand up radiator install
    By 02Sweet in forum External Engine
    Replies: 12
    Last Post: 06-03-2012, 06:00 PM
  3. Help: so the radiator...
    By Ws6islife in forum External Engine
    Replies: 2
    Last Post: 05-25-2011, 10:54 AM
  4. '01 Z28 Radiator
    By David Ray in forum General Help
    Replies: 3
    Last Post: 07-12-2009, 02:31 AM
  5. Replies: 0
    Last Post: 04-03-2007, 10:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •