Results 1 to 3 of 3

pls help!!!!!!

This is a discussion on pls help!!!!!! within the Firebird / WS6 forums, part of the Vehicle Specific category; my oil senser(i think thats what its called) above my oil filter is leaking oil .how can i fix this??? ...

  1. #1
    Junior Member
    Join Date
    Apr 2007
    Location
    dartmouth
    Posts
    32

    red
    1996 firebird

    pls help!!!!!!

    my oil senser(i think thats what its called) above my oil filter is leaking oil .how can i fix this??? do i need to just buy another and replace ?? pls help in need tks

  2. #2
    Junior Member JROBINSON1016's Avatar
    Join Date
    Jul 2006
    Location
    NORTH CAROLINA
    Age
    48
    Posts
    86

    RED
    1998 TRANS AM

    this is what i'd do...
    if the oil pressure guage is working fine,that means the sensor is ok.
    unless it's broken & is leaking out of it somehow.
    but i've never seen that happen.
    get some 3m weatherstrip adhesive from the parts house,it's in a tube,you can get either yellow or black,color doesn't matter to me.
    take out the sensor,clean it up good,see if you can clean out the hole with a rag,maybe some type of cleaner,as best you can.
    put some of the weatherstrip adhesive on the threads,screw it back in.
    there ya go,fixed up good as new.
    most machine shops use that stuff to seal up the freeze plugs on blocks,it works great,used it many times myself,never a problem.
    good luck.

  3. #3
    Junior Member
    Join Date
    Apr 2007
    Location
    dartmouth
    Posts
    32

    red
    1996 firebird

    Red face

    thanks i will give it a try

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •