Results 1 to 3 of 3

Passenger Bank Random Misfire

This is a discussion on Passenger Bank Random Misfire within the Firebird / WS6 forums, part of the Vehicle Specific category; I have just bought an 00 WS6 and it has a "SES" light that says random misfires, history codes show ...

  1. #1
    Junior Member
    Join Date
    Feb 2007
    Location
    Temple Texas
    Posts
    57

    Silver
    2000 WS6

    Question Passenger Bank Random Misfire

    I have just bought an 00 WS6 and it has a "SES" light that says random misfires, history codes show that the entire passenger bank has about 3500 misfires for each cyclinder. The car has long tube headers and no air pump or Egr, I had a custom tune done to fix the SES for EGR code. I'm new to the
    LS1 world and would really appreciate any help you guys could offer. I have read a few post that seem have similar problems but thought I throw out my two sense worth and I love my WS6 so far.

  2. #2
    Member ultra_badass's Avatar
    Join Date
    Mar 2007
    Location
    Corpus Christi
    Posts
    257

    navy blue matallic
    2000 WS6 trans am M6

    spark plugs could be gapped wrong...wires could be arcing....inj could be clogged...fuel filter could need to be replaced...im thinking its a fuel issue i had the same problem but on the driver side...replaced fuel filter and it all went away...fuel is vital to these cars....hope this helps a bit

  3. #3
    Junior Member
    Join Date
    Feb 2007
    Location
    Temple Texas
    Posts
    57

    Silver
    2000 WS6

    Fuel filter was changed and it had a injector service(for what its worth) already, ACDelco Iridium and wires are next on the list. Weird how it happens on one side only. Thank you for your quick reply.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trans am running bad getting a po308 misfire code on bank 8
    By Street Fighter in forum General Help
    Replies: 3
    Last Post: 02-27-2016, 05:05 AM
  2. Help: SES Flashing, Lean bank 1, Misfire #6 running poorly
    By bhunter0830 in forum General Help
    Replies: 57
    Last Post: 06-21-2012, 12:22 PM
  3. Help: Leaning out bank 2 and random miss
    By bhunter0830 in forum General Help
    Replies: 3
    Last Post: 06-10-2012, 03:21 PM
  4. Random Misfire
    By 01ws6er in forum General Help
    Replies: 3
    Last Post: 02-02-2010, 04:12 PM
  5. Help: Random Misfire!!!! HELP ME!!
    By MonteSS454 in forum General Help
    Replies: 28
    Last Post: 10-26-2009, 05:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •