Page 3 of 3 FirstFirst 123
Results 41 to 48 of 48

oil ????? synthetic???

This is a discussion on oil ????? synthetic??? within the Firebird / WS6 forums, part of the Vehicle Specific category; Originally Posted by Jims455 I just bought 6 quarts of Royal Purple for mine... I like it a lot. Thats ...

  1. #41
    Senior Member Tyler_LS1's Avatar
    Join Date
    Sep 2006
    Location
    Canby, Oregon
    Age
    29
    Posts
    2,121

    Pewter
    1999 Camaro SS-M6 #1775

    Quote Originally Posted by Jims455 View Post
    I just bought 6 quarts of Royal Purple for mine...

    I like it a lot.
    Thats what i used on mine, i had i only for one cycle but i noticed a difference

  2. #42
    Junior Member
    Join Date
    May 2006
    Location
    UK
    Age
    45
    Posts
    21

    00 white - 97 red
    trans am

    difference?

    Quote Originally Posted by Tyler_LS1 View Post
    I like it a lot.
    Thats what i used on mine, i had i only for one cycle but i noticed a difference
    what difference?

  3. #43
    Senior Member Tyler_LS1's Avatar
    Join Date
    Sep 2006
    Location
    Canby, Oregon
    Age
    29
    Posts
    2,121

    Pewter
    1999 Camaro SS-M6 #1775

    Quote Originally Posted by FERNANDO View Post
    what difference?


    it ran quieter at startup, the engine seemed to run more "free".

    it may have just been me, but overall i think it helped.

  4. #44
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    Quote Originally Posted by Tyler_LS1 View Post
    it ran quieter at startup, the engine seemed to run more "free".

    it may have just been me, but overall i think it helped.
    yea right ..j/k

  5. #45
    Senior Member Tyler_LS1's Avatar
    Join Date
    Sep 2006
    Location
    Canby, Oregon
    Age
    29
    Posts
    2,121

    Pewter
    1999 Camaro SS-M6 #1775

    anyone else have good results with RP?

  6. #46
    Junior Member
    Join Date
    May 2006
    Location
    UK
    Age
    45
    Posts
    21

    00 white - 97 red
    trans am

    switched back to valvoline

    i don't care if it's 50% water, my t/a loves valvoline.

    got rid of the highly acclaimed mobil and put valvoline maxlife 10w30. piston slap is totally gone, hard starts are gone, rough idle is gone, and it feels like it revs a bit faster.

    that ticking noise is back though. my friend's firehawk does the same thing. i was told it was the injectors pulsing away. are injectors really that loud or is it my buddy’s wild guess, who knows...

    valvoline has been around for like 130 years, at least that's what their website states.

    i'm sticking with valvoline from now on and it's cheaper.

    tylerls1 - sorry but i was going to try rp and decided to go back to what works for my car. she has 77k miles btw.

  7. #47
    Senior Member Tyler_LS1's Avatar
    Join Date
    Sep 2006
    Location
    Canby, Oregon
    Age
    29
    Posts
    2,121

    Pewter
    1999 Camaro SS-M6 #1775

    Quote Originally Posted by FERNANDO View Post
    i don't care if it's 50% water, my t/a loves valvoline.

    got rid of the highly acclaimed mobil and put valvoline maxlife 10w30. piston slap is totally gone, hard starts are gone, rough idle is gone, and it feels like it revs a bit faster.

    that ticking noise is back though. my friend's firehawk does the same thing. i was told it was the injectors pulsing away. are injectors really that loud or is it my buddy’s wild guess, who knows...

    valvoline has been around for like 130 years, at least that's what their website states.

    i'm sticking with valvoline from now on and it's cheaper.

    tylerls1 - sorry but i was going to try rp and decided to go back to what works for my car. she has 77k miles btw.
    thats great! i had vavloline in my car when i first got it it wasnt to bad, i used the Valvoline full synthetic power max or something like that.

    not all peoples driving habits are the same so different oils can make a difference, i tried Valvoline Mobil 1 and RP and I just like to RP better, its just what ever works for your car and your driving habits.


    the noise should not be the injectors unless they are really plugged up.

    diesels have that distinguished tick sound thats the injectors, they are pushing much more PSI though them than we are on our LS1's.

  8. #48
    Think Spring..... 4get gto's Avatar
    Join Date
    Aug 2005
    Location
    Northampton County, Pa.
    Posts
    1,147

    NBM
    2000 WS6

    Quote Originally Posted by 123456speed View Post
    it depends on what base the oil is... an oil like mobil 1 you can switch.. if you use something like AMSOIL you are not recommend to switch back at all..

    All the talk about switching back to conventional I think is nonsense. No proof anywhere that I'm aware of..

    Mine never knocked UNTIL I went to Mobil 1.
    Switched back to dino oil and ticking went away..
    2000 NBM WS6

    /oo_________oo\
    |==_/_ws6_\_==|

    ><(((º>´¯`·.¸¸.·´¯`·.¸¸><((((º>

Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Synthetic oil after 100k
    By johnfin in forum Internal Engine
    Replies: 4
    Last Post: 08-18-2016, 07:34 AM
  2. Best Synthetic?
    By Sarge in forum Almost Anything Goes
    Replies: 2
    Last Post: 05-22-2009, 06:38 AM
  3. when is it too late to use synthetic oil
    By jinouk67 in forum GTO
    Replies: 4
    Last Post: 07-01-2007, 04:17 PM
  4. Mobil1 100% Synthetic Not
    By Sarge in forum General Help
    Replies: 105
    Last Post: 06-02-2007, 07:59 PM
  5. Synthetic ATF Ok or Not?
    By sfletch2000 in forum Manual Transmission
    Replies: 7
    Last Post: 05-24-2007, 01:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •