Results 1 to 4 of 4

Oil question

This is a discussion on Oil question within the Firebird / WS6 forums, part of the Vehicle Specific category; I will be doing the oil on my WS6 tomorrow and I will go with Mobil 1 synthetic but I ...

  1. #1
    Member 1998 T/A's Avatar
    Join Date
    Aug 2008
    Location
    Huron Ohio
    Posts
    759

    Black
    2000 WS6 Trans AM

    Oil question

    I will be doing the oil on my WS6 tomorrow and I will go with Mobil 1 synthetic but I have a question on weight. The car will not be run during the winter months and will see temps no lower than 40 degrees, that being said I will probably just go with 5 dub-ya 30 and should I maybe grab the high mileage blend or is reg synthetic ok?

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Unless you have experienced a drop in oil pressure, I would probably stick with the regular 5W-30 synthetic oil.

  3. #3
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    It sounds like your car is a weekend vehicle and not a DD so I would stick with the 5W-30 Mobil 1. My cars only do 3k miles per year so I change the oil only once every spring with Mobil 1 5w-30 and a K&N filter. Use the best products and you will get the best results.
    My ride is a 2002 Camaro SS SLP #3296 with 30k, LTH, 3" Y, CME, Frost tune, K&N, ported TB, Blackwing lid, Bellows, MSD, Denso Iridium, and 85mm MAF, Bilsteins, Eibach springs, SLP strut brace, Adj. Panhard, TA Girdle, UMI, Pro 5.0, Nitto NT555
    My wife has a 2004 GTO with the rare SAP, 18" wheels, K&N Cold Air System, MSD, Ported TB, Frost tune, Denso Iridium, Flowmaster cat-back, 3200 Yank, 75k

  4. #4
    Member 1998 T/A's Avatar
    Join Date
    Aug 2008
    Location
    Huron Ohio
    Posts
    759

    Black
    2000 WS6 Trans AM

    Oil pressure I believe is fine, it sits smack dab I'm the middle at cold temps then at operating temp drops to about halfway between the 40 and the other tick on the left. If that makes any sense.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. speedometer question + top speed question
    By Krazy351w in forum General Help
    Replies: 7
    Last Post: 06-21-2007, 06:51 PM
  2. HPIII question (not the same old question)
    By slims00ls1z28 in forum Computer & Tuning
    Replies: 5
    Last Post: 06-01-2007, 05:55 PM
  3. 97 Bird Headlight question also engine noise question
    By Zapper2003 in forum General Help
    Replies: 2
    Last Post: 12-13-2006, 04:03 AM
  4. Speedometer question, RPO question
    By acrylicophobia in forum Firebird / WS6
    Replies: 12
    Last Post: 11-02-2006, 08:08 AM
  5. Sex Question spinoff- PORN QUESTION
    By egaian in forum Almost Anything Goes
    Replies: 77
    Last Post: 07-26-2006, 04:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •