Results 1 to 5 of 5

O2 Sim question

This is a discussion on O2 Sim question within the Firebird / WS6 forums, part of the Vehicle Specific category; So my car dumped to about 8 mpg on me recently and while i was looking for possible causes i ...

  1. #1
    Junior Member
    Join Date
    Oct 2007
    Location
    Indiana
    Posts
    96

    Pewter
    2001 Trans Am

    O2 Sim question

    So my car dumped to about 8 mpg on me recently and while i was looking for possible causes i found my 02 sims. I didnt install the sims the previous owner did and while I did not get SES (i never have for anything) it is showing up in the obd2 scans. My sims seen here (http://www.ftpp.net/images/CaspersEl.../104033-1.jpeg) have LED's on them presumably for verification of function.

    One side had come loose, I plugged it back in and it lit up while the car was on (not running).... GREAT! On to the other side.

    Not on, plugged in. So I grabbed the good one from the other side and plugged it in... no luck... took the one off the bad side and tried it on the good side. No luck either... Now what? My good one doesnt work on one side and the one from the bad side doesnt work on the good side.

    I had a volt meter on so i tested the connection from the car. The connector from the car had voltage so I dont know where to go next. Any suggestions? What should the voltage be?

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    The rear O2 senders simply provide feedback to the PCM to tell it if the cats are working. They have nothing to do with your fueling. If for some reason you have sims plugged into your front O2 senders -- that is a huge problem and needs to be rectified immediately.

    Other possible issues:

    Dirty air filter, dirty MAF, air leak in the exhaust fooling the O2's into calling for more fuel, worn plugs, and of course... heavy right foot.

  3. #3
    Junior Member
    Join Date
    Oct 2007
    Location
    Indiana
    Posts
    96

    Pewter
    2001 Trans Am

    So only to prevent SES light... case closed

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by SilentTrouble View Post
    So only to prevent SES light... case closed

    Exactly. Forgot to mention, that if your front O2's are starting to go that can also affect fueling. Any access to a scanner so you can see your sensor output and fuel trims?

  5. #5
    Junior Member
    Join Date
    Oct 2007
    Location
    Indiana
    Posts
    96

    Pewter
    2001 Trans Am

    Naw but im betting theres another problem...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. speedometer question + top speed question
    By Krazy351w in forum General Help
    Replies: 7
    Last Post: 06-21-2007, 06:51 PM
  2. HPIII question (not the same old question)
    By slims00ls1z28 in forum Computer & Tuning
    Replies: 5
    Last Post: 06-01-2007, 05:55 PM
  3. 97 Bird Headlight question also engine noise question
    By Zapper2003 in forum General Help
    Replies: 2
    Last Post: 12-13-2006, 04:03 AM
  4. Speedometer question, RPO question
    By acrylicophobia in forum Firebird / WS6
    Replies: 12
    Last Post: 11-02-2006, 08:08 AM
  5. Sex Question spinoff- PORN QUESTION
    By egaian in forum Almost Anything Goes
    Replies: 77
    Last Post: 07-26-2006, 04:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •