Results 1 to 12 of 12

Not Running Right . . .

This is a discussion on Not Running Right . . . within the Firebird / WS6 forums, part of the Vehicle Specific category; I have a 94 Trans Am ..... Bought used .. and it was running fine. . Now .. it takes ...

  1. #1
    chadrick
    Guest

    Not Running Right . . .

    I have a 94 Trans Am .....

    Bought used .. and it was running fine. .

    Now .. it takes spells. . . where the RPM's are jumpy .. and its laggin bad . . .
    Took it to the shop.. and they said. .come get her we fixed her ..
    [and they replaced the plugs and wires. ... on the way home...

    still doing it ...
    Im no mechanic .. .but do you think it could be the fuel filter or pump ??

    All help appriciated.

  2. #2
    Story of My Life!! BIG D's SS's Avatar
    Join Date
    Aug 2005
    Location
    Commerce Ga
    Age
    40
    Posts
    4,995

    Black, Blue
    07 TBSS, 07 GSXR1000

    Might be the opti spark.

  3. #3
    Member Tman's Avatar
    Join Date
    Aug 2005
    Location
    Woodstock, GA
    Posts
    469

    Black
    2000 WS6

    Are you seeing any Service Engine Soon (SES) or Check Engine light indications? If so, what is the code(s) ?

  4. #4
    chadrick
    Guest
    nope .. no check engine light... .. Um....

  5. #5
    Story of My Life!! BIG D's SS's Avatar
    Join Date
    Aug 2005
    Location
    Commerce Ga
    Age
    40
    Posts
    4,995

    Black, Blue
    07 TBSS, 07 GSXR1000

    Does it do it when it is hot or cold under a load or what. I would just about bet it is your opti spark.

  6. #6
    chadrick
    Guest
    Its really random. . sometimes i take it down the road its running like a scalded dog ... . then others. .. its lugging bad. . .
    and when im in a drive through and let off the brake. . it feels like its rocking foward. .. ???

  7. #7
    Story of My Life!! BIG D's SS's Avatar
    Join Date
    Aug 2005
    Location
    Commerce Ga
    Age
    40
    Posts
    4,995

    Black, Blue
    07 TBSS, 07 GSXR1000

    I hate to keep saying it but look under it and see if it is wet around the crank seal. I would almost bet it's the opti spark. That is really th only problems those cars have. We had about 5 guys in a month have that problem.

  8. #8
    Senior Member Zboner's Avatar
    Join Date
    Aug 2005
    Location
    cincinnati/northern ky
    Age
    31
    Posts
    9,045

    Black
    99 SS

    same up here man, a lot of opti problems

  9. #9
    chadrick
    Guest
    if it is that. . whats that going to cost me. . lol ?

  10. #10
    Story of My Life!! BIG D's SS's Avatar
    Join Date
    Aug 2005
    Location
    Commerce Ga
    Age
    40
    Posts
    4,995

    Black, Blue
    07 TBSS, 07 GSXR1000

    Your probably lookin about 300 for parts and then close to the same if you can't do it yourself.

  11. #11
    chadrick
    Guest
    I'll keep you all up to date. ......

  12. #12
    Story of My Life!! BIG D's SS's Avatar
    Join Date
    Aug 2005
    Location
    Commerce Ga
    Age
    40
    Posts
    4,995

    Black, Blue
    07 TBSS, 07 GSXR1000

    Alright good luck with it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Running rough if running at all help
    By ichliebecamaro in forum LT1
    Replies: 3
    Last Post: 01-25-2010, 11:54 AM
  2. Car is Running
    By Ed Blown Vert in forum Almost Anything Goes
    Replies: 106
    Last Post: 11-11-2009, 02:21 PM
  3. Question: running 12`s
    By SSMOKEshow in forum Drag Racing
    Replies: 41
    Last Post: 03-15-2008, 06:42 AM
  4. Got The Car Running Again But
    By theslow00 in forum Western Members
    Replies: 8
    Last Post: 03-05-2008, 01:08 PM
  5. Need help, car not running right?
    By blackSS01 in forum General Help
    Replies: 5
    Last Post: 10-15-2006, 09:20 AM

Members who have read this thread: 0

There are no members to list at the moment.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •