Results 1 to 11 of 11

noise question????

This is a discussion on noise question???? within the Firebird / WS6 forums, part of the Vehicle Specific category; has anyone done the electic water pump swap....if so is it worth it??....bkuz i think mine is about to go ...

  1. #1
    Member Firebirdformula's Avatar
    Join Date
    Feb 2009
    Location
    oklahoma
    Posts
    146

    black
    2000 firebird formula Ws6

    noise question????

    has anyone done the electic water pump swap....if so is it worth it??....bkuz i think mine is about to go out....i started my car this morning and out of no where a loud screech starts as soon as it fires up.....it was way louder then a belt squeek..and lasted maybe a minute.....it hasnt really done it much or as loud as it was this morning...but i can here it when im coming to a stop but barely. and my temp is normal and my charging is where it should be..i havent been able to pull the belt off and spin the pulleys...but hopefully i can soon anyone have any ideas??

  2. #2
    Member jagfan93's Avatar
    Join Date
    Sep 2009
    Location
    Florida
    Posts
    159

    Yellow
    02 CETA#732

    how many miles you got?

  3. #3
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    that sounds like a A/C issue..remove the ac belt and see if it fixes it.

  4. #4
    Member Firebirdformula's Avatar
    Join Date
    Feb 2009
    Location
    oklahoma
    Posts
    146

    black
    2000 firebird formula Ws6

    i have about 89,000 , ya i thot so to but i had an ac tensioner go out and it didnt sound like that....plus i turned the ac on and off and the heater on and off and nothing did a dam thing....but hell if its the ac...im yanking that shit out lol jus one less thing to break

  5. #5
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    Quote Originally Posted by Firebirdformula View Post
    i have about 89,000 , ya i thot so to but i had an ac tensioner go out and it didnt sound like that....plus i turned the ac on and off and the heater on and off and nothing did a dam thing....but hell if its the ac...im yanking that shit out lol jus one less thing to break
    yea just take off the belt first and see if it stops screeching

  6. #6
    Member Firebirdformula's Avatar
    Join Date
    Feb 2009
    Location
    oklahoma
    Posts
    146

    black
    2000 firebird formula Ws6

    ok cool i will thx man

  7. #7
    Member jagfan93's Avatar
    Join Date
    Sep 2009
    Location
    Florida
    Posts
    159

    Yellow
    02 CETA#732

    agree with trying a/c belt first, if that's not it then I've had alternators do exactly what you describe at about that mileage.

  8. #8
    Member Firebirdformula's Avatar
    Join Date
    Feb 2009
    Location
    oklahoma
    Posts
    146

    black
    2000 firebird formula Ws6

    ok cool, ya thats why im going to take the belt off and turn everything ....but its random when it does it? which sux...im not saying i want it to be constant haha but i jus hope i can find it

  9. #9
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    just run the car without the a/c for a few days and see if it comes back

  10. #10
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    as the belt is not needed.

  11. #11
    Member Firebirdformula's Avatar
    Join Date
    Feb 2009
    Location
    oklahoma
    Posts
    146

    black
    2000 firebird formula Ws6

    right on ya ill take it off tonight

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gear install/noise question
    By LeadFarmer in forum Drivetrain
    Replies: 6
    Last Post: 04-20-2010, 11:03 AM
  2. Question about putting noise in second
    By Patsy57 in forum External Engine
    Replies: 5
    Last Post: 03-22-2008, 04:25 PM
  3. belt tension/noise + hypertech programmer question
    By AntsSilverC5 in forum Corvette
    Replies: 14
    Last Post: 03-24-2007, 11:31 AM
  4. 97 Bird Headlight question also engine noise question
    By Zapper2003 in forum General Help
    Replies: 2
    Last Post: 12-13-2006, 04:03 AM
  5. What is this noise?!
    By BigFed in forum Firebird / WS6
    Replies: 11
    Last Post: 06-11-2006, 05:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •