Results 1 to 2 of 2

Need some help please!!!!!

This is a discussion on Need some help please!!!!! within the Firebird / WS6 forums, part of the Vehicle Specific category; I just got home from work. And when I reached a straight away I let er' rip!!! And all of ...

  1. #1
    Senior Member clg82's Avatar
    Join Date
    Feb 2007
    Location
    California
    Age
    35
    Posts
    2,453
    2000 Trans Am

    Need some help please!!!!!

    I just got home from work. And when I reached a straight away I let er' rip!!! And all of a sudden I noticed that my lights started to dim and my battery gauge started to read in the red!!! So I got off the throttle and everything started to read normal. So I got on it again and still the same thing, the voltage gauge started reading in the red!!! All the lights dimmed but the car still continued to accelerate!! What in the hell is going on?!?!? Someone please help!
    2000 Arctic White trans am, ws6 hood, ws6 air box, slp lid, slp smooth bellows, slp loudmouth exhaust,shift kit, rebuilt trans, LS6 intake, 3.73 gears, Shaner S3 p/p throttle body, and a tune . SFC. C6 ZO6 rims 18" in back 17" in front. Drilled and slotted rotors.

  2. #2
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    The alternator shuts off at high rpm, forget exactly where, but I would go to a battery shop & usually they will check the charging & battery for free !!! Good Luck !

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •