Page 2 of 2 FirstFirst 12
Results 21 to 27 of 27
Like Tree1Likes

Need help/advice for new ws6!!

This is a discussion on Need help/advice for new ws6!! within the Firebird / WS6 forums, part of the Vehicle Specific category; congrats......I can tell you real quick about the quarter panel. Someone has lifted the car incorrectly and broken the tabs ...

  1. #21
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    congrats......I can tell you real quick about the quarter panel. Someone has lifted the car incorrectly and broken the tabs off that hold that panel at the bottom. Look under the car behind the front tire and you'll see the 2 bolts that hold the tab. I would bet you that it broke right there. Very common mistake people make......and a costly one. You can try to epoxy it and get it back to where it needs to be but you'll probably find the only way to get it to where it looks right is to replace that quarter panel. Good luck and hope that works out for you. Sounds like you got a pretty good deal on the car though in general with those miles. Make it fast as shit and that quarter panel won't mean anything.

  2. #22
    Junior Member
    Join Date
    Apr 2014
    Location
    United States
    Posts
    74
    Quote Originally Posted by 0rion View Post
    congrats......I can tell you real quick about the quarter panel. Someone has lifted the car incorrectly and broken the tabs off that hold that panel at the bottom. Look under the car behind the front tire and you'll see the 2 bolts that hold the tab. I would bet you that it broke right there. Very common mistake people make......and a costly one. You can try to epoxy it and get it back to where it needs to be but you'll probably find the only way to get it to where it looks right is to replace that quarter panel. Good luck and hope that works out for you. Sounds like you got a pretty good deal on the car though in general with those miles. Make it fast as shit and that quarter panel won't mean anything.
    Yup..that's exactly what happened. When i got the steering rack replaced, i saw it on the lift and i realized that the left quarter panel tab with the bolts was completely broken off. What the guy did was pretty much just drill a screw into the bottom of the panel and it actually looks perfect...Now, with the right side, the tab is still there, not broken off. However, i think it just got bent from the lift, which pushed the panel out a little. I'll try to take it to a body shop to see what they can do to adjust it.
    Now, i have a separate question, i wanna see if you can help: Any time i step on the gas from a light, or just a complete stop, and go fast, i can feel/hear a couple of thumps/knocks under the car, around maybe where the y-pipe/exhaust is. When i'm on neutral and rev the engine, it doesnt happen...only when going fast from a complete stop. The knock/thumps are pretty loud tbh, and at first i thought it was the y-pip hitting the ground, since it sags a little...but even on flat street level, it happens...it only happens when i step on the gas substantially, but at regular speed it doesn't happen. What do you think?

  3. #23
    Member 1998 T/A's Avatar
    Join Date
    Aug 2008
    Location
    Huron Ohio
    Posts
    759

    Black
    2000 WS6 Trans AM

    From my experience it was clutch, don't ask me how all I know is I had the same issue and the clutch eventually went out (maybe a week later) then replaced and I no longer had an issue. I can't remember if you said it was auto or not. However it could be your rear end waiting to blow. On my T/A when I had it it would clunk really loud from the rear on a huge launch and then boom the rear stopped moving. Took the diff cover off and my 4.10s dropped into the oil pan in 300 pieces.

  4. #24
    Junior Member
    Join Date
    Apr 2014
    Location
    Goodyear
    Posts
    3

    Black
    98 trans am ws6

    definitely a good choice on the z28

  5. #25
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    Quote Originally Posted by sezo View Post
    Yup..that's exactly what happened. When i got the steering rack replaced, i saw it on the lift and i realized that the left quarter panel tab with the bolts was completely broken off. What the guy did was pretty much just drill a screw into the bottom of the panel and it actually looks perfect...Now, with the right side, the tab is still there, not broken off. However, i think it just got bent from the lift, which pushed the panel out a little. I'll try to take it to a body shop to see what they can do to adjust it.
    Now, i have a separate question, i wanna see if you can help: Any time i step on the gas from a light, or just a complete stop, and go fast, i can feel/hear a couple of thumps/knocks under the car, around maybe where the y-pipe/exhaust is. When i'm on neutral and rev the engine, it doesnt happen...only when going fast from a complete stop. The knock/thumps are pretty loud tbh, and at first i thought it was the y-pip hitting the ground, since it sags a little...but even on flat street level, it happens...it only happens when i step on the gas substantially, but at regular speed it doesn't happen. What do you think?
    I bet if you look at your tranny mount it's done. It could be the Y coming up and hitting the floorboard when the motor torques but my money from your description is on that tranny mount. Easy and cheap to replace. If it's the Y they usually hit directly under the drivers seat where that drivers side bend is in the Y. You could shove a piece of rubber hose between the floor and pipe and take it for a drive and see if it does it....that'll tell you if the Y is hitting. That's an easy fix too so if it's the Y let me know and I'll explain how I fixed mine. They sell a $40 clamp that mufflex I believe makes that'll stop the Y pipe bang but I got mine to stop without all that.

    Like I say though....your description is a classic tranny mount problem. It's at the rear of the tranny where it mounts to the cross member.

  6. #26
    Junior Member
    Join Date
    Apr 2014
    Location
    United States
    Posts
    74
    Quote Originally Posted by William L Grewe Jr View Post
    definitely a good choice on the z28
    Thanks, i'm really glad i waited

  7. #27
    Junior Member
    Join Date
    Apr 2014
    Location
    United States
    Posts
    74
    Quote Originally Posted by 0rion View Post
    I bet if you look at your tranny mount it's done. It could be the Y coming up and hitting the floorboard when the motor torques but my money from your description is on that tranny mount. Easy and cheap to replace. If it's the Y they usually hit directly under the drivers seat where that drivers side bend is in the Y. You could shove a piece of rubber hose between the floor and pipe and take it for a drive and see if it does it....that'll tell you if the Y is hitting. That's an easy fix too so if it's the Y let me know and I'll explain how I fixed mine. They sell a $40 clamp that mufflex I believe makes that'll stop the Y pipe bang but I got mine to stop without all that.

    Like I say though....your description is a classic tranny mount problem. It's at the rear of the tranny where it mounts to the cross member.
    Thanks for the help. Unfortunately i don't have a stand/ramp or anything, so i'd have to take it to the local mechanic. I'll have him test drive it to show him what i'm talking about. Hopefully he can figure it out. The banging noise is pretty loud/ hits pretty hard. It's hard enough to feel it under my seat and the floor board. It sounds like someone underneath smashed my pipe with something, it kinda scares me lol. It's also like a popping noise, kinda hard to explain

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New, need advice.
    By tomscamaro00 in forum New Member Introductions
    Replies: 5
    Last Post: 04-05-2010, 07:26 PM
  2. Need advice, possibly legal advice
    By JHayesLS1 in forum Almost Anything Goes
    Replies: 36
    Last Post: 12-19-2009, 10:23 AM
  3. Need serious advice...alot of advice. Long.
    By !!!FAST!!! in forum Almost Anything Goes
    Replies: 0
    Last Post: 10-31-2007, 08:49 PM
  4. Hello, and need advice
    By jpwamt in forum New Member Introductions
    Replies: 4
    Last Post: 12-19-2006, 08:18 PM
  5. Need ADVICE
    By dblanch35 in forum Automatic Transmission
    Replies: 1
    Last Post: 12-16-2006, 11:56 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •