Results 1 to 16 of 16

Need help with 02, V6 Firebird!

This is a discussion on Need help with 02, V6 Firebird! within the Firebird / WS6 forums, part of the Vehicle Specific category; I own an 02, 5-speed firebird that has 156,000 miles on it. It has always ran great untill the past ...

  1. #1
    Junior Member twinshow02's Avatar
    Join Date
    Jun 2011
    Location
    Mississippi
    Posts
    5

    pewter
    02 firebird

    Need help with 02, V6 Firebird!

    I own an 02, 5-speed firebird that has 156,000 miles on it. It has always ran great untill the past couple of weeks. It constantly wants to throw timing, making me lose half my horsepower. One min I can cruise down the road, the next min my car dosn't want to reach 60mph. I have replaced the fuel pump, catalytic converter, and Ecm. Also checked fuel pressure, sensors, and wires but nothing has made any bit of diffrence. Any ideas?

  2. #2
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    stop throwing money at it and take it to a shop

  3. #3
    Member damianj03's Avatar
    Join Date
    May 2009
    Location
    saint robert, mo
    Posts
    265

    slap your mama red
    1998 trans am

    1 how do you know its the timimg?
    2 does it throw any codes? If so have you had the codes checked?
    3 also could be a bad 02 sensor.

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Have you had a scanner on the car?

  5. #5
    Junior Member twinshow02's Avatar
    Join Date
    Jun 2011
    Location
    Mississippi
    Posts
    5

    pewter
    02 firebird

    I have taken it to 2 diffrent shops and a personal friend who works with alot of firebird T/As. It's not throwing any codes , checked the 02 sensors, and yes I have had a scanner hooked up to it. Says its running 10 degrees off.
    Last edited by twinshow02; 06-27-2011 at 09:49 PM.

  6. #6
    FASTER THNA SPEEDINtICKEt BANDITO's Avatar
    Join Date
    Apr 2008
    Location
    A, A
    Age
    28
    Posts
    281

    White
    2002 trans-am

    Are the injectors bad?

  7. #7
    Junior Member twinshow02's Avatar
    Join Date
    Jun 2011
    Location
    Mississippi
    Posts
    5

    pewter
    02 firebird

    Quote Originally Posted by BANDITO View Post
    Are the injectors bad?
    No, checked those 2.

  8. #8
    FASTER THNA SPEEDINtICKEt BANDITO's Avatar
    Join Date
    Apr 2008
    Location
    A, A
    Age
    28
    Posts
    281

    White
    2002 trans-am

    what about the vac. lines on the intake? maybe the throttle position sensor or manifold leak?

  9. #9
    Member damianj03's Avatar
    Join Date
    May 2009
    Location
    saint robert, mo
    Posts
    265

    slap your mama red
    1998 trans am

    check the heater hoses that are in the front of th passenger side of the engine. Mine on my 97 maro with the 3.8 liter started leaking from there and was dripping onto a dry rotted wireharness and would make my car do crazy shit.

  10. #10
    Junior Member twinshow02's Avatar
    Join Date
    Jun 2011
    Location
    Mississippi
    Posts
    5

    pewter
    02 firebird

    Quote Originally Posted by BANDITO View Post
    what about the vac. lines on the intake? maybe the throttle position sensor or manifold leak?
    Checked those aswell. Not leaking any water/fluid anywhere.

  11. #11
    Member damianj03's Avatar
    Join Date
    May 2009
    Location
    saint robert, mo
    Posts
    265

    slap your mama red
    1998 trans am

    i dont understand how a electronically contolled timing car can advance in timing? I mean i have had a serpentine belt break along with 2 pulleys and the car still ran off of the battery all of the way home. Has any work been done to the car recently and how long have you had the car?

  12. #12
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Can the OP please explain how it is being determined that the "timing is 10 degrees off"?

  13. #13
    Junior Member twinshow02's Avatar
    Join Date
    Jun 2011
    Location
    Mississippi
    Posts
    5

    pewter
    02 firebird

    Quote Originally Posted by pajeff02 View Post
    Can the OP please explain how it is being determined that the "timing is 10 degrees off"?
    I just called my buddy who helped me with it. He says the engine is detecting 15 degrees of knock which is the max and both knock sensors ohm'd out to spec. When he manually adds the timing back, the car stops rattling and sound/runs fine.

  14. #14
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by twinshow02 View Post
    I just called my buddy who helped me with it. He says the engine is detecting 15 degrees of knock which is the max and both knock sensors ohm'd out to spec. When he manually adds the timing back, the car stops rattling and sound/runs fine.

    If the PCM has the timing retarded 15 degrees, there should be no knock at all unless the car has other issues. If anything, adding the timing back in should result in knock under load, not remove it. Strange...

  15. #15
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by twinshow02 View Post
    Checked those aswell. Not leaking any water/fluid anywhere.
    How did you check the TPS on a throttle by wire car???

  16. #16
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by pajeff02 View Post
    If the PCM has the timing retarded 15 degrees, there should be no knock at all unless the car has other issues. If anything, adding the timing back in should result in knock under load, not remove it. Strange...
    +2.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. For Sale: Firebird gone! 98-02 firebird camaro parts left in my garage
    By JayTA98 in forum Parts For Sale / Trade
    Replies: 24
    Last Post: 03-08-2015, 05:25 PM
  2. 1972 Pontiac Firebird Vs. 2001 Firebird Formula - HPP Paveme
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 09-05-2012, 07:10 PM
  3. Firebird to T/A
    By TurboTom in forum New Member Introductions
    Replies: 10
    Last Post: 01-04-2009, 11:07 AM
  4. My Firebird
    By MegaMan in forum Member's Rides
    Replies: 1
    Last Post: 07-23-2007, 08:01 PM
  5. Stock Firebird Hood off my 2000 Firebird
    By blackbird04 in forum Parts For Sale / Trade
    Replies: 0
    Last Post: 09-15-2006, 08:12 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •