Results 1 to 6 of 6

my oil pressure...

This is a discussion on my oil pressure... within the Firebird / WS6 forums, part of the Vehicle Specific category; the gage sometimes says 20 then next time i go to turn it un it turns to 40 and once ...

  1. #1
    2002 Arctic White T/A Ws6islife's Avatar
    Join Date
    Sep 2009
    Location
    Houston , Texas
    Posts
    570

    Metallic Pewter
    2002 SLP Firehawk

    my oil pressure...

    the gage sometimes says 20 then next time i go to turn it un it turns to 40 and once again to 20..i have been having a small oil seep..witch im gettin fixed this comming weekend but i dunno is my oil pump going out? or what is going on any help would be appreciated..

  2. #2
    Junior Member
    Join Date
    Apr 2007
    Location
    Indianapolis, IN, USA
    Posts
    63

    Red
    1998 WS6 Trans Am

    heh my guage goes all over the place and it scares me to death. Hopefully it's just a sensor problem for you and myself as well. Someone once said they can go bad even after replacing em it often happens again. I'll post a video sometime when it stops snowing.

  3. #3
    Member goof4080's Avatar
    Join Date
    Jun 2009
    Location
    lisle, il
    Posts
    290

    Red, Black
    98 T/A M6, 79 T/A 6.6L

    my guage is very choppy sometimes. don't remember what exactly it runs tho. probably between 20-40 depending on oil temp and rpm with castrol gtx 5w30

  4. #4
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by enkryptik View Post
    heh my guage goes all over the place and it scares me to death. Hopefully it's just a sensor problem for you and myself as well. Someone once said they can go bad even after replacing em it often happens again. I'll post a video sometime when it stops snowing.
    Normal..

  5. #5
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Wink

    Quote Originally Posted by Ws6islife View Post
    the gage sometimes says 20 then next time i go to turn it un it turns to 40 and once again to 20..i have been having a small oil seep..witch im gettin fixed this comming weekend but i dunno is my oil pump going out? or what is going on any help would be appreciated..
    normal x2
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  6. #6
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    When the oil is cold it's "thicker" than when it's hot. Oil idle pressure when cold always reads higher than when hot. Could be a guage prob but tust me if there was issues with your pump yall would be walking. Oil pumps tend to either work or fail.. A heavily worn oil pump = a dead pump imho..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: oil pressure
    By Z28boy2000 in forum General Help
    Replies: 16
    Last Post: 07-14-2009, 08:32 AM
  2. Help: Oil pressure goes down!??
    By 98T/A.SNAKEATER_ in forum General Help
    Replies: 15
    Last Post: 11-02-2008, 07:08 AM
  3. Replies: 3
    Last Post: 04-01-2006, 04:59 PM
  4. Looking for gauges! nitrous pressure, fuel pressure!
    By texasss in forum Parts Wanted / Trade
    Replies: 2
    Last Post: 10-29-2005, 10:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •