Results 1 to 4 of 4

misfire fixed, spark plug question

This is a discussion on misfire fixed, spark plug question within the Firebird / WS6 forums, part of the Vehicle Specific category; so after replacing the coil pack on cylinder 7 i still had a misfire... yeah i know... start with the ...

  1. #1
    Member ls1ws6ben's Avatar
    Join Date
    Apr 2010
    Location
    west monroe, la
    Posts
    246

    white
    1998 Trans Am

    misfire fixed, spark plug question

    so after replacing the coil pack on cylinder 7 i still had a misfire... yeah i know... start with the simple things first.. i never learn.. so after spending $45 bucks on that i was kinda mad but also happy that it was just a bad spark plug... now i had no idea what kind was in there at this point and with my work hours, im kinda strapped for time.. so i stopped by advanced auto on the way home and picked up a new ac delco plug.. changed them out, and wa la.. no more misfire.. now my question is this... the other 7 plugs are bosch platinum plugs and the 1 i replaced is an ac delco.. because as previous stated i had no idea what plugs were in there.. is this going to cause a problem??? the guys at advanced auto said no, but i would like input from other ls1 owners...

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    It will not cause any issues that I am aware of. However, the fact that you had a bad plug to begin with would make me suspect that the condition of the remaining plugs may also be a pending issue.

    Lots of guys on here run the Delco Iridiums or NGK TR55's.

  3. #3
    Member ls1ws6ben's Avatar
    Join Date
    Apr 2010
    Location
    west monroe, la
    Posts
    246

    white
    1998 Trans Am

    Well I do plan on changing them all to match now that I know. As for the other issues. I found out that after they put a new motor in that car (previous owner) continued to race it and they replaced a lifter in that motor. They didn't replace any plugs when they put the new lifter in. Which is why I'm guessing it has been misfiring since I got it. But when I put that new plug in and fired her up, the rough idle went away and that motor is smoothe as silk now. And friday I had a flowmaster 80 series and 4 inch tips put on. Yesterday had the cats deleted. Even though a lot of people say magnaflow, I'm happy with how it sounds. Now that may change next month when the LTs go on, but for now I like it

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by ls1ws6ben View Post
    Well I do plan on changing them all to match now that I know. As for the other issues. I found out that after they put a new motor in that car (previous owner) continued to race it and they replaced a lifter in that motor. They didn't replace any plugs when they put the new lifter in. Which is why I'm guessing it has been misfiring since I got it. But when I put that new plug in and fired her up, the rough idle went away and that motor is smoothe as silk now. And friday I had a flowmaster 80 series and 4 inch tips put on. Yesterday had the cats deleted. Even though a lot of people say magnaflow, I'm happy with how it sounds. Now that may change next month when the LTs go on, but for now I like it

    Sounds like a plan. Post up some pics of the installs!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. spark plug question
    By Bad Bird in forum External Engine
    Replies: 3
    Last Post: 03-09-2014, 09:58 AM
  2. spark plug gap question
    By 98trans_am in forum External Engine
    Replies: 3
    Last Post: 06-17-2010, 11:00 PM
  3. Question: Another NGK TR-55 Spark Plug Gap Question
    By Mesterious in forum External Engine
    Replies: 18
    Last Post: 05-30-2010, 10:23 PM
  4. Help: Cylinder 3 Misfire after spark plug change.
    By first01SS in forum General Help
    Replies: 91
    Last Post: 01-21-2009, 04:52 PM
  5. Spark plug question
    By muteki in forum External Engine
    Replies: 12
    Last Post: 09-13-2008, 02:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •