Page 1 of 2 12 LastLast
Results 1 to 20 of 24

lid rubing?

This is a discussion on lid rubing? within the Firebird / WS6 forums, part of the Vehicle Specific category; i poped my hood the other day to find out my slp lid has rubed the hood not bad as ...

  1. #1
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    lid rubing?

    i poped my hood the other day to find out my slp lid has rubed the hood not bad as of yet but has any one but me had this prob. and if so how did you fix it?

  2. #2
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    Mine rubs, and there is nothing you can do unless you get a lower profile lid

  3. #3
    sell out Mustang Killa's Avatar
    Join Date
    Apr 2007
    Location
    Tempe AZ
    Age
    32
    Posts
    432

    Black
    2010 Black Camaro 2SS

    mine does the same thing, anyone have a prob with it NOT sealing in the rear??? i have an SLP lid

  4. #4
    Member Mike's TA's Avatar
    Join Date
    Nov 2006
    Location
    Austin, TX
    Age
    35
    Posts
    880

    Black
    99 Trans Am(sold)

    Quote Originally Posted by Mustang Killa View Post
    mine does the same thing, anyone have a prob with it NOT sealing in the rear??? i have an SLP lid
    I would have but then I remembered I had to take the foam ring that came with my K&N off the stocker and put it on the SLP lid. Fits tightly now.

  5. #5
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    my lid dosnt fit snug in the back eather, i cut some ruber hose and shimed the lid in the back to get it to seal beater and hopfully stop the rubing ill let you guys know how it works out

  6. #6
    ME!!
    Join Date
    May 2007
    Location
    PRATTVILLE ALABAMA
    Posts
    1,007

    LPM
    01 Z28

    speaking of the seal that came with the k&n, what do we do with that?

  7. #7
    sell out Mustang Killa's Avatar
    Join Date
    Apr 2007
    Location
    Tempe AZ
    Age
    32
    Posts
    432

    Black
    2010 Black Camaro 2SS

    you put the k&n seal around the inner lip of the lid, that hose idea is a good one let me know how that goes, i might be off to the harware store now..great idea

  8. #8
    Member Mike's TA's Avatar
    Join Date
    Nov 2006
    Location
    Austin, TX
    Age
    35
    Posts
    880

    Black
    99 Trans Am(sold)

    Quote Originally Posted by 01 T/A View Post
    my lid dosnt fit snug in the back eather, i cut some ruber hose and shimed the lid in the back to get it to seal beater and hopfully stop the rubing ill let you guys know how it works out
    Just make sure by doing this that you haven't created a gap on the sides allowing unfiltered air to get into your engine.

  9. #9
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    well thats y i put the hose in it i had a gap in the back of the lid for air to get in and i hope it will fix bouth of my isues im going to a fboby race this weekend and i will let you guys know how it works out monday

  10. #10
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    ok sorry it toke so long but the hose didnt work it just keep sliping out so im going to try some othe things and ill let you know how it works out

  11. #11
    Member
    Join Date
    Sep 2007
    Location
    Lansing MI
    Posts
    109

    Silver
    2002 WS6 TA

    I have the new SLP lid and mine fails to seal tightly in back and rubs as well. I have the blackwing filter from SLP which doen't fit well either. Any suggestion other than putting it in the trash would be welcome.

  12. #12
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    im going to try a cuple of thing out and see what hapines ill let you know if any one works but the k&n filter i have fits prity good

  13. #13
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    still no luck with this deal im still looking for a good fix

  14. #14
    sell out Mustang Killa's Avatar
    Join Date
    Apr 2007
    Location
    Tempe AZ
    Age
    32
    Posts
    432

    Black
    2010 Black Camaro 2SS

    ive been scouting the hardware and automotive stores lookin for something..i havent seen anything yet that looks like it will work, im about to say fuck it and duck it..cant go wrong with duck tape

  15. #15
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    Quote Originally Posted by Mustang Killa View Post
    ive been scouting the hardware and automotive stores lookin for something..i havent seen anything yet that looks like it will work, im about to say fuck it and duck it..cant go wrong with duck tape
    That is an awesome Avatar pic!

  16. #16
    sell out Mustang Killa's Avatar
    Join Date
    Apr 2007
    Location
    Tempe AZ
    Age
    32
    Posts
    432

    Black
    2010 Black Camaro 2SS

    .

    Quote Originally Posted by 9t8z28 View Post
    That is an awesome Avatar pic!
    thanks..always lots of love on this website..im gonna try a few types of weather stripping on my lid and let u guys know how it goes..i was at a car show tonight and saw a camaro with the same slp lid as i and it seemed to fit perfectly in the back??

  17. #17
    🤔 11s. blackbirdbrain89's Avatar
    Join Date
    Sep 2007
    Location
    hagerstown, mercersburg
    Age
    28
    Posts
    1,844

    black trans am
    2000

    i to have the slp lid and k&n filter and i have no porblems with it yeat .. i just got it about 2 weeks a go

  18. #18
    Member Since 1998 Mecinoid's Avatar
    Join Date
    May 2007
    Location
    Livermore, Ca.
    Posts
    498
    '98,'00 Bird '03, 14 Vets

    wow, my MTI didn't rub. Matter of fact I was able to put a few washers under that lid to get increase flow underneath.

    I now have a Stealth Lid (Corvette Sized Filter) and FTRA custom sealed to it. No problems there.

    I guess you might be able to shave the legs of the air box to drop it down some ... Or, sand the top of the lid where it is hitting bit.

    I have a stock hood not a Ram Air hood .... But, I thought those had even less clearance.

    Good luck .... Picts ????

  19. #19
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    ok so i tryed takeing the gasget out of the lid and it did not rub but now the clamps will not stay on this is starting to piss me off

  20. #20
    Junior Member johno's Avatar
    Join Date
    May 2009
    Location
    Harrisburg,PA
    Posts
    61

    Black &Gold &Tan Inside
    2001 WS6-NHRA

    can you tell me will a blk-wing lid fit good

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. lid rubing
    By 0verkill in forum Firebird / WS6
    Replies: 3
    Last Post: 02-22-2008, 09:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •