Page 2 of 2 FirstFirst 12
Results 21 to 38 of 38

I can't turn my TCS on? does anyone know how to fix it?

This is a discussion on I can't turn my TCS on? does anyone know how to fix it? within the Firebird / WS6 forums, part of the Vehicle Specific category; All I have to say is, why on earth would you want the traction control system ever on????...

  1. #21
    Junior Member samuelsamuel's Avatar
    Join Date
    Jan 2007
    Location
    Canada
    Posts
    28

    Black
    2002 camaro ss

    All I have to say is, why on earth would you want the traction control system ever on????

  2. #22
    Member Ryanater's Avatar
    Join Date
    Feb 2007
    Location
    Washington
    Age
    29
    Posts
    393
    1998 WS6, 1969 Camaro

    I don't. I just don't want there to be anything broken in my car. It just bugs me that it doesn't work.

  3. #23
    SS Driver aerojt's Avatar
    Join Date
    Jul 2007
    Location
    Ohio
    Posts
    553

    Black
    1998 Camaro SS M6 #1871

    I am having this same problem, anybody have an answer?

  4. #24
    Member onetroubledguy's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, TX
    Age
    31
    Posts
    401

    Navy Blue Metallic
    1999 Trans Am WS6

    I wish mine was off all the time. =[

  5. #25
    Member TROYWS6X's Avatar
    Join Date
    Oct 2005
    Location
    New York
    Posts
    141

    Black
    1998 WS6

    Quote Originally Posted by onetroubledguy View Post
    I wish mine was off all the time. =[
    x2!

  6. #26
    Junior Member 94TA25thANNIVERSARY's Avatar
    Join Date
    Apr 2007
    Location
    New Brunswick, Canada
    Age
    40
    Posts
    75

    White
    1994 Trans Am 25th

    My 95 LT1 just started doing the same thing so if I ever figure it out I'll post it up.

  7. #27
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    Quote Originally Posted by Ryanater View Post
    I don't. I just don't want there to be anything broken in my car. It just bugs me that it doesn't work.
    I can understand that.

  8. #28
    Still The Junior Member RedVertTA's Avatar
    Join Date
    Jun 2008
    Location
    Orlando FL
    Age
    28
    Posts
    1,045

    Red+White Top and Stripes
    2000TransAmConvertible A4

    This thread is not about your personal preferences people, he can fix his TCS if he wants.

    On that note it IS a good idea for him to look into this. The source of this problem may be more than just something TCS related, it could get worse and affect something besides the TCS and at that point he will have an even greater problem on his hands. Fix it now before it becomes a problem. (I'm see GM.)
    FAST 90/90, SLP Lid, Kooks JetHot Coated LT's, American Racing Y-Pipe+Magnaflow Cats, DHM Electric Cutout, Flowmaster American Thunder Catback, HP Tuners Software, 343 rwhp.

    BMR Convertible Subframe Connectors, Hotchkis Strut Tower Brace, BMR Driveshaft Safety Loop.

  9. #29
    Junior Member alexa's Avatar
    Join Date
    Sep 2008
    Location
    Canada
    Age
    41
    Posts
    19

    black as nite
    1998 trans am WS6

    Have the same problem now. Had before twice. Here how GM fixed the problem in my case. They replaced ebtcm. It costed previous owner 1300CAD for the second time to fix it, first time the car was on warranty. Faulty ebtcm, I have test results paperwork from GM, they measured resistance inside the module, found it incorrect between some connectors, concluded it's faulty. Replaced. In three years - same problem - same answer again, in 7 years - same problem, but this time I not gonna put any money to fix that sucker. Though I've seen ebtcm on e-bay once for 50 bucks or so.
    Hope this helps

  10. #30
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Quote Originally Posted by Ryanater View Post
    No code, I just scanned it last weekend.

    Thanks though.
    What type of scanner did you use?

  11. #31
    Member Ryanater's Avatar
    Join Date
    Feb 2007
    Location
    Washington
    Age
    29
    Posts
    393
    1998 WS6, 1969 Camaro

    Whatever shucks had to scan it.

  12. #32
    Member devildogws6's Avatar
    Join Date
    Mar 2008
    Location
    Monticello MN
    Posts
    683

    Black
    2000 trans am ws6

    iv had the same problem for two years and it hasnt affected anything else in my car just he annoying ass light is on thats it, also my ABS is inop too but owell

  13. #33
    Member Ryanater's Avatar
    Join Date
    Feb 2007
    Location
    Washington
    Age
    29
    Posts
    393
    1998 WS6, 1969 Camaro

    My ABS light has never come on though.

  14. #34
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Quote Originally Posted by INMY01TA View Post
    Wish my car had that problem.
    Me too..so it can be tuned to off through HP Tuners?

  15. #35
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Quote Originally Posted by Ryanater View Post
    Whatever shucks had to scan it.
    Their scanner won't be able to pull the codes. You need a shop that has a better scanner or go to the dealer.

  16. #36
    Member Ryanater's Avatar
    Join Date
    Feb 2007
    Location
    Washington
    Age
    29
    Posts
    393
    1998 WS6, 1969 Camaro

    Oh ok. Thanks.

  17. #37
    Senior Member big hammer's Avatar
    Join Date
    Nov 2007
    Location
    manitoba, canada
    Posts
    1,731

    silver
    2002 ws6

    Quote Originally Posted by SpeedAddict38 View Post
    if it is stuck in off thats a good thing......I turn mine off everytime I drive
    x2.... tcs sucks doink!

  18. #38
    Member fieropope's Avatar
    Join Date
    Jan 2009
    Location
    union mo
    Posts
    183

    white
    01 formula

    the only scanner ive seen to read tcs codes is a snapon modis .

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. When you turn 18...
    By Frazier in forum Almost Anything Goes
    Replies: 4
    Last Post: 03-17-2009, 07:25 PM
  2. How to turn off DRL
    By kool-aide in forum Stereo and Electronics
    Replies: 3
    Last Post: 08-05-2008, 03:29 PM
  3. Turn sig ?
    By 98T/Aformula in forum Firebird / WS6
    Replies: 1
    Last Post: 07-17-2007, 10:05 AM
  4. Turn on FX right now!!!!!
    By 99blueZ in forum Almost Anything Goes
    Replies: 4
    Last Post: 03-23-2007, 10:37 AM
  5. Help? Can someone turn off my SES?
    By BlackHawk#36 in forum Western Members
    Replies: 8
    Last Post: 01-04-2007, 01:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •