Page 2 of 2 FirstFirst 12
Results 21 to 30 of 30

I cant stand this sqeaking

This is a discussion on I cant stand this sqeaking within the Firebird / WS6 forums, part of the Vehicle Specific category; The infamous squeak I have about 10 million of those. Tracked every one of them down cause it pissed me ...

  1. #21
    Senior Member Redphoenix1998's Avatar
    Join Date
    Apr 2002
    Location
    San Jose
    Age
    36
    Posts
    1,897

    Red
    1998 Pontiac Trans Am

    The infamous squeak I have about 10 million of those. Tracked every one of them down cause it pissed me off.

    1. Hatch Strut
    2. Top bolt on shock
    3. Wingnut on light, I had 3 loose.
    4. Seat belt for rear seat was loose
    5. Rear seat latch locks and bolts were loose
    6. God forsaken hatch trim loose!
    7. LCA's loose
    8. I still have one that I can't find. It's a new one too coming from the passenger side of the trunk

    I sear, I'm about to dynamat the entire car, rebolt everything and lube whatever I get a hold of cause I'm getting annoyed

  2. #22
    Junior Member
    Join Date
    Jan 2006
    Location
    indiana
    Age
    44
    Posts
    13

    Pewter
    2000 Trans Am WS6

    I have a 2000 WS6.mine seems to squeak when my RPM,s are around 3000.been driveing me crazy for months.glad im not the only one.im going to try everything i just read here.if i find it to be something different ill be sher to post it.

  3. #23
    Junior Member
    Join Date
    Aug 2005
    Location
    Edmond,OK
    Age
    35
    Posts
    75

    Black
    2000 TransAm WS6

    Quote Originally Posted by 2000PEWTER,WS6 View Post
    I have a 2000 WS6.mine seems to squeak when my RPM,s are around 3000.been driveing me crazy for months.glad im not the only one.im going to try everything i just read here.if i find it to be something different ill be sher to post it.
    Try exaust hangers I had that on too

  4. #24
    Senior Member Redphoenix1998's Avatar
    Join Date
    Apr 2002
    Location
    San Jose
    Age
    36
    Posts
    1,897

    Red
    1998 Pontiac Trans Am

    that'll do it also. The rubber might be shot to hell. I should check that myself

  5. #25
    Junior Member
    Join Date
    Aug 2006
    Location
    NEW JERSEY
    Age
    36
    Posts
    9

    RED
    2000 WS6 TRANS AM

    i guess im gonna try the shock first because i can hear it from the outside................too bad i have had my car in the body shop for the last week i wanna try all these good ideas

  6. #26
    Junior Member
    Join Date
    Aug 2006
    Location
    Melbourne, Australia
    Posts
    1

    Silver
    1999 Chev Camaro Z28

    My 95 Z28 had a similar squeak. Turned out to be the 2 catches that hold the rear seats back. A little white body grease around the hook part & problem solved.

  7. #27
    insert witty title here Blk00ws6's Avatar
    Join Date
    Apr 2006
    Location
    Georgetown, Oh
    Age
    35
    Posts
    325

    Black
    2000 WS6

    Mine car did it, then it stopped. I think it may be only when it is cold outside 'cause it was more prominent in the winter.

  8. #28
    Junior Member
    Join Date
    Sep 2006
    Location
    Grande Prairie, Alberta. Canada....eh
    Age
    39
    Posts
    15

    Pearl White
    2001 Trans Am

    It might sound silly, but the power antenna squeaks too when it retracts after shutting the car off...
    Is there a nice way to lube it without having it attact thousands of bugs and a pile of dust?

  9. #29
    ls1ftw tigersport14's Avatar
    Join Date
    Sep 2006
    Location
    Tulsa
    Age
    29
    Posts
    2,035

    NBM
    98 trans am

    my solution to the squeaky noise is to turn up your music or listen to your exhaust =D

  10. #30
    Junior Member
    Join Date
    Sep 2006
    Location
    Grande Prairie, Alberta. Canada....eh
    Age
    39
    Posts
    15

    Pearl White
    2001 Trans Am

    Quote Originally Posted by tigersport14 View Post
    my solution to the squeaky noise is to turn up your music or listen to your exhaust =D
    The music doesn't play and the car no longer revs when I turn it off.
    However.. thats when the antenna retracts, ending in a squeak.

    So neither 'solution' will work. :P

    (Although I'd preffer either one compaired to a squeak any day!)

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. DIY Engine Break-In Stand - Stand Delivered, Part II
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 02-17-2011, 02:00 PM
  2. DIY Engine Break-In Stand - Stand Delivered
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 01-20-2011, 02:30 PM
  3. Help: sqeaking
    By joker in forum Drivetrain
    Replies: 5
    Last Post: 05-31-2009, 05:03 PM
  4. Which oil seems to stand out?
    By FISH 99 WS6 in forum Internal Engine
    Replies: 26
    Last Post: 04-01-2009, 10:23 PM
  5. SLP stand for...?
    By slakin in forum General Help
    Replies: 11
    Last Post: 08-27-2005, 03:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •