Results 1 to 5 of 5

Hubs

This is a discussion on Hubs within the Firebird / WS6 forums, part of the Vehicle Specific category; Hello, can anyone tell me how to know when the front hub is bad. I have a vibration up front ...

  1. #1
    Member
    Join Date
    Oct 2008
    Location
    Miami, Fla
    Posts
    200

    Spiral Gray
    2004 Auto Corvette

    Unhappy Hubs

    Hello, can anyone tell me how to know when the front hub is bad. I have a vibration up front with a low pitched rumbling noise. You can barely feel it in the steering wheel. Have all new tires they are a week old and the balance is good. The noise starts around 65 mph on up. It does not get louder. The tunnel where the driveshaft runs does not vibrate at all, I was thinking the shaft might be causing it. Any ideas? Could a dragging brake caliper cause this?? I posted this same question before and some people thought it was the u joints but they are ok.

  2. #2
    War Machine BIG GUNS's Avatar
    Join Date
    May 2007
    Location
    St. Louis MO.
    Age
    53
    Posts
    2,100

    Black
    00 Trans Am/Auto

    How about an alignment to start with? I would go that route first and then look at some other issues.

  3. #3
    Senior Member GULLETT17's Avatar
    Join Date
    Oct 2007
    Location
    Muncie, IN
    Posts
    2,554

    00 TA PWTR, 98 VertTA NBM
    80 TA BLK, 80 Formula NBM

    Quote Originally Posted by BIG GUNS View Post
    How about an alignment to start with? I would go that route first and then look at some other issues.
    i thought i had a hub bad, but suspected the alignment after examining my tire wear. I had big o tires but it up on the alignment rack, and it was way out of adjustment.

  4. #4
    Member
    Join Date
    Oct 2008
    Location
    Miami, Fla
    Posts
    200

    Spiral Gray
    2004 Auto Corvette

    Thanks for the quick replies. I will have the shop that put the tires on look at the alignment. The old tires did have very even wear.

  5. #5
    War Machine BIG GUNS's Avatar
    Join Date
    May 2007
    Location
    St. Louis MO.
    Age
    53
    Posts
    2,100

    Black
    00 Trans Am/Auto

    Quote Originally Posted by Retired Cop View Post
    Thanks for the quick replies. I will have the shop that put the tires on look at the alignment. The old tires did have very even wear.
    Yeah, these F-bodies are notorious for shake at around 60mph. They shake like a B-17 on a bombing raid....lol. Alignment first.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: brakes and hubs
    By MudStainKILLA in forum General Help
    Replies: 0
    Last Post: 09-04-2012, 06:27 PM
  2. Hubs (replacement)
    By nomolos1 in forum Drivetrain
    Replies: 54
    Last Post: 07-03-2011, 05:29 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •