Results 1 to 16 of 16

Hid problems!!

This is a discussion on Hid problems!! within the Firebird / WS6 forums, part of the Vehicle Specific category; Does anybody have any clue why my HIDs are always burning out?? Is anybody else experiencing this? I have burned ...

  1. #1
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    Hid problems!!

    Does anybody have any clue why my HIDs are always burning out?? Is anybody else experiencing this? I have burned out the bulb for my low beams and the ballast. The fog light bulb went out as well. Ive checked for moisture and theres nothing, is it faulty wiring maybe? This keeps happening to the driver side headlight

  2. #2
    Member WS-6's Avatar
    Join Date
    Feb 2008
    Location
    NW Indiana
    Posts
    418

    Pewter
    2000 T/A WS-6

    are you running relays for them?

  3. #3
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    No, I wasnt told I was suppose to

  4. #4
    Member tpilews's Avatar
    Join Date
    Aug 2005
    Location
    Tampa, FL
    Age
    34
    Posts
    918

    Black
    '98 Z28

    Quote Originally Posted by 01ls1ws6 View Post
    No, I wasnt told I was suppose to
    Not sure what your problem is, but take a look at DDM Tuning. Their sets are pretty cheap and carry a lifetime warranty. Mine were straight plug n play.

  5. #5
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    Screw it, I got pissed off and went back to stock

  6. #6
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    was probably loose wire or the ballast5 was bouncing or cheap kit. All my cheap ebay kits have lasted for a few years soo far. Only had one low beam ballast go out when i replaced the headlight motor I forgot to mount the ballast back up and it was swinging and bouncing and banging around for a few months then went bad. Replaced it and made sure to mount it down and no more issues. I have 6 sets from ebay and one bi xenon for my 93 5.0 and never an issue and the only one that has relay on it is the bi xenon the rest were pretty much plug and play.
    1998 Trans Am 85k miles.
    Bolt ons, MS3 113LSA cam, Circle D Stall, Tune, Modified WS6 style hood, Full Suspension, 6000k HID's, Clear Side Markers w/ Leds, Led 3rd Brake Light and 18" AR Staggered Killer Wheels w/ BFG KDW NT's.- Weekend Toy/DD
    02 Trailblazer -Sold
    09 Ram 1500 CC - Sold
    09 Cobalt SS/TC - Sold
    13 ram 1500 LoneStar CC 4x4 - Magnaflow, K&N,and more to come-DD/Toy

  7. #7
    Impounded
    Join Date
    Dec 2007
    Location
    SAN FRAN SISCO BABY
    Age
    30
    Posts
    836

    VW BEETLE W/ FLOWER
    88 CRX

    how much did you pay for it?
    the reason i never went HID is because i was told to get a real HID kit expect too pay between 700-900$ for a good one with ballists and all other needed components. almost bought a set for my 06 P/U but the guy talked me out of the 100$ kit glad he did.

  8. #8
    Member tpilews's Avatar
    Join Date
    Aug 2005
    Location
    Tampa, FL
    Age
    34
    Posts
    918

    Black
    '98 Z28

    Quote Originally Posted by TmaxicanA View Post
    how much did you pay for it?
    the reason i never went HID is because i was told to get a real HID kit expect too pay between 700-900$ for a good one with ballists and all other needed components. almost bought a set for my 06 P/U but the guy talked me out of the 100$ kit glad he did.
    I paid $85 shipped with lifetime warranty. They actually had a sale a while ago and I picked up a set for the fog lights for $60 shipped.
    Last edited by tpilews; 06-07-2010 at 10:02 PM.

  9. #9
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    I payed between $40 and $90 depending on when they were bought. The bi xenon for the 5.0 was a little extra also.

  10. #10
    Junior Member
    Join Date
    Jun 2010
    Location
    Cali
    Posts
    4

    Na
    NA

    Quote Originally Posted by 01ls1ws6 View Post
    Does anybody have any clue why my HID headlight kits are always burning out?? Is anybody else experiencing this? I have burned out the bulb for my low beams and the ballast. The fog light bulb went out as well. Ive checked for moisture and theres nothing, is it faulty wiring maybe? This keeps happening to the driver side headlight
    Where did you get your kits from?

  11. #11
    Member Mieux97's Avatar
    Join Date
    Dec 2007
    Location
    Chicago
    Posts
    614

    White
    99 Pontiac Trans Am #2466

    I just discovered my left HID fog went out last night and I only had it for 3 months!!!

  12. #12
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    Quote Originally Posted by Mieux97 View Post
    I just discovered my left HID fog went out last night and I only had it for 3 months!!!
    Same exact thing happened to me twice...thats why I went back to stock. fuck that HID bullshit

  13. #13
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    I have them on 3 cars with no problems I dunno what's going on with the kits some of you have gotten. There's no need for relays and usually no wiring just plug and done. Some I have cut and splice that I have instakked depending on the car and how they wen't un usually had to do with replacing the sealed beams with replacable bulb setup or we took the flipouts on a 240SX for a customer and his are replaced with solid mount replacement with HID's.

  14. #14
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    I hear more stories on HIDs burning out within months then I hear success stories. 2 of my friends so far have had this happen.

  15. #15
    Member WS-6's Avatar
    Join Date
    Feb 2008
    Location
    NW Indiana
    Posts
    418

    Pewter
    2000 T/A WS-6

    I ve been running them in my z71 for over a year and a half with no problems they have been in the bird longer but it only sees 2-4k miles a year. I will probably have one go out now.

  16. #16
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    I have gotten 10k miles on the sets in my TA and 30k on the ones in my Trailblazer and the TA's fog light ballasts have been submerged when it flooded on my way home. I haven't had anyone come back with problem with any kits I have installed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 97 LT1 problems
    By james78657 in forum LT1
    Replies: 18
    Last Post: 01-20-2012, 10:30 AM
  2. Help: 62.9i problems
    By trooperrunner in forum Stereo and Electronics
    Replies: 1
    Last Post: 08-12-2009, 04:08 PM
  3. problems with my 66 g.t.o. (help)
    By 05gtoautoX in forum GTO
    Replies: 6
    Last Post: 07-11-2006, 04:49 AM
  4. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 07:26 PM
  5. A/C problems.
    By gnomee in forum General Help
    Replies: 2
    Last Post: 03-14-2006, 07:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •