Results 1 to 15 of 15

help anyone

This is a discussion on help anyone within the Firebird / WS6 forums, part of the Vehicle Specific category; I have a 98 trans am ws6 it started running bad like a week ago feelin like its about to ...

  1. #1
    Junior Member javeryboy's Avatar
    Join Date
    Oct 2012
    Location
    new Orleans
    Posts
    11

    blue
    1998 trans am ws6

    help anyone

    I have a 98 trans am ws6 it started running bad like a week ago feelin like its about to cut off wen I come to a stop r wen I drive around the block but wen im on the bridge its fine. Do anyone have a clue

  2. #2
    Moderator 98TransAmWs-6's Avatar
    Join Date
    Apr 2010
    Location
    Fairfax, VA
    Posts
    3,596

    Black/ Silver
    98 TA WS6/ 01 C5 Corvette

    Any codes or anything?
    1998 Trans Am WS6 - Phantom
    421 CI LQ9, Tick Performance Custom Cam, TFS 255cc LS3 heads, Kooks 2" LT headers, Kooks 3" True Duals w/ high flow cats, FTP 104 lid, Speed Density Tune, 4" silicon tube, LS6 VCT, FAST 102 Intake, NW 102 TB, Oil Catch Can, SLP Bilstein Shocks w/ Vogtland Springs, CTS-V 4-piston Calipers w/C6 Z06 rotors, Stainless Steel Brake Lines, R1 concepts premium rotors, Hawk HP+ brake pads, VFN WSQ Hood, C5-R timing chain, SLP oil pump, E85 tune, Walbro 450 fuel pump, Deatschwerkz 95# injectors, Breathless performance headlights, Frost Tune, !HVAC.
    (Coming Soon) BMR DSL, UMI TQ Arm
    421 LQ9 14.8:1 on E85 Build/

  3. #3
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    I forget when they did it, but at some point they dropped the EGR. IF you there is an EGR on your car I would start there and clean it up or replace it. When's the last time the plugs or fuel filter was changed?

  4. #4
    Junior Member javeryboy's Avatar
    Join Date
    Oct 2012
    Location
    new Orleans
    Posts
    11

    blue
    1998 trans am ws6

    haven't had a chance to put it on the machine

    No not yet

  5. #5
    Junior Member javeryboy's Avatar
    Join Date
    Oct 2012
    Location
    new Orleans
    Posts
    11

    blue
    1998 trans am ws6

    I brought it 2yrs ago

    Never changed it

  6. #6
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    It quick and cheap insurance to change it, whether it is the issue or not, I never trust the previous owners maintenance work. One more thing to look for, check for cracks in the bellows after the MAF, it has happened before to another members car.

  7. #7
    Moderator 98TransAmWs-6's Avatar
    Join Date
    Apr 2010
    Location
    Fairfax, VA
    Posts
    3,596

    Black/ Silver
    98 TA WS6/ 01 C5 Corvette

    I would check your fuel pressure at the rails and then check the other basics like plugs and wires as well as the MAF (make sure it is clean). It should be around 58 psi. The feeling like it is going to cut off sounds like a fuel issue. Out of curiosity what rpms arw you at usually when it feels like it is going to cut off? Also are you modded at all?

  8. #8
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    check for a vacuum leak....the pcv hose likes to crack on the backside where it turns to go into the intake. When you say "cutoff" do you mean it's idling low or missing?

  9. #9
    Senior Member theorangeguy's Avatar
    Join Date
    May 2013
    Location
    Nashville, TN
    Posts
    1,434

    Black / White
    '00 T/A M6/'15 Hemi Truck

    sounds like a bad vacuum leak...does it idle high when you are almost at a stop or going say, 5-10mph? I just went through a very similar issue...
    Last edited by theorangeguy; 08-27-2013 at 04:40 PM.

  10. #10
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Has there been any work done on the car recently?

    Other than that, these guys have pretty much nailed down the most likely issues.

  11. #11
    Junior Member javeryboy's Avatar
    Join Date
    Oct 2012
    Location
    new Orleans
    Posts
    11

    blue
    1998 trans am ws6

    It doesn't idld high n I also smell gas

  12. #12
    Junior Member javeryboy's Avatar
    Join Date
    Oct 2012
    Location
    new Orleans
    Posts
    11

    blue
    1998 trans am ws6

    It does smell like gas sometimes

  13. #13
    Junior Member javeryboy's Avatar
    Join Date
    Oct 2012
    Location
    new Orleans
    Posts
    11

    blue
    1998 trans am ws6

    Yes it idle low n plus I smell gas

  14. #14
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Has the air filter been replaced lately? Also, how about cleaning the throttle body? It gets gummed up, especially with the oil that is pulled in through the PCV system (that's why catch cans are recommended on our cars) and once it gets to the point of restricting airflow around the closed throttle blade you will have issues. The IAC (Idle Air Control valve) is also a potential culprit and may be gummed up as well.

  15. #15
    Junior Member
    Join Date
    Sep 2013
    Location
    surprise, az
    Posts
    1

    black
    2001 trans am ws6

    I had a very similar problem before. It turned out to be the IAC. Idle air control valve. It was an easy fix.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •