Results 1 to 4 of 4

Help?

This is a discussion on Help? within the Firebird / WS6 forums, part of the Vehicle Specific category; I've been having some weird issues.. Let me start off to say I'm lost. Ok, so the other day I ...

  1. #1
    Junior Member sunstylez's Avatar
    Join Date
    Sep 2007
    Location
    Trenton, Georgia
    Posts
    18

    Black
    1998 Pontiac Trans AM

    Help?

    I've been having some weird issues.. Let me start off to say I'm lost. Ok, so the other day I was driving down the road when I noticed my oil pressure was lower than usual on a warm drive(30psi [normal 40-45psi] at 1500RPM). Then my oil gauge started to shake very erratically left to right. So I bought a new oil sending unit and replaced it, the erratic movement of the gauge had stopped. But I still have a lower oil pressure reading.. And at Idle my heat temperature has raised faster than usual as well.. Reading 210 within just 10 minutes of idle w/ 90 degree weather. But soon falls back to 180 with air flow of motion. I'm guessing this is somewhat normal? Considering the block is aluminum and heats up faster, and as well cools faster... Or am I missing something? Any suggestions or comments to fix my ignorance will be appreciated :]

  2. #2
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    Well, the temp issue sounds like a thermostat needs changed. If you are using a programmer of any kind, I would install a 160 stat. If not, just get a new stock T-stat.

  3. #3
    Miss Pennsylvania ls1blackbeauty98's Avatar
    Join Date
    Aug 2005
    Location
    West Cheter, PA
    Posts
    2,851

    '98 Black Gone :(
    01 WS6 Midnight Blue

    as for the oil pressure, ive noticed with any trans am no matter what year, the oil pressure is always lower (30 ish) then "normal" oil pressure (40 +) especially at idle. Just sharing my experience.

  4. #4
    Junior Member sunstylez's Avatar
    Join Date
    Sep 2007
    Location
    Trenton, Georgia
    Posts
    18

    Black
    1998 Pontiac Trans AM

    well.. when i turn my heat on lol it doesn't run up as hot. so i changed out the thermostat. heat issue solved. and as for the oil pressure. replaced the o-ring it was busted... still a little low.. then i changed from castrol 10-w30 synthetic to mobile 1 10-w30 synthetic. This really sounds strange considering my weights remained the same.. but yeah.. warm idle is at 40 now :]

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •