Results 1 to 12 of 12

headlight and right turn signal issue

This is a discussion on headlight and right turn signal issue within the Firebird / WS6 forums, part of the Vehicle Specific category; my left headlight does not come up but the light still turns, on thats it. and my right turn signal ...

  1. #1
    Member nate_the_great17's Avatar
    Join Date
    Aug 2007
    Location
    fortworth
    Posts
    224

    81 camaro
    2001 trans am ws6

    headlight and right turn signal issue

    my left headlight does not come up but the light still turns, on thats it. and my right turn signal does not blink. i have check my fuses for both of the issues and changed my bulb for the turn signal but nothing seems to work. any ideas how to fix it

  2. #2
    Freezin in AK! ArcticZ06's Avatar
    Join Date
    Aug 2007
    Location
    Anchorage AK
    Age
    36
    Posts
    1,450

    Old: 00 WS6, 02 Z06, 79TA
    11 F350 CC 6.7L

    My right turn signal just quit working too. The light in the dash just stays on and doesnt blink or make the clicking noise.

  3. #3
    Member nate_the_great17's Avatar
    Join Date
    Aug 2007
    Location
    fortworth
    Posts
    224

    81 camaro
    2001 trans am ws6

    yup do u know what could be wrong

  4. #4
    Freezin in AK! ArcticZ06's Avatar
    Join Date
    Aug 2007
    Location
    Anchorage AK
    Age
    36
    Posts
    1,450

    Old: 00 WS6, 02 Z06, 79TA
    11 F350 CC 6.7L

    no clue. I'll mess around with it this weekend.

  5. #5
    Member nate_the_great17's Avatar
    Join Date
    Aug 2007
    Location
    fortworth
    Posts
    224

    81 camaro
    2001 trans am ws6

    maybe u will have some luck cuz i have tryed every thing to my knowledge

  6. #6
    Junior Member
    Join Date
    Sep 2007
    Location
    Northern Kentucky
    Posts
    7

    Black
    1998 Pontiac Trans Am Ws6

    sounds like you need to replace your flasher module. You said you replaced the bulb, correct? I recently had some turn signal issues such as this, and it turned out to be nothing more than the turn signal flasher. You can buy one at Pep-Boys or any auto-store. The flasher is usually located behind the lower part of the dashboard, underneath the steering column. You will probably have to remove that part of the dash to access it. It's about an inch and a half long plastic cyclinder. Just unplug the old one, and pop the new one in. That hopefully will fix the signal problem. Not sure about the headlight though. Sorry!

  7. #7
    Member firemedic0135's Avatar
    Join Date
    Jun 2007
    Location
    East Texas
    Age
    42
    Posts
    195

    Arctic White
    2000/Trans Am

    usually the turn signals quit blinking due to a bulb being burned out.
    For the headlight make sure all your connections are tight,they should be ,but if you cant get it to come up try turning the manual raise knob up and then down and try it again. You can also try pulling up on the headlight while you turn the light on and see if it takes off that way.If it does then you need to replace the gear inside the motor.

  8. #8
    Freezin in AK! ArcticZ06's Avatar
    Join Date
    Aug 2007
    Location
    Anchorage AK
    Age
    36
    Posts
    1,450

    Old: 00 WS6, 02 Z06, 79TA
    11 F350 CC 6.7L

    Quote Originally Posted by AssassinWs6 View Post
    sounds like you need to replace your flasher module. You said you replaced the bulb, correct? I recently had some turn signal issues such as this, and it turned out to be nothing more than the turn signal flasher. You can buy one at Pep-Boys or any auto-store. The flasher is usually located behind the lower part of the dashboard, underneath the steering column. You will probably have to remove that part of the dash to access it. It's about an inch and a half long plastic cyclinder. Just unplug the old one, and pop the new one in. That hopefully will fix the signal problem. Not sure about the headlight though. Sorry!
    Yeah the light in the dash and the actuall lights come on... just dont blink. I'll have to check out that module. Thanks!

  9. #9
    Member nate_the_great17's Avatar
    Join Date
    Aug 2007
    Location
    fortworth
    Posts
    224

    81 camaro
    2001 trans am ws6

    thanks im going to try that

  10. #10
    Heinz
    Join Date
    Jun 2007
    Location
    Houston
    Posts
    19

    Pewter
    2001 TA WS6

    i went through like 5 bulbs in 3 months in houston during the summer. It was raining all summer and what i found out was that the water gets in and burns out the bulb. The signal flasher and module and all that business might work but i just found it to be water. Make sure your connection is solid to the opening in your turn signal and if you want to try bulb grease it keeps out the moisture. Moisture basically is what I found it to be

  11. #11
    Junior Member
    Join Date
    Sep 2007
    Location
    Northern Kentucky
    Posts
    7

    Black
    1998 Pontiac Trans Am Ws6

    ketchup, that bulb grease sounds like a great idea. I had never heard of that before, but it would probably come in really handy. I also have had to replace a few bulbs because of water getting in and frying the bulb. unfortunatley it hasn't happened lately... it hasn't rained here in cincinnati in about 4 1/2 months!! let us know how the signal/lighting problems go though guys.

  12. #12
    Junior Member
    Join Date
    Sep 2007
    Location
    Richmond, TX
    Posts
    12

    Silver
    2000 Firebird

    Quote Originally Posted by Ketchup View Post
    i went through like 5 bulbs in 3 months in houston during the summer. It was raining all summer and what i found out was that the water gets in and burns out the bulb. The signal flasher and module and all that business might work but i just found it to be water. Make sure your connection is solid to the opening in your turn signal and if you want to try bulb grease it keeps out the moisture. Moisture basically is what I found it to be
    Hey Ketchup, I've had your same problem! I've gone through so many turn signal bulbs. I sorta live south of Sugarland and when it rains, moisture definitely gets in through my cracked Turn Signal Lens. That cold water hitting that hot bulb just makes it explode. I've found that you either need to replace the lens or just seal it up with 60 second epoxy (which is what I did and no more leaks!).

    Also, due to relevance to this post... Definitely check your flasher module. Once you replace it, it should start working.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Turn signal/hazard issue (left side out).
    By tyler durden in forum General Help
    Replies: 3
    Last Post: 09-20-2009, 01:29 PM
  2. Help: Electrical problem? Headlight/signal issue
    By onetroubledguy in forum Firebird / WS6
    Replies: 23
    Last Post: 01-20-2009, 08:53 PM
  3. turn signal/drl bulb issue
    By 1MileCrash in forum General Help
    Replies: 11
    Last Post: 11-06-2008, 06:44 PM
  4. Turn signal issue
    By Whiteboycntdnce in forum Camaro / SS
    Replies: 6
    Last Post: 03-20-2007, 07:45 PM
  5. turn signal
    By malibumaniac in forum Stereo and Electronics
    Replies: 4
    Last Post: 08-20-2005, 08:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •