Results 1 to 6 of 6

Gauge issues. Probably a dumb question, BUT....

This is a discussion on Gauge issues. Probably a dumb question, BUT.... within the Firebird / WS6 forums, part of the Vehicle Specific category; I used the search function, and cannot find an answer to my "problem". I have just finished putting a TH400 ...

  1. #1
    Junior Member
    Join Date
    Apr 2014
    Location
    Pittsburgh PA
    Posts
    3

    Black
    1998 WS-6

    Gauge issues. Probably a dumb question, BUT....

    I used the search function, and cannot find an answer to my "problem". I have just finished putting a TH400 in my 98 WS6. I am running the MSD 6ls, and I have gone to a carb (1050 cfm) to feed the 418cu in LS beast. Now, I have no working gauges.

    Question 1: Is there a plug and play kit for my set up, so I have use of my factory gauges again.

    Question 2: I see that auto meter makes a direct fit, gauge kit for Ford...

    summitracing.com/parts/atm-7010/overview/

    But does anyone make one for the WS6? Or are we forgotten about?

    Thanks for any help. It just sucks street driving, and praying I'm not speeding.

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Welcome to the site!

  3. #3
    Junior Member
    Join Date
    Apr 2014
    Location
    Pittsburgh PA
    Posts
    3

    Black
    1998 WS-6

    Thank you!!!

  4. #4
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    Good luck with that one Shawn. It sounds like you are creating a Frankencar and you will have to figure out the electrical. We have people here who can help but may need more information. Go Steelers.
    My ride is a 2002 Camaro SS SLP #3296 with 30k, LTH, 3" Y, CME, Frost tune, K&N, ported TB, Blackwing lid, Bellows, MSD, Denso Iridium, and 85mm MAF, Bilsteins, Eibach springs, SLP strut brace, Adj. Panhard, TA Girdle, UMI, Pro 5.0, Nitto NT555
    My wife has a 2004 GTO with the rare SAP, 18" wheels, K&N Cold Air System, MSD, Ported TB, Frost tune, Denso Iridium, Flowmaster cat-back, 3200 Yank, 75k

  5. #5
    Junior Member
    Join Date
    Apr 2014
    Location
    Pittsburgh PA
    Posts
    3

    Black
    1998 WS-6

    I agree.... And it pissed me off so bad, after 5 years.... I sold the car tonight. I have no regrets about it either. Too many headaches, too much cursing, and WAYYYYYY too many bloody knuckles. Back to playing with my street car. <frustrated!!!!>

  6. #6
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    Quote Originally Posted by Tastic View Post
    I agree.... And it pissed me off so bad, after 5 years.... I sold the car tonight. I have no regrets about it either. Too many headaches, too much cursing, and WAYYYYYY too many bloody knuckles. Back to playing with my street car. <frustrated!!!!>
    Problem solved. lol

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel Gauge Issues
    By 02 CamaroSS in forum General Help
    Replies: 4
    Last Post: 03-27-2011, 06:19 AM
  2. A Dumb Question
    By 88MonteSS98WS6 in forum Appearance Section
    Replies: 2
    Last Post: 07-03-2007, 05:21 PM
  3. Fuel Gauge Issues!
    By DSMKilla in forum Corvette
    Replies: 8
    Last Post: 03-08-2007, 07:46 AM
  4. Instrument gauge issues...Help!!
    By Dawgbone003 in forum Stereo and Electronics
    Replies: 2
    Last Post: 09-04-2006, 05:21 PM
  5. Air/Fuel Gauge Issues
    By jimbo98z in forum General Help
    Replies: 10
    Last Post: 03-10-2006, 01:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •