Results 1 to 7 of 7

Fuel Pump Problems

This is a discussion on Fuel Pump Problems within the Firebird / WS6 forums, part of the Vehicle Specific category; So, a few years ago I did a tune and some other mods on my car, including a Granatelli racing ...

  1. #1
    Member speedracer25f's Avatar
    Join Date
    Nov 2007
    Location
    Bethlehem, Pa
    Age
    43
    Posts
    202

    Midnight Blue
    1998 Trans Am

    Fuel Pump Problems

    So, a few years ago I did a tune and some other mods on my car, including a Granatelli racing pump. You could hear the pump from inside the car. The following spring, my car would start running bad, and we found out that the pump was heating up and causing the gas to get hot. I replaced it with another granatelli pump, this time is was quiet. It ran great. I only put 1500 miles on the car last summer. This year I pulled it out of the garage, drove it 100 miles, and the pump quit on my last night. Started sputtering for about a block and quit. The fuse and relay are good. Anyone else have problems with these pumps? Anything else I should do or look for to avoid problems?

  2. #2
    Member Baluchitherium's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Age
    46
    Posts
    319
    It has a big wing!

    No experience with the Granatelli but,my brother and I did install a Walbro pump in his 98' that has been going strong for almost 5yrs now??

    Only problem we had was access,so we cut an access panel...

  3. #3
    Junior Member camaro071's Avatar
    Join Date
    Sep 2008
    Location
    FL
    Age
    47
    Posts
    49

    blau-green
    2001 T/A

    I don't know about Granatelly but I use Edelbrock electric fuel pump (Red) on my 3rd gen camaro and never have any problem if I drive daily but when I park for couple months I got the same problem like you.After 4-5 mos setting in garage at first 100 miles driving start with problems,already replace 4 time.You need drive often and no more problems.

  4. #4
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Go with a Walbro or Racetronix, forget the Granatelli pump.

  5. #5
    Yo Da Lin The Valley..... astyles's Avatar
    Join Date
    Mar 2006
    Location
    here
    Posts
    3,693
    2001

    granatelli= walbro....i had the same prob. found out the had stopped making that pump because of bearing failure......i think the one i have now was the same as for the 5.0 mustang,but im not totally sure

  6. #6
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    I hav a Walbro in my 98 TA after the stock died. Been running great ever since and I beat my car
    1998 Trans Am 85k miles.
    Bolt ons, MS3 113LSA cam, Circle D Stall, Tune, Modified WS6 style hood, Full Suspension, 6000k HID's, Clear Side Markers w/ Leds, Led 3rd Brake Light and 18" AR Staggered Killer Wheels w/ BFG KDW NT's.- Weekend Toy/DD
    02 Trailblazer -Sold
    09 Ram 1500 CC - Sold
    09 Cobalt SS/TC - Sold
    13 ram 1500 LoneStar CC 4x4 - Magnaflow, K&N,and more to come-DD/Toy

  7. #7
    Member speedracer25f's Avatar
    Join Date
    Nov 2007
    Location
    Bethlehem, Pa
    Age
    43
    Posts
    202

    Midnight Blue
    1998 Trans Am

    Ok, so I had power at the tank. I pulled the pump, hotwired it to a battery and it worked. So Im not sure where my problem is. All the wiring seems fine. Think Im going to try to use a hotwire kit. Another question I have is my sending unit stopped working last year when I put the last pump in. Not sure how to test what the problem with that is. Any help? And where do I find sending unit parts once I figure out what I need?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel pump fuel guage issues on my '02 B4C
    By ANDYZ28 in forum Camaro / SS
    Replies: 7
    Last Post: 12-29-2014, 11:30 AM
  2. Pontiac Fuel Pumps - Do You Have The Right Fuel Pump?
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 03-15-2011, 10:20 PM
  3. LS1 all yr fuel injectors, oe fuel rail, pump,more
    By Frost in forum Parts For Sale / Trade
    Replies: 7
    Last Post: 04-27-2009, 03:26 PM
  4. fuel pump problems
    By jomomma in forum External Engine
    Replies: 0
    Last Post: 07-11-2008, 06:47 PM
  5. Replies: 3
    Last Post: 10-02-2006, 07:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •