Results 1 to 6 of 6

Ever Replaced the...

This is a discussion on Ever Replaced the... within the Firebird / WS6 forums, part of the Vehicle Specific category; Ever replace the coolant level sensor? Where is it at and anyone know the part # from gm? My brothers ...

  1. #1
    Impwnded Smkn_TA's Avatar
    Join Date
    May 2007
    Location
    Davenport, Iowa
    Age
    29
    Posts
    1,977

    Bright Red
    1999 Trans Am Ws6

    Ever Replaced the...

    Ever replace the coolant level sensor? Where is it at and anyone know the part # from gm? My brothers taurus the sensor for the windshield washer fluid went and the light stayed on nonstop, I assume it is similar sensor. because my level is correct and the line comes on and goes off with no pattern. I even added a little in case it was on the fence. If the sensor is hard to get to, I remove the light from the dash =) I know my level is right. Temp stays where it is supposed to. The radiator is filled to the top, and the overflow thing is right on the level it should be. SENSOR is definitly bad.

  2. #2
    Member Goldcuffs's Avatar
    Join Date
    Aug 2008
    Location
    Florida
    Posts
    411

    Silver
    2000 Trans Am

    Look below the cap about 8 inches on the engine side. Square 2 wire sensor. Very easy to change.

  3. #3
    Member Mike's TA's Avatar
    Join Date
    Nov 2006
    Location
    Austin, TX
    Age
    35
    Posts
    880

    Black
    99 Trans Am(sold)

    I need to replace mine also. I've taken it out and cleaned it and it's still messed up. I priced them and they run about $40 in my area. It's a fairly quick swap. IMO

  4. #4
    Member flipsutter's Avatar
    Join Date
    May 2008
    Location
    Arkansas
    Age
    37
    Posts
    141

    White
    1999 Firehawk

    I have replaced mine but the error light is still on. ;\

  5. #5
    Member Mike's TA's Avatar
    Join Date
    Nov 2006
    Location
    Austin, TX
    Age
    35
    Posts
    880

    Black
    99 Trans Am(sold)

    Well, that sucks. Now I'm wondering if something else is wrong.

    HELP!!

  6. #6
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    I havnt replaced mine, but I did knock it out when my battery came loose and smacked it out of the radiator. Some torque and a loose battery doesnt go well. It would be a very simple job. I put mine back in out on the road after I lost a few gallons of coolant.

    Yea, that was a good day.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need a Bulb Replaced?
    By BashamWS6 in forum Appearance Section
    Replies: 0
    Last Post: 12-25-2010, 11:53 AM
  2. Ls1 replaced with ls6.. Same height?
    By 5abivt in forum Internal Engine
    Replies: 4
    Last Post: 10-22-2010, 10:29 AM
  3. anyone had their cat(s) replaced under warranty
    By twozs in forum General Help
    Replies: 5
    Last Post: 04-17-2010, 06:35 PM
  4. PCV Valve Replaced, but..
    By RandomOmen in forum General Help
    Replies: 9
    Last Post: 06-03-2008, 06:08 PM
  5. The SS has been replaced......
    By pinky93 in forum Camaro / SS
    Replies: 40
    Last Post: 09-15-2006, 01:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •