Page 2 of 2 FirstFirst 12
Results 21 to 24 of 24

Electrical problem? Headlight/signal issue

This is a discussion on Electrical problem? Headlight/signal issue within the Firebird / WS6 forums, part of the Vehicle Specific category; Originally Posted by shady milkman this should be sticky It has been for a long time...

  1. #21
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Quote Originally Posted by shady milkman View Post
    this should be sticky
    It has been for a long time

  2. #22
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    Quote Originally Posted by Y2KPewterSS View Post
    It has been for a long time
    i b king of n00bsz

  3. #23
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Quote Originally Posted by shady milkman View Post
    i b king of n00bsz

  4. #24
    Member WS6chick's Avatar
    Join Date
    Jan 2009
    Location
    Merritt Island, FL
    Age
    35
    Posts
    151

    Black w/ red race stripes
    2001 Trans AM WS6

    I was having the same problem with mine for months (sockets were rusty as hell!!!) After replacing the sockets, the passenger side went out this weekend– grrrrrrrrr lol. Pulled it out and it was dripping wet… saw a few posts on drilling holes and was told to use dielectric grease as an insulator, but get mixed reviews – any suggestions?

    update: Nevermind, just found another thread on this lol~!
    Last edited by WS6chick; 01-20-2009 at 09:06 PM. Reason: found another thread

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. electrical issue i think
    By Ieatstangs in forum General Help
    Replies: 11
    Last Post: 03-22-2011, 06:57 PM
  2. Headlight issue....possibly electrical?
    By Twizz in forum Firebird / WS6
    Replies: 9
    Last Post: 05-12-2010, 11:46 AM
  3. headlight and right turn signal issue
    By nate_the_great17 in forum Firebird / WS6
    Replies: 11
    Last Post: 09-07-2007, 12:03 AM
  4. Electrical issue please help!
    By Stricken1 in forum General Help
    Replies: 1
    Last Post: 06-25-2007, 07:30 PM
  5. Headlight / electrical problem
    By h0rsepwr in forum Firebird / WS6
    Replies: 10
    Last Post: 05-15-2007, 11:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •