Results 1 to 16 of 16

Damn Security Light

This is a discussion on Damn Security Light within the Firebird / WS6 forums, part of the Vehicle Specific category; I am having problems with my car. I have a 2000 WS-6 and the security light on my dash turns ...

  1. #1
    Junior Member StarscreamsWS-6's Avatar
    Join Date
    Jun 2009
    Location
    SFV
    Posts
    4

    Blue
    2000 TA WS-6

    Unhappy Damn Security Light

    I am having problems with my car. I have a 2000 WS-6 and the security light on my dash turns on alot. Recently when I try to start my car when I turn the key the light comes on and my car won't start until the light turns off. I usally takes about 3-5 minutes before the light goes off, but this morning it did it repeatedly. I was waiting almost half an hour when I got it to turn on. Does anyone know what wrong with it? Thanks.

  2. #2
    Junior Member
    Join Date
    Feb 2008
    Location
    Milwaukee
    Posts
    75

    SOM
    2001 SOM WS6 408

    VATS. Just happened to mine. You will have to get resistors by finding out with an ohm meter what resistance your key is and plugging the resistors in the harness or take to dealer and get a new ignition cylinder. About $390 at dealer, but includes 2 new keys. Basically your wires are broken in the ignition cyl.
    2001 WS6 SOM 6 speed procharged forged 347
    2000 Camaro SS #1097, 425rwhp SOLD
    2001 Thundercat 1108

  3. #3
    Junior Member clow76's Avatar
    Join Date
    Jun 2008
    Location
    Troy, Missouri
    Posts
    32

    Black
    02 WS6 TA

    Mine did the same thing for about a month till it wouldnt start at all, its the VATS, i broke one of the two white wires coming from my igntion from tilting the streeing coloumn up and down repeatedly. Mine was under warranty would of costed about $400 from the dealer.

  4. #4
    Junior Member StarscreamsWS-6's Avatar
    Join Date
    Jun 2009
    Location
    SFV
    Posts
    4

    Blue
    2000 TA WS-6

    Thanks guys.

  5. #5
    lmpounded SandmanWs7's Avatar
    Join Date
    Jan 2006
    Location
    Dallas, Texas
    Posts
    8,028

    Silver
    2007 CTS-V

    Quote Originally Posted by StarscreamsWS-6 View Post
    Thanks guys.
    In case you dont have $300+ to fix it do the bypass.

    How to Bypass your VATS

  6. #6
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    I was able to repair my wiring. You have to take the airbag off, pull the wheel, look for the 2 wires coming off the locking cylinder, get a piece of wire crimp together, and then reassemble.

    It takes a bit of time, but a $3 fix saved me $300. Most breaks happen at the lock cylinder.

    I would try this first, if you screw up you are at least half way done to replacing the locking cylinder yourself.

  7. #7
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    I'm lazy, I'd just bypass VATS.

  8. #8
    Member flipsutter's Avatar
    Join Date
    May 2008
    Location
    Arkansas
    Age
    37
    Posts
    141

    White
    1999 Firehawk

    I got the same damn thing yesterday after leaving church.

    I started the car and it died. I looked up and the security light was on. I wait about 15 seconds and fired it up again. But this time the damn light stayed on and was on for the next 2 hours. I was stumped. Hopefully the damn thing won't die on me going down the road or somewhere were I can't fix it.

  9. #9
    Junior Member clow76's Avatar
    Join Date
    Jun 2008
    Location
    Troy, Missouri
    Posts
    32

    Black
    02 WS6 TA

    Quote Originally Posted by flipsutter View Post
    I got the same damn thing yesterday after leaving church.

    I started the car and it died. I looked up and the security light was on. I wait about 15 seconds and fired it up again. But this time the damn light stayed on and was on for the next 2 hours. I was stumped. Hopefully the damn thing won't die on me going down the road or somewhere were I can't fix it.
    The guys that fixed mine said that if it starts it will stay on but it wont start after you shut it off

  10. #10
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    I've seen posts where the car will start and run with the security light on steady, BCM goes into fault enable mode - saw a good reading from a previous cycle, recognizes the fault, and determines a malfunction - not someone trying to steal the car.

  11. #11
    lmpounded SandmanWs7's Avatar
    Join Date
    Jan 2006
    Location
    Dallas, Texas
    Posts
    8,028

    Silver
    2007 CTS-V

    Quote Originally Posted by clow76 View Post
    The guys that fixed mine said that if it starts it will stay on but it wont start after you shut it off


    When mine first started acting up I was at Ennis ( 45minutes from home) I had to push start it and it didnt die on the way home. Once I shut it off at home it wouldnt start again.

  12. #12
    Member phoenix05's Avatar
    Join Date
    Mar 2008
    Location
    SA,TX
    Age
    28
    Posts
    126

    artic white/black stripes
    97 TA

    funny my security light stays lit all the time and has been that way for awhile...just attributed it to the fact i can remove the key while the car is on xP

  13. #13
    Junior Member 00TransAm's Avatar
    Join Date
    Mar 2009
    Location
    Louisiana
    Posts
    18

    Dark Blue Metalic
    2000 WS6

    mine has been on for about 6 months now but my car starts fine, I have heard that if it comes on when the car is running it should still start but if it comes on before you start the car it will not start, don't know how true this is but mine has always started
    Kooks LT headers w/ Y pipe & SLP loud mouth
    Diablo programer
    SLP 90mm throttle body
    SLP mas air flow
    Eiback springs - SLPsub frame connectors
    SLP strut tower bracket
    BMR anti squat brackets
    BMR panhard rod
    3:73 gears
    ZR 1 rims-315back/275front

  14. #14
    Junior Member StarscreamsWS-6's Avatar
    Join Date
    Jun 2009
    Location
    SFV
    Posts
    4

    Blue
    2000 TA WS-6

    Just took mine in. Waiting on the call.

  15. #15
    Member
    Join Date
    Dec 2005
    Location
    NC
    Posts
    163

    primer
    1973 Camaro

    Mine had same problem. It would randomly not start, security light on, after several minutes it would start and work fine. A couple of times it started fine but the light stayed on for a couple days. It final got to the point that it failed to start on the first try every time. I did the VATS bypass a couple months ago. Starts everytime now with no security light.

  16. #16
    Junior Member StarscreamsWS-6's Avatar
    Join Date
    Jun 2009
    Location
    SFV
    Posts
    4

    Blue
    2000 TA WS-6

    It was the Body Control Module. Don't know what it is all I know is it cost me $632 to get it replaced and installed. Ouch!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Security light?
    By WICKEDLS1 in forum Computer & Tuning
    Replies: 6
    Last Post: 09-13-2011, 09:29 PM
  2. Security light
    By MSTZ TA in forum Computer & Tuning
    Replies: 23
    Last Post: 10-13-2010, 09:00 AM
  3. Question: security light
    By 95Firebirdred in forum LT1
    Replies: 11
    Last Post: 01-24-2009, 05:24 AM
  4. Security light
    By 02blackbirdws6 in forum Firebird / WS6
    Replies: 4
    Last Post: 07-25-2008, 12:20 AM
  5. damn security light
    By 98WSSick in forum General Help
    Replies: 8
    Last Post: 12-27-2006, 11:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •