Results 1 to 4 of 4

coolant problem

This is a discussion on coolant problem within the Firebird / WS6 forums, part of the Vehicle Specific category; on cold starts, i hear a strange noise, sounds like its comming from my water pump possibly. i checked my ...

  1. #1
    Member 6sw00's Avatar
    Join Date
    May 2006
    Location
    N.Y
    Age
    31
    Posts
    282

    black
    2000 trans am ws6

    coolant problem

    on cold starts, i hear a strange noise, sounds like its comming from my water pump possibly. i checked my cooland and was very low. i added some, then after driving it around, i checked it again and was low again.

  2. #2
    LoudMouth SStriker's Avatar
    Join Date
    Jul 2006
    Location
    Westminster/Sykesville, Maryland
    Age
    28
    Posts
    512

    Red
    2000 Trans Am

    are you leaking fluid? Burning it? If not when was the coolant changed last? Could have a bubble in the system..

  3. #3
    Member 6sw00's Avatar
    Join Date
    May 2006
    Location
    N.Y
    Age
    31
    Posts
    282

    black
    2000 trans am ws6

    i guess id need to get a flush huh.. but the noise sounds like the water pump. i herd that the engine lets go of coolant that it doesnt need. is this true?

  4. #4
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    No, its not true, what happens is that as the coolant warms it expands vreating pressure, after a set point the rad cap opens letting out excess pressure into the coolant bottle, as it cools is suckes it back in. you ahvea leack some where, If it was really low you may need to beeld the system and add coolant as your need.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. z28 coolant problem?
    By mammoth713 in forum General Help
    Replies: 25
    Last Post: 07-13-2010, 05:35 AM
  2. ls6 intake manifold coolant problem
    By MurderedOutTA in forum External Engine
    Replies: 5
    Last Post: 06-14-2010, 11:15 AM
  3. Coolant light problem
    By cobrahunter in forum External Engine
    Replies: 3
    Last Post: 08-06-2007, 12:51 AM
  4. Weird Coolant problem
    By deadboltmk in forum External Engine
    Replies: 3
    Last Post: 12-18-2006, 09:11 PM
  5. coolant problem!!!!
    By 98inportkillerta in forum General Help
    Replies: 22
    Last Post: 01-08-2006, 06:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •