Page 1 of 2 12 LastLast
Results 1 to 20 of 26

Car probem. HELP!!!

This is a discussion on Car probem. HELP!!! within the Firebird / WS6 forums, part of the Vehicle Specific category; I have a 99 Trans Am few mods reprogrammed. Its seems whenever im at steady throttle pressure either wide open ...

  1. #1
    Junior Member ToolLS1's Avatar
    Join Date
    Jul 2008
    Location
    Indianapolis,IN
    Posts
    23

    Silver
    99 Trans am

    Angry Car probem. HELP!!!

    I have a 99 Trans Am few mods reprogrammed. Its seems whenever im at steady throttle pressure either wide open or part throttle, it will bog down whenever it shifts into second or third it just depends. Do you think it could just be something as simple as my spark plugs or something more serious. I am open for all suggestions. I havent really looked into the problem in depth yet but thought I might get some suggestions before I start messing with stuff.

  2. #2
    U-R-Sofa-King-Retarded SINISTER-TA's Avatar
    Join Date
    Nov 2006
    Location
    SOCO
    Posts
    844

    NBM
    2002 Trans Am

    Is it an A4? If so is it stalled? Does it do it at WOT ot just part throttle? Sounds like it could be the torque management.

  3. #3
    Junior Member ToolLS1's Avatar
    Join Date
    Jul 2008
    Location
    Indianapolis,IN
    Posts
    23

    Silver
    99 Trans am

    What do you mean A4, Im pretty sure it does it at WOT, all my torque managment should be shut off

  4. #4
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    A4 means automatic transimission. M6 means manual transmission.
    CCW SP 500s 18x10 275/35 18x11 295/35
    SLP CME with GMMG style catback
    Painted manta stripe

    Quote Originally Posted by konigandy6 View Post
    I'd rather be bi than full homo!!!!

  5. #5
    U-R-Sofa-King-Retarded SINISTER-TA's Avatar
    Join Date
    Nov 2006
    Location
    SOCO
    Posts
    844

    NBM
    2002 Trans Am

    Automatic transmission. I know that some tuners will take out the torque managment that is programed into the PCM from the factory. Some wont and do not recomend it because of the added stress (shock) it can cause to the drivetrain.

  6. #6
    Junior Member ToolLS1's Avatar
    Join Date
    Jul 2008
    Location
    Indianapolis,IN
    Posts
    23

    Silver
    99 Trans am

    It is automatic. You think i shoud turn torque managment back on then.

  7. #7
    U-R-Sofa-King-Retarded SINISTER-TA's Avatar
    Join Date
    Nov 2006
    Location
    SOCO
    Posts
    844

    NBM
    2002 Trans Am

    Quote Originally Posted by ToolLS1 View Post
    It is automatic. You think i shoud turn torque managment back on then.
    It sounds like the torque management is working and doing what it's suppose to do. What mods do you have done to your car? That will give us a better idea about what may be happening. My car is stalled with alot of mods like heads, cam and has a tranny with a valve body kit etc. I noticed that I could feel the torque management kick it big time especially after I installed the Yank 3600 stall converter.

  8. #8
    Junior Member ToolLS1's Avatar
    Join Date
    Jul 2008
    Location
    Indianapolis,IN
    Posts
    23

    Silver
    99 Trans am

    Air Lid, MAF, Diablosport predator, Shift kit, Flowmaster Exhaust and thats pretty much at I can think of right now.

  9. #9
    U-R-Sofa-King-Retarded SINISTER-TA's Avatar
    Join Date
    Nov 2006
    Location
    SOCO
    Posts
    844

    NBM
    2002 Trans Am

    Well if it's the the tourque management (which is what it sounds like) it would only do it at part throttle. With the shift kit you have installed, the harder shifts might be making the tourque managemnt much more noiceable. If you want it gone it can be tuned out of the PCM with HP tuners, EFI live etc. I'm not sure if there are any hand held tuners that are capable of it. Might be...just not sure. I would make sure if it is in fact doing it at WOT and not just part throttle. My car does it all the time when I'm just cruising around at short part throttle "bursts". If it is doing it at WOT, there could be a problem with the tranny but it still sounds like your feeling the torque management kick in.

  10. #10
    U-R-Sofa-King-Retarded SINISTER-TA's Avatar
    Join Date
    Nov 2006
    Location
    SOCO
    Posts
    844

    NBM
    2002 Trans Am

    Also, I think you might be confusing the Torque management with the traction control system (TCS)(button on the inside of your car). They have two different functions. The torque managent is programmed into the PCM from the factory and it's purpose is to relieve added shock to the drive train when the transmission shifts into a higher gear. The TCS minimizes throttle input during low traction conditions like snow, rain mud etc.
    Last edited by SINISTER-TA; 09-20-2008 at 09:44 PM.

  11. #11
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    does anyone else think his car could be acting up because of the descreened maf?

  12. #12
    Awaiting Activation
    Join Date
    Sep 2007
    Location
    Colorado
    Posts
    1,188

    Black
    RIP S4 06Tbss

    Quote Originally Posted by c5z28 View Post
    does anyone else think his car could be acting up because of the descreened maf?
    Yes that sounds like that could be the problem...Try to get a hold of a stock maf if you can.

  13. #13
    Member
    Join Date
    Nov 2005
    Location
    allenhurst GA
    Age
    41
    Posts
    369

    onyx black
    1999 formula firebird

    is your car throwing codes? ses light?

  14. #14
    U-R-Sofa-King-Retarded SINISTER-TA's Avatar
    Join Date
    Nov 2006
    Location
    SOCO
    Posts
    844

    NBM
    2002 Trans Am

    Quote Originally Posted by c5z28 View Post
    does anyone else think his car could be acting up because of the descreened maf?
    Unless it was damaged during descreening I doubt it.

  15. #15
    Junior Member ToolLS1's Avatar
    Join Date
    Jul 2008
    Location
    Indianapolis,IN
    Posts
    23

    Silver
    99 Trans am

    No its not throwing any codes, but i did take the screen out of my MAF, you really think thats it could that possible make it bog down like that,

  16. #16
    Member 1998 T/A's Avatar
    Join Date
    Aug 2008
    Location
    Huron Ohio
    Posts
    759

    Black
    2000 WS6 Trans AM

    it could be a ton of things...my M6 would bog down after i shifted from 1-2...turns out it had low fuel pressure, it was throwing an o2 sensor code but the guy at the muffler shop said it was because of the low fuel pressure and it was getting inaccurate readings. could also be your MAF, maybe a crack in your intake, dirty fuel filter etc..

  17. #17
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    how many miles are on the car, if it's over 60,000 you don't have to switch out the filter but it doesnt's hurt, the maf can be acting up a bit especially if you don't have a tune (most tuners don't like tuning without the maf because descreening it makes it that much harder to figure out air/fuel throughout the curve), those little wires guesstemate how much air is coming through the whole intake with that screen in front of them, if you take it out there goes what was an accurate measurement, you could also try getting a maf cleaner and spray it. good luck.

  18. #18
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by ToolLS1 View Post
    No its not throwing any codes, but i did take the screen out of my MAF, you really think thats it could that possible make it bog down like that,
    nope my maf has been with out it's screen the day i bought my car... i've never had a problem with mine... sounds to me like a tq convert problem or that oyur bands might be slipping...

  19. #19
    Junior Member ToolLS1's Avatar
    Join Date
    Jul 2008
    Location
    Indianapolis,IN
    Posts
    23

    Silver
    99 Trans am

    I will probably try the cheapest thing first as fas as cleaning the MAF and buying a new fuel filter. If its something wrong with the transmission im really not worried, my buddy rebuilds them for a living. I had him test drive and he said it really doesnt act like the tranny. I just bought some new spark plugs and will probably change them out tomm.. I might also take my buddys MAF and swap it out and see what that does, he still has the screen in his. I will let you guys know what happens and see if some of these things fix the problem. I really appreciate everybodys input and keep it comin, it all helps.
    Thanks guys

  20. #20
    Junior Member ToolLS1's Avatar
    Join Date
    Jul 2008
    Location
    Indianapolis,IN
    Posts
    23

    Silver
    99 Trans am

    [QUOTE=1998 T/A;1647816]it could be a ton of things...my M6 would bog down after i shifted from 1-2...turns out it had low fuel pressure, it was throwing an o2 sensor code but the guy at the muffler shop said it was because of the low fuel pressure and it was getting inaccurate readings. could also be your MAF, maybe a crack in your intake, dirty fuel filter etc..[/Q

    Did you ever work out the problem on yours?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Think I have a probem.......gassing an IROC
    By ArcticZ06 in forum Almost Anything Goes
    Replies: 22
    Last Post: 10-29-2008, 07:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •