Results 1 to 13 of 13

Brake lights are not working.. Any ideas?

This is a discussion on Brake lights are not working.. Any ideas? within the Firebird / WS6 forums, part of the Vehicle Specific category; Ok usually i post on here with my problem after i try about everything that i know of. First thing ...

  1. #1
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    Brake lights are not working.. Any ideas?

    Ok usually i post on here with my problem after i try about everything that i know of. First thing i checked was the bulbs, they were good, i bought new ones anyways and they didnt work either.. So then i checked the fuse and it was fine, i even changed it and it still didnt work. So then i checked the brake light switches on the pedal, they both are fine. Heres the deal, My middle brake light (on the wing) works fine. My running lights work and my blinkers also work. Just the brake lights dont work. The bulbs are a double light bulb and the functions they do are the brake light and the running light for night time. It doesnt make any sense, the running lights work but the brake lights dont. So its getting power...... im stuck here

  2. #2
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Are you getting voltage to the plugs for the bulbs? I'm going to guess you have a problem with the wiring somewhere. The wiring is pretty accessable in the hatch, so I'd go through that first.

  3. #3
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    I put a test meter on it (just a cheap one that lights up) but it doesnt light up at all... BUT, my running lights work. Its all in the same socket and the same bulb. It doesnt make any sense

  4. #4
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    You'll need to isolate the positive wire for the brakes coming from the switch. Should be on the drivers side.

  5. #5
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    I figured out the problem
    No Brake Lights ???

  6. #6
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    I figured that was the problem. Unfortunately, it's not the easiest to fix. Good luck.

  7. #7
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    it shouldnt be too hard, i just recently had to take apart my steering column

  8. #8
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Previous experience does help, lol.

  9. #9
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    lol oh yes. It was a little bit of a pain but i know exactly whut it is so i can narrow down the problem

  10. #10
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    i took it apart all in about 30 minutes and put the new one in and it works! wow i cant believe something like that controls the brake lights....

  11. #11
    Senior Member justinmc978's Avatar
    Join Date
    May 2009
    Location
    college station, tx
    Posts
    2,564

    sold: 1999 firebird
    1998 Trans Am

    Quote Originally Posted by Lunatikgixxer View Post
    i took it apart all in about 30 minutes and put the new one in and it works! wow i cant believe something like that controls the brake lights....
    glad you got it fixed, I wonder if a broken switch could affect just one side.. sometimes my left brake lights decide not to work,

  12. #12
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    who knows? possibly, i think its just an electrical problem

  13. #13
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    yes this is a classic turn signal problem, no outside brake lights but the center one works.

    And yes, you could also have the problem show up as one side not working, but not usually.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lights not working. :(
    By SouthBLVD in forum General Help
    Replies: 5
    Last Post: 12-26-2008, 03:13 PM
  2. Fog Lights are not working
    By bevenue in forum General Help
    Replies: 0
    Last Post: 06-23-2007, 01:47 PM
  3. Dash lights and others not working
    By Red Chevy in forum Stereo and Electronics
    Replies: 3
    Last Post: 10-19-2006, 12:08 AM
  4. wipers not working when lights are on........
    By astyles in forum Stereo and Electronics
    Replies: 1
    Last Post: 06-10-2006, 03:26 PM
  5. Fog Lights Quite Working
    By Z28LOVER in forum Stereo and Electronics
    Replies: 7
    Last Post: 09-18-2005, 07:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •