Results 1 to 16 of 16

Blinker Problems!!! NEED HELP

This is a discussion on Blinker Problems!!! NEED HELP within the Firebird / WS6 forums, part of the Vehicle Specific category; I have a 96 Trans am LT1, and my blinkers wont work. The fuse was burnt so i replaced it ...

  1. #1
    Import Killer camarostripes96's Avatar
    Join Date
    Aug 2006
    Location
    academy,tx
    Age
    33
    Posts
    574

    Black
    1996 Trans am

    Question Blinker Problems!!! NEED HELP

    I have a 96 Trans am LT1, and my blinkers wont work. The fuse was burnt so i replaced it with a new one and whenever i use my blinker it blows another fuse, i did this about 2 times and kept blowing the fuse whenever i put my blinker on. Has anyone ever has this problem or know what it could be.
    Thanks for the help
    Dustin

  2. #2
    I see Yello and I like it 02cetransam's Avatar
    Join Date
    Mar 2007
    Location
    Ontario, Canada
    Posts
    2,066

    yellow
    02 Collector Trans Am

    sounds like you got yourself a short. Look for bare wires.

  3. #3
    Import Killer camarostripes96's Avatar
    Join Date
    Aug 2006
    Location
    academy,tx
    Age
    33
    Posts
    574

    Black
    1996 Trans am

    i was hoping to avoid that , i dont even know where to start at. any other ideas what it can be anyone

  4. #4
    I see Yello and I like it 02cetransam's Avatar
    Join Date
    Mar 2007
    Location
    Ontario, Canada
    Posts
    2,066

    yellow
    02 Collector Trans Am

    was the car ever in a major accident?

  5. #5
    Import Killer camarostripes96's Avatar
    Join Date
    Aug 2006
    Location
    academy,tx
    Age
    33
    Posts
    574

    Black
    1996 Trans am

    nope never been wrecked, i have had the car for about a year and it just started doing this about 2 weeks ago

  6. #6
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    According to www.kalecoauto.com you need blinker fluid. They say you can tell when you need it when your blinker makes a clicking noise everytime it "blinks" and you should change it regularly every 10,000 blinks, also you loose hp. They sell it at 8.99 a bottle



    I hope that can be at some help hehe

  7. #7
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    Sounds like a turn signal switch, in the steering column. Have you tried with your tilt wheel in different positions? Wires can stretch and break/short.

  8. #8
    Member Mike's TA's Avatar
    Join Date
    Nov 2006
    Location
    Austin, TX
    Age
    35
    Posts
    880

    Black
    99 Trans Am(sold)

    Did you check to make sure there isn't any water in the housings or that the sockets where you plug the bulbs into aren't corroded?

  9. #9
    Junior Member blackTA6585's Avatar
    Join Date
    Aug 2005
    Location
    Florida
    Age
    32
    Posts
    83

    Black
    1999 Trans Am

    Quote Originally Posted by Mike's TA View Post
    Did you check to make sure there isn't any water in the housings or that the sockets where you plug the bulbs into aren't corroded?
    Yeah I had that exact problem and i finally went to check the bulbs and had a bunch of water in the housing. And after I got the water out it was fixed.

  10. #10
    Member Mike's TA's Avatar
    Join Date
    Nov 2006
    Location
    Austin, TX
    Age
    35
    Posts
    880

    Black
    99 Trans Am(sold)

    Check the lens on the housings to make sure you don't have any micro cracks. That's how water gets in there. You can either try resealing the lens or go buy new housings. I opted for new housings cause my drivers side on just craked to shit one day and looked horrible. Of course I then had to get another passenger side one since the drivers side looked so good. All in all, I spent $160 fixing my blinkers. Two housings and One socket. The socket was horribly corroded and beyond repair.

  11. #11
    Babies: 2 Girls, 5 FBods FBODYREDDEVIL's Avatar
    Join Date
    Mar 2007
    Location
    Rainy, WA
    Age
    41
    Posts
    55

    of my F-Bodies
    Too tough to pick just 1

    If it blows with either indicator on then it's not a single socket or bulb. Does it pop when the park lights are on? No: That would also tell you it's not a socket. So then you've got to figure out the common denominator. I say it's an issue in the column, also possible relay.

  12. #12
    Import Killer camarostripes96's Avatar
    Join Date
    Aug 2006
    Location
    academy,tx
    Age
    33
    Posts
    574

    Black
    1996 Trans am

    ok i havnt tried my steering wheel is all the way in the down position, and whenever i put a fuse in it , i just put the blinker on one time and barely has enough time to blink once and it blows the fuse

  13. #13
    Member
    Join Date
    Aug 2005
    Location
    tx
    Age
    37
    Posts
    108

    pewter
    99 trans am ws6

    i know this is an old thread but did you finally fix this issue. my car is doing the exact same thing andwas trying to narrow down the issue

  14. #14
    🤔 11s. blackbirdbrain89's Avatar
    Join Date
    Sep 2007
    Location
    hagerstown, mercersburg
    Age
    28
    Posts
    1,844

    black trans am
    2000

    if all that stuff does not work try buting a new flashet realy in. what could be haping is the contacks are drwing to much amp and poping the fuse. i just replaced mine b/c it stoped working it would just stop blinking for right truns and poped a fuse after a few mins that my .02

  15. #15
    Member
    Join Date
    Aug 2005
    Location
    tx
    Age
    37
    Posts
    108

    pewter
    99 trans am ws6

    i did that already and its still happening. the next thing that i am going to do is change the turn signal switch.

  16. #16
    Si Vis Pacem, Para Bellum 2002_LS1's Avatar
    Join Date
    Feb 2008
    Location
    Mountain Home, Id
    Age
    31
    Posts
    17

    Pewter Metallic
    2002 Firebird Trans Am

    Yeah, my left turn signal isn't blinking just stays lit on the dash when i use it. I did switch my column during a long ass drive from florida to arizona...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Blinker problems
    By MasonWS6 in forum General Help
    Replies: 7
    Last Post: 08-12-2014, 03:23 AM
  2. Blinker problems
    By Firebird98 in forum Firebird / WS6
    Replies: 5
    Last Post: 04-11-2009, 07:51 PM
  3. Blinker/Park Lamp Problems
    By Ryanater in forum General Help
    Replies: 13
    Last Post: 02-14-2008, 11:24 PM
  4. Blinker Problems pissing me off!!
    By camarostripes96 in forum Stereo and Electronics
    Replies: 12
    Last Post: 09-23-2007, 12:01 PM
  5. Blinker problems....
    By T/AKing in forum General Help
    Replies: 11
    Last Post: 10-24-2006, 11:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •