Results 1 to 19 of 19

blinker problem...

This is a discussion on blinker problem... within the Firebird / WS6 forums, part of the Vehicle Specific category; if i push the blinker lever down(to signal a left turn) the arrow comes on and stays on on the ...

  1. #1
    Senior Member justinmc978's Avatar
    Join Date
    May 2009
    Location
    college station, tx
    Posts
    2,564

    sold: 1999 firebird
    1998 Trans Am

    blinker problem...

    if i push the blinker lever down(to signal a left turn) the arrow comes on and stays on on the dash, no blinking, the left tailight also comes on but with no blinking,

    the right signal works fine

    what do i do?, this is brand new problem, just started doing it tonight
    Last edited by justinmc978; 11-16-2009 at 07:37 PM.

  2. #2
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Have you checked to see if the bulb is burned out? Typically when the bulb is out, thats what it does, the arrow comes on, but doesn't blink.

  3. #3
    Senior Member justinmc978's Avatar
    Join Date
    May 2009
    Location
    college station, tx
    Posts
    2,564

    sold: 1999 firebird
    1998 Trans Am

    Quote Originally Posted by Y2KPewterSS View Post
    Have you checked to see if the bulb is burned out? Typically when the bulb is out, thats what it does, the arrow comes on, but doesn't blink.
    i know the drl and both rear tail bulbs that blink are good, ill check the lights on the side h/o..

  4. #4
    Senior Member justinmc978's Avatar
    Join Date
    May 2009
    Location
    college station, tx
    Posts
    2,564

    sold: 1999 firebird
    1998 Trans Am

    lights all around the car are in check, its the wierdest thing..

    flasher maybe? a fuse? i dont know electronics..

  5. #5
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    check your blinker fluid

  6. #6
    Senior Member justinmc978's Avatar
    Join Date
    May 2009
    Location
    college station, tx
    Posts
    2,564

    sold: 1999 firebird
    1998 Trans Am

    Quote Originally Posted by tatertot91 View Post
    check your blinker fluid
    stfu


    i pulled out one of the two hayes manuals i have, says if one side works but another side doesnt you have a bad bulb, but, all my bulbs work, when i flip the blinker switch the front drl bulbs 'second' high powered light(forgive my lack of vocabulary) doesnt come on, so i'm hopeing that the secondary one has blown but the one that normally runs at all times hasn't,

    thats what will help me sleep tonight until i can figure it out tomorrow,

  7. #7
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    you could turn your hazzard lights on and walk around to see if any dont work

  8. #8
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    I had the same problem on my older Camaro and it was a bad bulb....

    WHen you check your bulbs, blinker bulbs have two separate filaments. You probably know that already though. But make sure you look at both.

    I would also think that if your flasher module was bad, probably both blinkers would stay on.

    Lastly, could it be an actual switch problem? In the actual lever arm? If that is bad, that is a little more involved.

  9. #9
    Senior Member justinmc978's Avatar
    Join Date
    May 2009
    Location
    college station, tx
    Posts
    2,564

    sold: 1999 firebird
    1998 Trans Am

    high beam filament is dead on left drl i have a couple of thse bulbs laying around here somewhere...

    thanks ya'll for everything!

    i was begining to plan to have to go in and change all my steering column stuff and and all that bs, what a relief.

  10. #10
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Quote Originally Posted by justinmc978 View Post
    high beam filament is dead on left drl i have a couple of thse bulbs laying around here somewhere...

    thanks ya'll for everything!

    i was begining to plan to have to go in and change all my steering column stuff and and all that bs, what a relief.
    my buddy called me up one time and had the same problem
    he was like "my blinker doesn't blink, its just solid"
    i asked if the bulb was burnt
    he said, "no, i had my friend stand in the back of the car and the light worked, it just didn't blink"
    me again, "did you check the front?"
    His reply, "ohh, i guess there's some in the front too"

  11. #11
    Senior Member justinmc978's Avatar
    Join Date
    May 2009
    Location
    college station, tx
    Posts
    2,564

    sold: 1999 firebird
    1998 Trans Am

    Quote Originally Posted by tatertot91 View Post
    my buddy called me up one time and had the same problem
    he was like "my blinker doesn't blink, its just solid"
    i asked if the bulb was burnt
    he said, "no, i had my friend stand in the back of the car and the light worked, it just didn't blink"
    me again, "did you check the front?"
    His reply, "ohh, i guess there's some in the front too"
    it fooled me cause of the dual filament, works when i put the ebrake down or push unlock on the key fob, but wont work with the hazards so

  12. #12
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Quote Originally Posted by justinmc978 View Post
    it fooled me cause of the dual filament, works when i put the ebrake down or push unlock on the key fob, but wont work with the hazards so
    at least its fixed

  13. #13
    Member
    Join Date
    Oct 2006
    Location
    Florida
    Age
    42
    Posts
    262

    Navy Blue Metallic
    2002 Trans Am WS6

    Quote Originally Posted by tatertot91 View Post
    check your blinker fluid
    Damn you! Ya beat me to it!

  14. #14
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Quote Originally Posted by NvyBluMtlc02WS6 View Post
    Damn you! Ya beat me to it!

  15. #15
    Team Skeet Captain JHayesLS1's Avatar
    Join Date
    Dec 2006
    Location
    Winter Garden, FL
    Age
    30
    Posts
    2,061

    Black
    1999 Camaro Z28

    Check the fuse. Mine was a bad relay.

  16. #16
    The Silver Bullet LS1_ws6's Avatar
    Join Date
    Apr 2009
    Location
    Brush Colorado
    Posts
    323

    Silver
    1999 Trans Am

    yeah mine was that too.

  17. #17
    Junior Member 00ls1TAWs6's Avatar
    Join Date
    Feb 2008
    Location
    Luverne, MN
    Posts
    28

    Black
    2000 Trans Am WS6

    I have a different problem with my blinkers. When i turn them on either left or right neither of them do anything, i tried the flashers and all of them still blink then. I also tried changing the fuse and it didnt change anything. any help would be appreciated.

  18. #18
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Quote Originally Posted by 00ls1TAWs6 View Post
    I have a different problem with my blinkers. When i turn them on either left or right neither of them do anything, i tried the flashers and all of them still blink then. I also tried changing the fuse and it didnt change anything. any help would be appreciated.
    I don't know if it's the same, but on my 1996 V6 this happened and the blinker module under the dash was bad. It looked something like this:

    Like I said though, not sure if this is the same on the 4th gens.

  19. #19
    Junior Member 00ls1TAWs6's Avatar
    Join Date
    Feb 2008
    Location
    Luverne, MN
    Posts
    28

    Black
    2000 Trans Am WS6

    alright ill have to check that out, thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Blinker problem
    By Spikito in forum General Help
    Replies: 15
    Last Post: 06-08-2011, 03:25 PM
  2. Blinker Problem
    By BlackTAWS6 in forum Firebird / WS6
    Replies: 24
    Last Post: 05-12-2010, 09:57 PM
  3. blinker problem
    By ultra_badass in forum General Help
    Replies: 8
    Last Post: 12-22-2008, 12:00 PM
  4. Blinker problem
    By camarostripes96 in forum LT1
    Replies: 2
    Last Post: 09-19-2007, 06:57 PM
  5. blinker problem
    By 98silveraptorhoodws7 in forum General Help
    Replies: 2
    Last Post: 01-06-2007, 05:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •