Results 1 to 15 of 15

Am I missing something?

This is a discussion on Am I missing something? within the Firebird / WS6 forums, part of the Vehicle Specific category; ...

  1. #1
    Member onetroubledguy's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, TX
    Age
    31
    Posts
    401

    Navy Blue Metallic
    1999 Trans Am WS6

    Am I missing something?




  2. #2
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    A real rearend, exhaust, a cleaning job, and an upgraded suspension
    CCW SP 500s 18x10 275/35 18x11 295/35
    SLP CME with GMMG style catback
    Painted manta stripe

    Quote Originally Posted by konigandy6 View Post
    I'd rather be bi than full homo!!!!

  3. #3
    Member onetroubledguy's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, TX
    Age
    31
    Posts
    401

    Navy Blue Metallic
    1999 Trans Am WS6

    Quote Originally Posted by Y2KPewterSS View Post
    A real rearend, exhaust, a cleaning job, and an upgraded suspension
    x2 on the suspension & cleaning

  4. #4
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Quote Originally Posted by onetroubledguy View Post
    x2 on the suspension & cleaning
    Just giving ya a hard time

  5. #5
    Member onetroubledguy's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, TX
    Age
    31
    Posts
    401

    Navy Blue Metallic
    1999 Trans Am WS6

    Quote Originally Posted by Y2KPewterSS View Post
    Just giving ya a hard time
    No I really do need new shocks. They are pretty bad lol.

  6. #6
    Member fieropope's Avatar
    Join Date
    Jan 2009
    Location
    union mo
    Posts
    183

    white
    01 formula

    umm i think you misplaced your EXHUAST sir probly sounds badass though

  7. #7
    Member NavdeepWS6's Avatar
    Join Date
    Oct 2008
    Location
    Sacramento
    Posts
    221

    Black
    2002 Trans Am

    did you have a stock exhaust before and how easy was it to take off no cutting or was there i want to keep mine intact

  8. #8
    Member onetroubledguy's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, TX
    Age
    31
    Posts
    401

    Navy Blue Metallic
    1999 Trans Am WS6

    Quote Originally Posted by NavdeepWS6 View Post
    did you have a stock exhaust before and how easy was it to take off no cutting or was there i want to keep mine intact
    Mine was stock except for a cutout on the mid-pipe. It was easy to remove. I did have to cut the over-axle pipe but nothing else.

  9. #9
    Member Mike's TA's Avatar
    Join Date
    Nov 2006
    Location
    Austin, TX
    Age
    35
    Posts
    880

    Black
    99 Trans Am(sold)

    And what are you putting in it's place? If anything?

  10. #10
    Member onetroubledguy's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, TX
    Age
    31
    Posts
    401

    Navy Blue Metallic
    1999 Trans Am WS6

    Quote Originally Posted by Mike's TA View Post
    And what are you putting in it's place? If anything?
    It has a magnaflow catback now.

  11. #11
    Junior Member
    Join Date
    Oct 2008
    Location
    Ponchatoula La.
    Posts
    20

    Black
    1999 Trans am

    How about an exhaust !!!!!!!!!

  12. #12
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    did you know that your rear wheels arent touching? maybe that why you are having acceleration issues

  13. #13
    🤔 11s. blackbirdbrain89's Avatar
    Join Date
    Sep 2007
    Location
    hagerstown, mercersburg
    Age
    28
    Posts
    1,844

    black trans am
    2000


  14. #14
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    pretty

  15. #15
    War Machine BIG GUNS's Avatar
    Join Date
    May 2007
    Location
    St. Louis MO.
    Age
    53
    Posts
    2,100

    Black
    00 Trans Am/Auto

    Quote Originally Posted by fieropope View Post
    umm i think you misplaced your EXHUAST sir probly sounds badass though
    OMG, didn't notice that til you said it. Holy shit.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need help??? ls1 missing
    By ozmossis in forum LT1
    Replies: 1
    Last Post: 11-08-2010, 08:58 PM
  2. Missing Cat
    By SteveCZ28 in forum Almost Anything Goes
    Replies: 7
    Last Post: 09-02-2010, 03:18 AM
  3. Missing ?
    By 97txaggie in forum General Help
    Replies: 10
    Last Post: 06-18-2010, 06:36 PM
  4. Missing Something?????
    By predator506 in forum Camaro / SS
    Replies: 18
    Last Post: 11-07-2007, 03:10 PM
  5. What am I missing?
    By slims00ls1z28 in forum Request and Feedback
    Replies: 1
    Last Post: 07-01-2007, 12:04 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •