Results 1 to 19 of 19

2000 Trans am lights flicker!

This is a discussion on 2000 Trans am lights flicker! within the Firebird / WS6 forums, part of the Vehicle Specific category; Has anyone resolved the problem with their trans am headlights flickering? If so how did you get it done?...

  1. #1
    Junior Member juvie909's Avatar
    Join Date
    Apr 2009
    Location
    ca
    Posts
    7

    Candy Tangerine
    2000 WS6

    2000 Trans am lights flicker!

    Has anyone resolved the problem with their trans am headlights flickering? If so how did you get it done?

  2. #2
    Military Muscle :usa: MYSCZ06's Avatar
    Join Date
    Aug 2005
    Location
    Columbia,SC
    Age
    44
    Posts
    511

    Millienum Yellow
    2003 Corvette Z06

    going ot ask the obvious but have you checked the connection to the back of the light? Might have come loose??

  3. #3
    Sold: LS1 '85 El Camino ls1camino's Avatar
    Join Date
    Dec 2005
    Location
    Laurel, Maryland
    Posts
    4,977

    2000 Grand Prix GTP
    2000 Trans Am WS6 M6

    Is it all of your lights or just the headlights?...it could be your alternator going bad.

  4. #4
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Alternator/Air Pump cycling.

    Here is an example of my air pump cycling before i deleted all my emissions... its near the end I think...


  5. #5
    Junior Member
    Join Date
    May 2008
    Location
    Dallas
    Posts
    26

    Black
    99 trans am

    i have the same problems with my headlights and taillights

  6. #6
    Member TOMASINO's Avatar
    Join Date
    Mar 2008
    Location
    downers grove
    Posts
    206

    white
    2000

    Quote Originally Posted by RLamas View Post
    i have the same problems with my headlights and taillights
    alternator GM made the mistake of puttin the alternator under (not on top) when u catch a bad storm alt is easy to get wet everytime, sooner get dry but messes with the regulator the only way 2 fix this is buyin the whole alternator or maybe a rubber cover will help protect the alternator from watet...but then again it may get too hot and faulty

  7. #7
    LINGER LONGERRR DUBB's Avatar
    Join Date
    Jun 2008
    Location
    BC,CANADA
    Posts
    696

    NBM
    02 M6 Formula

    funny you say that, my pass side headlight flickers. I only notice it at night time on signs and in peoples back windows and stuff. I tried to see if i could tighten something up but the joint on the bracket (rivet) that pivots the light up and down is loose. Probably more annoying to people that im driving behind at night. probably unrelated but thats my issue.

  8. #8
    Member TOMASINO's Avatar
    Join Date
    Mar 2008
    Location
    downers grove
    Posts
    206

    white
    2000

    Quote Originally Posted by DUBB View Post
    funny you say that, my pass side headlight flickers. I only notice it at night time on signs and in peoples back windows and stuff. I tried to see if i could tighten something up but the joint on the bracket (rivet) that pivots the light up and down is loose. Probably more annoying to people that im driving behind at night. probably unrelated but thats my issue.
    u can get that arm bracket and any dealer i got mine for 20 bucks!! so ur light wont vibrate at nite///

  9. #9
    Member Numba1TA's Avatar
    Join Date
    Feb 2008
    Location
    Missouri, STL
    Age
    30
    Posts
    142

    Pewter
    1999 Trans Am WS6 A4

    I got the same problem I think I might try to buy the alternator relocation kit that gets rid of the tensioner

  10. #10
    LINGER LONGERRR DUBB's Avatar
    Join Date
    Jun 2008
    Location
    BC,CANADA
    Posts
    696

    NBM
    02 M6 Formula

    Quote Originally Posted by TOMASINO View Post
    u can get that arm bracket and any dealer i got mine for 20 bucks!! so ur light wont vibrate at nite///
    o rly? i might go do that tommorow, thx, Any idea what its called? headlight arm bracket?

  11. #11
    Junior Member juvie909's Avatar
    Join Date
    Apr 2009
    Location
    ca
    Posts
    7

    Candy Tangerine
    2000 WS6

    headlights and dashboard and taillights.

    My headlights and dashboard and taillights all do the same thing. Also my voltage meter on my dashboard flickers from 12 volts to 8 or 10. Any ideas? how much is a new alt?
    Last edited by juvie909; 05-01-2009 at 11:29 PM. Reason: forgot to post something

  12. #12
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Quote Originally Posted by juvie909 View Post
    My headlights and dashboard and taillights all do the same thing. Also my voltage meter on my dashboard flickers from 12 volts to 8 or 10. Any ideas? how much is a new alt?
    169.00 brand new AC delco remy with limited lifetime warranty


  13. #13
    Junior Member juvie909's Avatar
    Join Date
    Apr 2009
    Location
    ca
    Posts
    7

    Candy Tangerine
    2000 WS6

    thanks joshiedoom

  14. #14
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Quote Originally Posted by juvie909 View Post
    thanks joshiedoom
    YW. thats from advanced auto BTW!

  15. #15
    Junior Member
    Join Date
    Nov 2008
    Location
    Warner Robins, ga
    Posts
    9

    red
    2002 Trans Am

    Quote Originally Posted by juvie909 View Post
    My headlights and dashboard and taillights all do the same thing. Also my voltage meter on my dashboard flickers from 12 volts to 8 or 10. Any ideas? how much is a new alt?
    It is possible that your electrical system could have an intermittent high draw condition, loose connection or a bad battery. When I worked at AZ we would see this problem occasionally...sometimes the side terminals on the battery would be bad...sometimes the the plates in the battery would short and you could have an issue with the distribution panel on the driver's side of the car or bad connection at the alternator. Check your connection at the alternator thoroughly...look for brittle or discolored wiring. If it is bad solder in your new pigtail assy DO NOT CRIMP CONNECT.

    Hope it works out!

  16. #16
    Member TOMASINO's Avatar
    Join Date
    Mar 2008
    Location
    downers grove
    Posts
    206

    white
    2000

    Quote Originally Posted by calgator73 View Post
    It is possible that your electrical system could have an intermittent high draw condition, loose connection or a bad battery. When I worked at AZ we would see this problem occasionally...sometimes the side terminals on the battery would be bad...sometimes the the plates in the battery would short and you could have an issue with the distribution panel on the driver's side of the car or bad connection at the alternator. Check your connection at the alternator thoroughly...look for brittle or discolored wiring. If it is bad solder in your new pigtail assy DO NOT CRIMP CONNECT.

    Hope it works out!

    did that change the batt also... still the same problem i replace the alt end of problem but after a couple thunderstorms about a year car start doin it again so i say forget it i just gonna let it die lol

  17. #17
    Junior Member juvie909's Avatar
    Join Date
    Apr 2009
    Location
    ca
    Posts
    7

    Candy Tangerine
    2000 WS6

    i replaced the batt with an optima batt so i narrowed that out. but i still havent replaced the alt. Also has anyone had a problem with their horn. mine never goes off?

  18. #18
    Member TOMASINO's Avatar
    Join Date
    Mar 2008
    Location
    downers grove
    Posts
    206

    white
    2000

    Quote Originally Posted by juvie909 View Post
    i replaced the batt with an optima batt so i narrowed that out. but i still havent replaced the alt. Also has anyone had a problem with their horn. mine never goes off?
    i replace mines too guess whats the problem??? WATER again... i found them at napa auto parts for like 35 dlls. original replacement even with the conectors.

  19. #19
    Junior Member
    Join Date
    Nov 2008
    Location
    Warner Robins, ga
    Posts
    9

    red
    2002 Trans Am

    Quote Originally Posted by juvie909 View Post
    i replaced the batt with an optima batt so i narrowed that out. but i still havent replaced the alt. Also has anyone had a problem with their horn. mine never goes off?
    What do you mean by "mine never goes off"? When you push the pad? Set the alarm? I had a problem with my low note horn filling up with water every time it rained. The high note horn was on the bottom and pointed down while the low note was pointed up. I replaced the horn and swiveled it on the bracket as far as the harness would let me to point it down too....problem solved.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: 2000 WS-6 HID Lights
    By Taurian00 in forum Firebird / WS6
    Replies: 13
    Last Post: 03-12-2010, 04:40 AM
  2. All Lights Flicker
    By vgm in forum Stereo and Electronics
    Replies: 16
    Last Post: 12-23-2008, 03:05 AM
  3. why do my headlights flicker?
    By ws62002 in forum Firebird / WS6
    Replies: 19
    Last Post: 01-21-2007, 09:36 AM
  4. abs/ tcs lights always on 2000 GTP
    By ksenzee in forum Computer & Tuning
    Replies: 4
    Last Post: 09-20-2006, 05:57 PM
  5. My headlights and dash lights flicker????
    By DW2000TA in forum General Help
    Replies: 4
    Last Post: 01-05-2006, 10:27 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •